aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/flameshot/Makefile29
-rw-r--r--deskutils/flameshot/distinfo3
-rw-r--r--deskutils/flameshot/files/patch-flameshot.pro35
-rw-r--r--deskutils/flameshot/pkg-descr11
-rw-r--r--deskutils/flameshot/pkg-plist10
6 files changed, 89 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index ed1335fc3377..e1e7c204f54a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -43,6 +43,7 @@
SUBDIR += everygui
SUBDIR += fbreader
SUBDIR += fet
+ SUBDIR += flameshot
SUBDIR += freemind
SUBDIR += fusenshi
SUBDIR += gaddr
diff --git a/deskutils/flameshot/Makefile b/deskutils/flameshot/Makefile
new file mode 100644
index 000000000000..1021174a512c
--- /dev/null
+++ b/deskutils/flameshot/Makefile
@@ -0,0 +1,29 @@
+# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flameshot
+PORTVERSION= 0.5.0
+DISTVERSIONPREFIX= v
+CATEGORIES= deskutils
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Powerful yet simple to use screenshot software
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+GH_ACCOUNT= lupoDharkael
+
+INSTALL_ICONS= yes
+
+USES= qmake
+USE_GCC= yes
+USE_GITHUB= yes
+USE_GL= gl
+USE_QT5= core dbus gui linguist network widgets
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
+ ${WRKSRC}/${PORTNAME}.pro
+
+.include <bsd.port.mk>
diff --git a/deskutils/flameshot/distinfo b/deskutils/flameshot/distinfo
new file mode 100644
index 000000000000..d00ca33b7f60
--- /dev/null
+++ b/deskutils/flameshot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516551815
+SHA256 (lupoDharkael-flameshot-v0.5.0_GH0.tar.gz) = 32d593c14c37286d9f64873c4ef9a07eb084723c92b2280d5c22152547c1e3f0
+SIZE (lupoDharkael-flameshot-v0.5.0_GH0.tar.gz) = 464600
diff --git a/deskutils/flameshot/files/patch-flameshot.pro b/deskutils/flameshot/files/patch-flameshot.pro
new file mode 100644
index 000000000000..71fdd772e3fa
--- /dev/null
+++ b/deskutils/flameshot/files/patch-flameshot.pro
@@ -0,0 +1,35 @@
+--- flameshot.pro.orig 2017-12-20 13:41:48 UTC
++++ flameshot.pro
+@@ -177,27 +177,27 @@ unix: {
+ packaging {
+ USRPATH = /usr
+ } else {
+- USRPATH = /usr/local
++ USRPATH = %%LOCALBASE%%
+ }
+
+ target.path = $${BASEDIR}$${USRPATH}/bin/
+
+- qmfile.path = $${BASEDIR}/usr/share/flameshot/translations/
++ qmfile.path = $${BASEDIR}$${USRPATH}/share/flameshot/translations/
+ qmfile.files = $${TRANSLATIONS_FILES}
+
+- dbus.path = $${BASEDIR}/usr/share/dbus-1/interfaces/
++ dbus.path = $${BASEDIR}$${USRPATH}/share/dbus-1/interfaces/
+ dbus.files = dbus/org.dharkael.Flameshot.xml
+
+ icon.path = $${BASEDIR}$${USRPATH}/share/icons/
+ icon.files = img/flameshot.png
+
+- completion.path = /usr/share/bash-completion/completions/
++ completion.path = $${BASEDIR}$${USRPATH}/share/bash-completion/completions/
+ completion.files = docs/bash-completion/flameshot
+
+ desktopentry.path = $${BASEDIR}$${USRPATH}/share/applications
+ desktopentryinit.path = $${BASEDIR}$${USRPATH}/share/applications
+ desktopentryconfig.path = $${BASEDIR}$${USRPATH}/share/applications
+- servicedbus.path = $${BASEDIR}/usr/share/dbus-1/services/
++ servicedbus.path = $${BASEDIR}$${USRPATH}/share/dbus-1/services/
+
+ packaging {
+ desktopentry.files = docs/desktopEntry/package/flameshot.desktop
diff --git a/deskutils/flameshot/pkg-descr b/deskutils/flameshot/pkg-descr
new file mode 100644
index 000000000000..63bd7dff72fc
--- /dev/null
+++ b/deskutils/flameshot/pkg-descr
@@ -0,0 +1,11 @@
+Powerful yet simple to use screenshot software.
+
+Features:
+
+ * Customizable appearance.
+ * Easy to use.
+ * In-app screenshot edition.
+ * DBus interface.
+ * Upload to Imgur.
+
+WWW: https://github.com/lupoDharkael/flameshot
diff --git a/deskutils/flameshot/pkg-plist b/deskutils/flameshot/pkg-plist
new file mode 100644
index 000000000000..c9ec5c124395
--- /dev/null
+++ b/deskutils/flameshot/pkg-plist
@@ -0,0 +1,10 @@
+bin/flameshot
+share/applications/flameshot-config.desktop
+share/applications/flameshot-init.desktop
+share/applications/flameshot.desktop
+share/bash-completion/completions/flameshot
+share/dbus-1/interfaces/org.dharkael.Flameshot.xml
+share/dbus-1/services/org.dharkael.Flameshot.service
+%%DATADIR%%/translations/Internationalization_ca.qm
+%%DATADIR%%/translations/Internationalization_es.qm
+share/icons/flameshot.png