aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/exempi/Makefile3
-rw-r--r--textproc/exempi/distinfo6
-rw-r--r--textproc/exempi/files/patch-exempi_Makefile.in19
-rw-r--r--textproc/exempi/files/patch-samples_source_Makefile.in19
-rw-r--r--textproc/exempi/files/patch-samples_source_common_DumpFile.cpp38
-rw-r--r--textproc/exempi/pkg-plist2
6 files changed, 81 insertions, 6 deletions
diff --git a/textproc/exempi/Makefile b/textproc/exempi/Makefile
index 683f7ef13885..ce33af7ef4e5 100644
--- a/textproc/exempi/Makefile
+++ b/textproc/exempi/Makefile
@@ -1,6 +1,5 @@
PORTNAME= exempi
-DISTVERSION= 2.5.2
-PORTREVISION= 1
+DISTVERSION= 2.6.2
CATEGORIES= textproc
MASTER_SITES= http://libopenraw.freedesktop.org/download/
diff --git a/textproc/exempi/distinfo b/textproc/exempi/distinfo
index f4ec15b0959a..71962d2f3145 100644
--- a/textproc/exempi/distinfo
+++ b/textproc/exempi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626540964
-SHA256 (exempi-2.5.2.tar.bz2) = 52f54314aefd45945d47a6ecf4bd21f362e6467fa5d0538b0d45a06bc6eaaed5
-SIZE (exempi-2.5.2.tar.bz2) = 3658606
+TIMESTAMP = 1659086948
+SHA256 (exempi-2.6.2.tar.bz2) = 4d17d4c93df2a95da3e3172c45b7a5bf317dd31dafd1c7a340169728c7089d1d
+SIZE (exempi-2.6.2.tar.bz2) = 3709476
diff --git a/textproc/exempi/files/patch-exempi_Makefile.in b/textproc/exempi/files/patch-exempi_Makefile.in
new file mode 100644
index 000000000000..a644ce876a26
--- /dev/null
+++ b/textproc/exempi/files/patch-exempi_Makefile.in
@@ -0,0 +1,19 @@
+--- exempi/Makefile.in.orig 2022-07-29 09:33:18 UTC
++++ exempi/Makefile.in
+@@ -128,7 +128,6 @@ bin_PROGRAMS = exempi$(EXEEXT)
+ build_triplet = @build@
+ host_triplet = @host@
+ bin_PROGRAMS = exempi$(EXEEXT)
+-@UNIX_ENV_TRUE@am__append_1 = -lrt
+ @WITH_UNIT_TEST_TRUE@check_PROGRAMS = testexempicore$(EXEEXT) \
+ @WITH_UNIT_TEST_TRUE@ testserialise$(EXEEXT) \
+ @WITH_UNIT_TEST_TRUE@ testwritenewprop$(EXEEXT) \
+@@ -801,7 +800,7 @@ libexempi_la_LIBADD = $(top_builddir)/source/libxmpcom
+ $(top_builddir)/XMPCore/source/libXMPCore.la \
+ $(top_builddir)/XMPFiles/source/libXMPFiles.la \
+ $(top_builddir)/third-party/zuid/interfaces/libmd5.la -lexpat \
+- -lz -ldl $(am__append_1)
++ -lz $(am__append_1)
+ libexempi_la_LDFLAGS = -version-info @EXEMPI_VERSION_INFO@
+ dist_man1_MANS = exempi.1
+
diff --git a/textproc/exempi/files/patch-samples_source_Makefile.in b/textproc/exempi/files/patch-samples_source_Makefile.in
new file mode 100644
index 000000000000..9afce776b44c
--- /dev/null
+++ b/textproc/exempi/files/patch-samples_source_Makefile.in
@@ -0,0 +1,19 @@
+--- samples/source/Makefile.in.orig 2022-07-29 09:33:18 UTC
++++ samples/source/Makefile.in
+@@ -129,7 +129,6 @@ noinst_PROGRAMS = xmpcoverage$(EXEEXT) xmpfilescoverag
+ dumpxmp$(EXEEXT) dumpmainxmp$(EXEEXT) customschema$(EXEEXT) \
+ modifyingxmp$(EXEEXT) readingxmp$(EXEEXT) \
+ xmpcommandtool$(EXEEXT)
+-@UNIX_ENV_TRUE@am__append_1 = -lrt
+ subdir = samples/source
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/m4/ax_append_compile_flags.m4 \
+@@ -438,7 +437,7 @@ XMPLIBS = $(top_builddir)/XMPCore/source/libXMPCore.la
+ XMPLIBS = $(top_builddir)/XMPCore/source/libXMPCore.la \
+ $(top_builddir)/XMPFiles/source/libXMPFiles.la \
+ $(top_builddir)/source/libxmpcommon.la -lexpat -lz \
+- $(top_builddir)/third-party/zuid/interfaces/libmd5.la -ldl \
++ $(top_builddir)/third-party/zuid/interfaces/libmd5.la \
+ $(am__append_1)
+ noinst_LTLIBRARIES = libsamplescommon.la
+ libsamplescommon_la_SOURCES = common/DumpFile.cpp common/DumpFile.h \
diff --git a/textproc/exempi/files/patch-samples_source_common_DumpFile.cpp b/textproc/exempi/files/patch-samples_source_common_DumpFile.cpp
new file mode 100644
index 000000000000..1587cd397d00
--- /dev/null
+++ b/textproc/exempi/files/patch-samples_source_common_DumpFile.cpp
@@ -0,0 +1,38 @@
+--- samples/source/common/DumpFile.cpp.orig 2022-06-25 21:43:18 UTC
++++ samples/source/common/DumpFile.cpp
+@@ -2476,7 +2476,7 @@ DumpISOBoxes(LFA_FileRef file, XMP_Uns32 maxBoxLen, st
+ DumpTIFF(tiffContent, tiffLength, offset, "HEIF Exif", "HEIF:Exif");
+ LFA_Seek(file, keep, SEEK_SET, &ok);
+ assertMsg("seek failed", ok);
+- exif_item_id = NULL;
++ exif_item_id = 0;
+ }
+ }
+ //Get the data for xmp - using value from mime_item_id
+@@ -2494,7 +2494,7 @@ DumpISOBoxes(LFA_FileRef file, XMP_Uns32 maxBoxLen, st
+ DumpXMP(xmpContent, xmpLength, offset, "XMP");
+ LFA_Seek(file, keep, SEEK_SET, &ok);
+ assertMsg("seek failed", ok);
+- mime_item_id = NULL;
++ mime_item_id = 0;
+ }
+ }
+ break;
+@@ -2646,7 +2646,7 @@ DumpISOBoxes(LFA_FileRef file, XMP_Uns32 maxBoxLen, st
+ DumpTIFF(tiffContent, tiffLength, offset, "HEIF Exif", "HEIF:Exif");
+ LFA_Seek(file, keep, SEEK_SET, &ok);
+ assertMsg("seek failed", ok);
+- exif_item_id = NULL;
++ exif_item_id = 0;
+ }
+ }
+ //Get the data for xmp - using value from mime_item_id
+@@ -2664,7 +2664,7 @@ DumpISOBoxes(LFA_FileRef file, XMP_Uns32 maxBoxLen, st
+ DumpXMP(xmpContent, xmpLength, offset, "XMP");
+ LFA_Seek(file, keep, SEEK_SET, &ok);
+ assertMsg("seek failed", ok);
+- mime_item_id = NULL;
++ mime_item_id = 0;
+ }
+ }
+
diff --git a/textproc/exempi/pkg-plist b/textproc/exempi/pkg-plist
index cc5fea78b8b2..4fe1dcf8844c 100644
--- a/textproc/exempi/pkg-plist
+++ b/textproc/exempi/pkg-plist
@@ -6,6 +6,6 @@ include/exempi-2.0/exempi/xmperrors.h
lib/libexempi.a
lib/libexempi.so
lib/libexempi.so.8
-lib/libexempi.so.8.0.2
+lib/libexempi.so.8.1.2
libdata/pkgconfig/exempi-2.0.pc
man/man1/exempi.1.gz