aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-perf/Makefile23
-rw-r--r--devel/go-perf/distinfo5
-rw-r--r--devel/go-perf/pkg-descr16
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 105d0382d571..5c98b45c8551 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -872,6 +872,7 @@
SUBDIR += go-bindata-assetfs
SUBDIR += go-git
SUBDIR += go-glide
+ SUBDIR += go-perf
SUBDIR += go-protobuf
SUBDIR += go-tools
SUBDIR += gob2
diff --git a/devel/go-perf/Makefile b/devel/go-perf/Makefile
new file mode 100644
index 000000000000..d0d7d14b39b1
--- /dev/null
+++ b/devel/go-perf/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= go-perf
+PORTVERSION= ${MODVERSION:S/-/./g:R}
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= fuz@fuz.su
+COMMENT= Go performance measurement, storage, and analysis tools
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+MODVERSION= 0.0.0-20210220033136-40a54f11e909
+GO_MODULE= golang.org/x/perf@v${MODVERSION}
+
+GO_TARGET= ./cmd/benchsave \
+ ./cmd/benchstat \
+ ./analysis/localperf \
+ ./storage/localperfdata
+
+PLIST_FILES= ${GO_TARGET:T:S,^,bin/,}
+
+.include <bsd.port.mk>
diff --git a/devel/go-perf/distinfo b/devel/go-perf/distinfo
new file mode 100644
index 000000000000..b848262a5ae2
--- /dev/null
+++ b/devel/go-perf/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1632473930
+SHA256 (go/devel_go-perf/go-perf-v0.0.0.20210220033136/v0.0.0-20210220033136-40a54f11e909.mod) = 3b1f4fe0abf96dca5f9ffa67883ac85c426911911aac3d8d104b72f6d2734b77
+SIZE (go/devel_go-perf/go-perf-v0.0.0.20210220033136/v0.0.0-20210220033136-40a54f11e909.mod) = 1182
+SHA256 (go/devel_go-perf/go-perf-v0.0.0.20210220033136/v0.0.0-20210220033136-40a54f11e909.zip) = 65222c86111e01f2606a1fbf385d7ae99448532d4702d91915df72d44d6cbb99
+SIZE (go/devel_go-perf/go-perf-v0.0.0.20210220033136/v0.0.0-20210220033136-40a54f11e909.zip) = 188481
diff --git a/devel/go-perf/pkg-descr b/devel/go-perf/pkg-descr
new file mode 100644
index 000000000000..30511de89db7
--- /dev/null
+++ b/devel/go-perf/pkg-descr
@@ -0,0 +1,16 @@
+This port contains utilities to analyse and publish Go benchmark
+results. The main use case is to compare two series of benchmarks
+for minuscule performance improvements. Four programs are included:
+
+ - benchstat is a command-line tool that computes and compares
+ statistics about benchmarks
+
+ - benchsave is a command-line tool for publishing benchmark results
+
+ - localperfdata is a local version of the https://perfdata.golang.org/
+ benchmark result storage system
+
+ - localperf is a local version of the https://perf.golang.org/
+ benchmark result analysis system.
+
+WWW: https://golang.org/x/perf