aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/kicad-devel/Makefile18
-rw-r--r--cad/kicad-devel/Makefile.git_rev4
-rw-r--r--cad/kicad-devel/distinfo6
-rw-r--r--cad/kicad-devel/files/patch-eeschema_sim_sim__plot__frame.cpp10
-rw-r--r--cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp32
-rw-r--r--cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt10
-rw-r--r--cad/kicad-devel/pkg-plist5
7 files changed, 64 insertions, 21 deletions
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index a4cfbc9b36dc..9aea541f972c 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kicad
DISTVERSION= r${GIT_SRC_DATE}
-PORTREVISION= 4
+#PORTREVISION= 1
CATEGORIES= cad
PKGNAMESUFFIX= -devel
DIST_SUBDIR= ${PORTNAME}
@@ -35,13 +35,14 @@ OPTIONS_DEFINE= DOCS
PLIST_SUB= OPSYS=${OPSYS} \
DESKTOPDIR=${DESKTOPDIR:S|^${PREFIX}/||}
-USES= desktop-file-utils shared-mime-info compiler:c++14-lang tar:bzip2 cmake:insource,noninja \
- gettext pkgconfig python:3.5+ shebangfix ssl gl xorg gnome
+USES= cmake:noninja compiler:c++11-lib desktop-file-utils gl \
+ gettext gnome pkgconfig python:3.5+ shared-mime-info shebangfix ssl \
+ tar:bzip2 xorg
USE_GITLAB= yes
GL_ACCOUNT= kicad/code
GL_PROJECT= kicad
GL_COMMIT= ${GIT_SRC_HASH}
-USE_GL= gl glew glu glut
+USE_GL= gl glu glut
USE_WX= 3.2
WX_COMPS= wx python:lib
USE_GNOME= atk cairo gtk30 gdkpixbuf2 pango
@@ -50,7 +51,7 @@ BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
-CXXFLAGS+= -I${WRKSRC} -I${WRKSRC}/include -I${LOCALBASE}/include
+CXXFLAGS+= --std=c++11 -I${WRKSRC} -I${WRKSRC}/include -I${LOCALBASE}/include
CXXFLAGS_powerpc= -O0
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DCMAKE_BUILD_TYPE="Debug" \
@@ -109,8 +110,8 @@ pre-configure:
${WRKSRC}/common/pgm_base.cpp
post-configure:
- ${REINPLACE_CMD} -e 's|#define HAVE_ISO646_H|//#define HAVE_ISO646_H|' \
- ${WRKSRC}/config.h
+# ${REINPLACE_CMD} -e 's|#define HAVE_ISO646_H|//#define HAVE_ISO646_H|' \
+# ${WRKSRC}/config.h
for f in `${FIND} ${WRKSRC} -name \*.make -o -name link.txt` ; do \
${REINPLACE_CMD} \
-e 's|CC = gcc|#CC = gcc|' \
@@ -124,6 +125,9 @@ post-configure:
-e 's/-pthread;-D_THREAD_SAFE/-pthread -D_THREAD_SAFE/g' \
$$f ; \
done
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/xdg-open|${LOCALBASE}/bin/xdg-open|' \
+ ${WRKSRC}/common/pgm_base.cpp
+
pre-install:
@echo "${DATADIR}, ${DOCSDIR}"
diff --git a/cad/kicad-devel/Makefile.git_rev b/cad/kicad-devel/Makefile.git_rev
index 46fba182b1a9..b8b3fd764303 100644
--- a/cad/kicad-devel/Makefile.git_rev
+++ b/cad/kicad-devel/Makefile.git_rev
@@ -1,2 +1,2 @@
-GIT_SRC_HASH= 4a66203493fcc58ac607449b04f9ba88c6c80cbc
-GIT_SRC_DATE= 20221009002759
+GIT_SRC_HASH= 063478b3dc2257641a43fa9830902fcdd89976d5
+GIT_SRC_DATE= 20230108153438
diff --git a/cad/kicad-devel/distinfo b/cad/kicad-devel/distinfo
index a491799a122c..6dc0f0717071 100644
--- a/cad/kicad-devel/distinfo
+++ b/cad/kicad-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665327758
-SHA256 (kicad/kicad/code-kicad-4a66203493fcc58ac607449b04f9ba88c6c80cbc_GL0.tar.gz) = cc9010995f71bbaca4e6dc8eb4d951f736fe6a6613cbd5321da88c716a5edaa4
-SIZE (kicad/kicad/code-kicad-4a66203493fcc58ac607449b04f9ba88c6c80cbc_GL0.tar.gz) = 54098837
+TIMESTAMP = 1673190180
+SHA256 (kicad/kicad/code-kicad-063478b3dc2257641a43fa9830902fcdd89976d5_GL0.tar.gz) = cc4f560965f6b4001ac825e4d3a0e4a3dfa472a413a948d50aa6a7ecafb78576
+SIZE (kicad/kicad/code-kicad-063478b3dc2257641a43fa9830902fcdd89976d5_GL0.tar.gz) = 55179322
diff --git a/cad/kicad-devel/files/patch-eeschema_sim_sim__plot__frame.cpp b/cad/kicad-devel/files/patch-eeschema_sim_sim__plot__frame.cpp
index a7b40f4b3256..ed9e2c51bd83 100644
--- a/cad/kicad-devel/files/patch-eeschema_sim_sim__plot__frame.cpp
+++ b/cad/kicad-devel/files/patch-eeschema_sim_sim__plot__frame.cpp
@@ -1,6 +1,6 @@
---- eeschema/sim/sim_plot_frame.cpp.orig 2022-09-14 16:35:24 UTC
-+++ eeschema/sim/sim_plot_frame.cpp
-@@ -167,15 +167,15 @@ SIM_PLOT_FRAME::SIM_PLOT_FRAME( KIWAY* aKiway, wxWindo
+--- eeschema/sim/sim_plot_frame.cpp.orig 2023-01-06 17:32:00.707624000 +0100
++++ eeschema/sim/sim_plot_frame.cpp 2023-01-06 17:35:04.237427000 +0100
+@@ -156,15 +156,15 @@
Bind( EVT_SIM_CURSOR_UPDATE, &SIM_PLOT_FRAME::onCursorUpdate, this );
// Toolbar buttons
@@ -16,8 +16,8 @@
- m_toolTune = m_toolBar->AddTool( ID_SIM_TUNE, _( "Tune" ),
+ m_toolTune = m_toolBar->AddTool( ID_SIM_TUNE, wxEmptyString,
KiBitmap( BITMAPS::sim_tune ), _( "Tune component values" ), wxITEM_NORMAL );
-- m_toolSettings = m_toolBar->AddTool( wxID_ANY, _( "Sim Parameters" ),
+- m_toolSettings = m_toolBar->AddTool( wxID_ANY, _( "Sim Command" ),
+ m_toolSettings = m_toolBar->AddTool( wxID_ANY, wxEmptyString,
- KiBitmap( BITMAPS::config ), _( "Simulation parameters and settings" ), wxITEM_NORMAL );
+ KiBitmap( BITMAPS::config ), _( "Simulation command and settings" ), wxITEM_NORMAL );
// Start all toolbar buttons except settings as disabled
diff --git a/cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp b/cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp
new file mode 100644
index 000000000000..12625f24511b
--- /dev/null
+++ b/cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp
@@ -0,0 +1,32 @@
+--- pcbnew/import_gfx/dxf_import_plugin.cpp.orig 2023-01-08 16:40:34.270267000 +0100
++++ pcbnew/import_gfx/dxf_import_plugin.cpp 2023-01-08 16:40:37.228586000 +0100
+@@ -581,5 +581,5 @@
+
+ VECTOR2D center( mapX( centerCoords.x ), mapY( centerCoords.y ) );
+- VECTOR2D major( mapX( majorCoords.x ), mapY( majorCoords.y ) );
++ VECTOR2D _major( mapX( majorCoords.x ), mapY( majorCoords.y ) );
+
+ // DXF elliptical arcs store their angles in radians (unlike circular arcs which use degrees)
+@@ -599,5 +599,5 @@
+ if( aData.ratio == 1.0 )
+ {
+- double radius = major.EuclideanNorm();
++ double radius = _major.EuclideanNorm();
+
+ if( startAngle == endAngle )
+@@ -617,5 +617,5 @@
+
+ std::vector<BEZIER<double>> splines;
+- ELLIPSE<double> ellipse( center, major, aData.ratio, startAngle, endAngle );
++ ELLIPSE<double> ellipse( center, _major, aData.ratio, startAngle, endAngle );
+
+ TransformEllipseToBeziers( ellipse, splines );
+@@ -631,6 +631,6 @@
+
+ // Naive bounding
+- updateImageLimits( center + major );
+- updateImageLimits( center - major );
++ updateImageLimits( center + _major );
++ updateImageLimits( center - _major );
+ }
+
diff --git a/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt b/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt
new file mode 100644
index 000000000000..18c5a496dd6c
--- /dev/null
+++ b/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- thirdparty/glew/CMakeLists.txt.orig 2022-05-07 15:44:23 +0200
++++ thirdparty/glew/CMakeLists.txt
+@@ -5,6 +5,7 @@
+ # The actual include directories will be added to the global include paths as
+ # system headers
+ target_include_directories( glew PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include" )
++target_include_directories( glew SYSTEM PRIVATE "${CMAKE_INSTALL_PREFIX}/include" )
+
+ # Definitions for compiling GLEW staticly for EGL (extracted from the main GLEW CMakeLists.txt file)
+ add_definitions( -DGLEW_STATIC )
diff --git a/cad/kicad-devel/pkg-plist b/cad/kicad-devel/pkg-plist
index 31b9efa3c0e3..fa6f49dbdade 100644
--- a/cad/kicad-devel/pkg-plist
+++ b/cad/kicad-devel/pkg-plist
@@ -17,9 +17,6 @@ bin/kicad-cli
bin/pcb_calculator
bin/pcbnew
bin/pl_editor
-include/argparse/argparse.hpp
-lib/cmake/argparse/argparseConfig-version.cmake
-lib/cmake/argparse/argparseConfig.cmake
lib/kicad/plugins/3d/libs3d_plugin_idf.so
lib/kicad/plugins/3d/libs3d_plugin_oce.so
lib/kicad/plugins/3d/libs3d_plugin_vrml.so
@@ -27,7 +24,6 @@ lib/libkicad_3dsg.so
lib/libkicad_3dsg.so.2.0.0
%%PYTHON_SITELIBDIR%%/_pcbnew.so
%%PYTHON_SITELIBDIR%%/pcbnew.py
-libdata/pkgconfig/argparse.pc
%%DESKTOPDIR%%/org.kicad.bitmap2component.desktop
%%DESKTOPDIR%%/org.kicad.eeschema.desktop
%%DESKTOPDIR%%/org.kicad.gerbview.desktop
@@ -303,6 +299,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/plugins/README-bom.txt
%%DATADIR%%/plugins/bom_csv_grouped_by_value.py
%%DATADIR%%/plugins/bom_csv_grouped_by_value_with_fp.py
+%%DATADIR%%/plugins/bom_csv_grouped_extra.py
%%DATADIR%%/plugins/bom_csv_sorted_by_ref.py
%%DATADIR%%/plugins/bom_html_grouped_by_value.py
%%DATADIR%%/plugins/bom_html_with_advanced_grouping.py