aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/firefox/Makefile9
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug12885876
-rw-r--r--www/firefox/files/patch-bug162856734
4 files changed, 10 insertions, 45 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 2e683bcd97fd..1ef6981cdca3 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,8 +1,7 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 90.0.2
-PORTREVISION= 1
+DISTVERSION= 91.0
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
@@ -12,11 +11,11 @@ DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
-BUILD_DEPENDS= nspr>=4.26:devel/nspr \
- nss>=3.64:security/nss \
+BUILD_DEPENDS= nspr>=4.32:devel/nspr \
+ nss>=3.68:security/nss \
icu>=67.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=2.8.0:print/harfbuzz \
+ harfbuzz>=2.8.1:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
libvpx>=1.8.2:multimedia/libvpx \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 9b8273348e10..09b47f493f95 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626904720
-SHA256 (firefox-90.0.2.source.tar.xz) = 35c45dbc21a7bd59e5daa6b3fef7a08c51ff0a1333f47a355bb1cbc840c3ff59
-SIZE (firefox-90.0.2.source.tar.xz) = 380670372
+TIMESTAMP = 1628005545
+SHA256 (firefox-91.0.source.tar.xz) = 85c11de2dbf23f881283e2283b250a355c50b1bd961aaa288bb6725792125ff3
+SIZE (firefox-91.0.source.tar.xz) = 379049704
diff --git a/www/firefox/files/patch-bug1288587 b/www/firefox/files/patch-bug1288587
index ef6c2ffc3b5b..0925ac98733c 100644
--- a/www/firefox/files/patch-bug1288587
+++ b/www/firefox/files/patch-bug1288587
@@ -32,6 +32,6 @@ index 855214a..1e91d51 100644
+ del os.environ["PYTHON3"]
+ except KeyError:
+ pass
- # Homebrew on macOS will change Python's sys.executable to a custom
- # value which messes with mach's virtualenv handling code. Override
- # Homebrew's changes with the correct sys.executable value.
+ # Another quirk on macOS, with the system python, the virtualenv is
+ # not fully operational (missing entries in sys.path) if
+ # __PYVENV_LAUNCHER__ is set.
diff --git a/www/firefox/files/patch-bug1628567 b/www/firefox/files/patch-bug1628567
deleted file mode 100644
index f48f78bcfd0d..000000000000
--- a/www/firefox/files/patch-bug1628567
+++ /dev/null
@@ -1,34 +0,0 @@
-Don't pass --target when CC/CXX contains clang
-
---- third_party/rust/cc/src/lib.rs.orig 2020-04-10 00:57:23 UTC
-+++ third_party/rust/cc/src/lib.rs
-@@ -2344,28 +2344,7 @@ impl Tool {
- }
-
- fn with_features(path: PathBuf, clang_driver: Option<&str>, cuda: bool) -> Self {
-- // Try to detect family of the tool from its name, falling back to Gnu.
-- let family = if let Some(fname) = path.file_name().and_then(|p| p.to_str()) {
-- if fname.contains("clang-cl") {
-- ToolFamily::Msvc { clang_cl: true }
-- } else if fname.contains("cl")
-- && !fname.contains("cloudabi")
-- && !fname.contains("uclibc")
-- && !fname.contains("clang")
-- {
-- ToolFamily::Msvc { clang_cl: false }
-- } else if fname.contains("clang") {
-- match clang_driver {
-- Some("cl") => ToolFamily::Msvc { clang_cl: true },
-- _ => ToolFamily::Clang,
-- }
-- } else {
-- ToolFamily::Gnu
-- }
-- } else {
-- ToolFamily::Gnu
-- };
--
-+ let family = ToolFamily::Gnu;
- Tool {
- path: path,
- cc_wrapper_path: None,