aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/dftbplus/Makefile1
-rw-r--r--science/simple-dftd3/Makefile1
-rw-r--r--science/tblite/Makefile1
-rw-r--r--textproc/toml-f/Makefile3
-rw-r--r--textproc/toml-f/distinfo6
-rw-r--r--textproc/toml-f/pkg-plist15
6 files changed, 18 insertions, 9 deletions
diff --git a/science/dftbplus/Makefile b/science/dftbplus/Makefile
index 272e2b4c0495..717a9386b38e 100644
--- a/science/dftbplus/Makefile
+++ b/science/dftbplus/Makefile
@@ -1,5 +1,6 @@
PORTNAME= dftbplus
DISTVERSION= 22.1
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/simple-dftd3/Makefile b/science/simple-dftd3/Makefile
index 9a1f6f1ece6d..2bc5817146c4 100644
--- a/science/simple-dftd3/Makefile
+++ b/science/simple-dftd3/Makefile
@@ -1,6 +1,7 @@
PORTNAME= simple-dftd3
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= science # chemistry
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/tblite/Makefile b/science/tblite/Makefile
index a4fc0c97b56d..8c911f595f4a 100644
--- a/science/tblite/Makefile
+++ b/science/tblite/Makefile
@@ -1,6 +1,7 @@
PORTNAME= tblite
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= science # chemistry
MAINTAINER= yuri@FreeBSD.org
diff --git a/textproc/toml-f/Makefile b/textproc/toml-f/Makefile
index 51589786152f..dca5d918e27b 100644
--- a/textproc/toml-f/Makefile
+++ b/textproc/toml-f/Makefile
@@ -1,6 +1,6 @@
PORTNAME= toml-f
DISTVERSIONPREFIX= v
-DISTVERSION= 0.2.3
+DISTVERSION= 0.3.0
CATEGORIES= textproc
MAINTAINER= yuri@FreeBSD.org
@@ -14,6 +14,7 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_TESTING_ON= FREEBSD_BUILD_TESTS
post-patch: # see https://github.com/toml-f/toml-f/issues/51
@${REINPLACE_CMD} -e 's|$${CMAKE_Fortran_COMPILER_ID}-$${CMAKE_Fortran_COMPILER_VERSION}||' ${WRKSRC}/config/CMakeLists.txt
diff --git a/textproc/toml-f/distinfo b/textproc/toml-f/distinfo
index 3a8f51c8ebe1..d9c9ec6edc59 100644
--- a/textproc/toml-f/distinfo
+++ b/textproc/toml-f/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649822252
-SHA256 (toml-f-toml-f-v0.2.3_GH0.tar.gz) = 679e36daf1be40e187e3488e6aa44e33e27dd426ba1947f816563d20d063e02a
-SIZE (toml-f-toml-f-v0.2.3_GH0.tar.gz) = 94058
+TIMESTAMP = 1659543682
+SHA256 (toml-f-toml-f-v0.3.0_GH0.tar.gz) = dff1bf3466ff346d2dee24440d1a4728e71051fe34d5c282b6ce7e6dc3ce0de9
+SIZE (toml-f-toml-f-v0.3.0_GH0.tar.gz) = 408857
diff --git a/textproc/toml-f/pkg-plist b/textproc/toml-f/pkg-plist
index 712e767a216c..35257702d870 100644
--- a/textproc/toml-f/pkg-plist
+++ b/textproc/toml-f/pkg-plist
@@ -4,26 +4,31 @@ include/toml-f/tomlf_build.mod
include/toml-f/tomlf_build_array.mod
include/toml-f/tomlf_build_keyval.mod
include/toml-f/tomlf_build_merge.mod
+include/toml-f/tomlf_build_path.mod
include/toml-f/tomlf_build_table.mod
include/toml-f/tomlf_constants.mod
include/toml-f/tomlf_datetime.mod
include/toml-f/tomlf_de.mod
-include/toml-f/tomlf_de_character.mod
-include/toml-f/tomlf_de_tokenizer.mod
+include/toml-f/tomlf_de_abc.mod
+include/toml-f/tomlf_de_context.mod
+include/toml-f/tomlf_de_lexer.mod
+include/toml-f/tomlf_de_parser.mod
+include/toml-f/tomlf_de_token.mod
+include/toml-f/tomlf_diagnostic.mod
include/toml-f/tomlf_error.mod
include/toml-f/tomlf_ser.mod
include/toml-f/tomlf_structure.mod
include/toml-f/tomlf_structure_base.mod
include/toml-f/tomlf_structure_vector.mod
+include/toml-f/tomlf_terminal.mod
include/toml-f/tomlf_type.mod
include/toml-f/tomlf_type_array.mod
include/toml-f/tomlf_type_keyval.mod
include/toml-f/tomlf_type_table.mod
include/toml-f/tomlf_type_value.mod
include/toml-f/tomlf_utils.mod
-include/toml-f/tomlf_utils_convert.mod
+include/toml-f/tomlf_utils_io.mod
include/toml-f/tomlf_utils_sort.mod
-include/toml-f/tomlf_utils_verify.mod
include/toml-f/tomlf_version.mod
lib/cmake/toml-f/toml-f-config-version.cmake
lib/cmake/toml-f/toml-f-config.cmake
@@ -31,5 +36,5 @@ lib/cmake/toml-f/toml-f-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/toml-f/toml-f-targets.cmake
lib/libtoml-f.so
lib/libtoml-f.so.0
-lib/libtoml-f.so.0.2.3
+lib/libtoml-f.so.0.3.0
libdata/pkgconfig/toml-f.pc