aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/neofetch/Makefile3
-rw-r--r--sysutils/neofetch/files/patch-Makefile9
-rw-r--r--sysutils/neofetch/files/patch-neofetch11
3 files changed, 14 insertions, 9 deletions
diff --git a/sysutils/neofetch/Makefile b/sysutils/neofetch/Makefile
index 9b4e60cc539b..b709baa902a4 100644
--- a/sysutils/neofetch/Makefile
+++ b/sysutils/neofetch/Makefile
@@ -1,5 +1,6 @@
PORTNAME= neofetch
DISTVERSION= 7.1.0
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= pkubaj@FreeBSD.org
@@ -16,6 +17,8 @@ GH_ACCOUNT= dylanaraps
NO_ARCH= yes
NO_BUILD= yes
+MAKE_ENV= PREFIX="${PREFIX}"
+
OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
diff --git a/sysutils/neofetch/files/patch-Makefile b/sysutils/neofetch/files/patch-Makefile
deleted file mode 100644
index c63bf0db6f4e..000000000000
--- a/sysutils/neofetch/files/patch-Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.orig 2018-05-19 21:56:46 UTC
-+++ Makefile
-@@ -1,5 +1,5 @@
--PREFIX ?= /usr
-+PREFIX ?= /usr/local
- MANDIR ?= $(PREFIX)/share/man
-
- all:
- @echo Run \'make install\' to install Neofetch.
diff --git a/sysutils/neofetch/files/patch-neofetch b/sysutils/neofetch/files/patch-neofetch
new file mode 100644
index 000000000000..a6082749d12d
--- /dev/null
+++ b/sysutils/neofetch/files/patch-neofetch
@@ -0,0 +1,11 @@
+--- neofetch.orig 2022-08-05 13:28:08 UTC
++++ neofetch
+@@ -1193,7 +1193,7 @@ get_distro() {
+
+ # Get OS architecture.
+ case $os in
+- Solaris|AIX|Haiku|IRIX|FreeMiNT)
++ Solaris|AIX|Haiku|IRIX|FreeMiNT|BSD)
+ machine_arch=$(uname -p)
+ ;;
+