aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/gnuls/Makefile2
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/opendircolors/Makefile20
-rw-r--r--sysutils/opendircolors/distinfo3
-rw-r--r--sysutils/opendircolors/pkg-descr4
-rw-r--r--sysutils/opendircolors/pkg-plist6
6 files changed, 36 insertions, 0 deletions
diff --git a/misc/gnuls/Makefile b/misc/gnuls/Makefile
index 99cc7bfe4d3b..b7ff8912139b 100644
--- a/misc/gnuls/Makefile
+++ b/misc/gnuls/Makefile
@@ -18,6 +18,8 @@ CONFIGURE_ENV= FORCE_UNSAFE_CONFIGURE=1
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+CONFLICTS_INSTALL= opendircolors # bin/dircolors
+
USES= gmake perl5 tar:xz
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 40632e7eb93d..f443c08efbcc 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -788,6 +788,7 @@
SUBDIR += opa
SUBDIR += open
SUBDIR += opencorsairlink
+ SUBDIR += opendircolors
SUBDIR += openipmi
SUBDIR += opensbi
SUBDIR += openseachest
diff --git a/sysutils/opendircolors/Makefile b/sysutils/opendircolors/Makefile
new file mode 100644
index 000000000000..8fefc5fc2ee0
--- /dev/null
+++ b/sysutils/opendircolors/Makefile
@@ -0,0 +1,20 @@
+# Created by: Cameron Katri <me@cameronkatri.com>
+
+PORTNAME= opendircolors
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.2
+CATEGORIES= sysutils
+
+MAINTAINER= me@cameronkatri.com
+COMMENT= BSD-licensed replacement for dircolors
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= uidfix
+USE_GITHUB= yes
+GH_ACCOUNT= CRKatri
+
+CONFLICTS_INSTALL= gnuls # bin/dircolors
+
+.include <bsd.port.mk>
diff --git a/sysutils/opendircolors/distinfo b/sysutils/opendircolors/distinfo
new file mode 100644
index 000000000000..137216c2c94b
--- /dev/null
+++ b/sysutils/opendircolors/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619811619
+SHA256 (CRKatri-opendircolors-v0.0.2_GH0.tar.gz) = 12409855744afa7522506aebc2b0fac8cd43902b27e329ef641bd1ed7482e8c0
+SIZE (CRKatri-opendircolors-v0.0.2_GH0.tar.gz) = 6406
diff --git a/sysutils/opendircolors/pkg-descr b/sysutils/opendircolors/pkg-descr
new file mode 100644
index 000000000000..e8b854ca49b7
--- /dev/null
+++ b/sysutils/opendircolors/pkg-descr
@@ -0,0 +1,4 @@
+A BSD-licensed replacement for GNU dircolors(1),
+with support for FreeBSD's ls(1) using LSCOLORS.
+
+WWW: https://github.com/CRKatri/opendircolors
diff --git a/sysutils/opendircolors/pkg-plist b/sysutils/opendircolors/pkg-plist
new file mode 100644
index 000000000000..05774a72c095
--- /dev/null
+++ b/sysutils/opendircolors/pkg-plist
@@ -0,0 +1,6 @@
+bin/dircolors
+bin/dirconvert
+bin/opendircolors
+man/man1/dircolors.1.gz
+man/man1/dirconvert.1.gz
+man/man1/opendircolors.1.gz