aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/tclap/files/patch-CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/devel/tclap/files/patch-CMakeLists.txt b/devel/tclap/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..55470e0a172a
--- /dev/null
+++ b/devel/tclap/files/patch-CMakeLists.txt
@@ -0,0 +1,16 @@
+--- CMakeLists.txt.orig 2021-09-07 09:26:56 UTC
++++ CMakeLists.txt
+@@ -25,7 +25,13 @@ install(FILES "${PROJECT_BINARY_DIR}/tclap/TCLAPConfig
+ DESTINATION include/tclap
+ )
+
++if (FREEBSD_DOCS)
+ add_subdirectory(docs)
++endif()
++if (FREEBSD_EXAMPLES)
+ add_subdirectory(examples)
++endif()
++if (FREEBSD_TESTS)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(include/tclap)