aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/php56-redis/Makefile2
-rw-r--r--databases/php70-redis/Makefile2
-rw-r--r--databases/phpmyadmin/Makefile1
-rw-r--r--devel/pecl-propro2/Makefile2
-rw-r--r--devel/pecl-raphf2/Makefile2
-rw-r--r--devel/php-Psr_Log/Makefile2
-rw-r--r--devel/php70-APCu/Makefile2
-rw-r--r--lang/php56-extensions/Makefile2
-rw-r--r--lang/php70-extensions/Makefile2
-rw-r--r--math/pecl-bitset/Makefile2
-rw-r--r--math/pecl-stats2/Makefile2
-rw-r--r--net-mgmt/zabbix24-server/Makefile1
-rw-r--r--net-mgmt/zabbix3-server/Makefile1
-rw-r--r--net-mgmt/zabbix32-server/Makefile1
-rw-r--r--net/pecl-oauth2/Makefile2
-rw-r--r--sysutils/pcbsd-appweb/Makefile1
-rw-r--r--textproc/pecl-xdiff2/Makefile2
-rw-r--r--www/pecl-http/Makefile2
-rw-r--r--www/zikula/Makefile1
19 files changed, 12 insertions, 20 deletions
diff --git a/databases/php56-redis/Makefile b/databases/php56-redis/Makefile
index d17cf5bc5804..c0f7b83e550a 100644
--- a/databases/php56-redis/Makefile
+++ b/databases/php56-redis/Makefile
@@ -15,7 +15,7 @@ LICENSE= PHP301
USES= php:ext
USE_PHP= session:build
PHP_VER= 56
-IGNORE_WITH_PHP= 55 70
+IGNORE_WITH_PHP= 70
USE_GITHUB= yes
GH_ACCOUNT= nicolasff
diff --git a/databases/php70-redis/Makefile b/databases/php70-redis/Makefile
index cdc58958de5e..8b2bce4e29ac 100644
--- a/databases/php70-redis/Makefile
+++ b/databases/php70-redis/Makefile
@@ -14,7 +14,7 @@ LICENSE= PHP301
USES= php:ext
USE_PHP= session:build
PHP_VER= 70
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
USE_GITHUB= yes
GH_ACCOUNT= phpredis
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 4456d9a26e87..7fb8fc32c5e1 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -19,7 +19,6 @@ CPE_PRODUCT= ${PORTNAME:tl}
NO_ARCH= yes
NO_BUILD= yes
.if !defined(WITHOUT_PHP_DEPENDS)
-IGNORE_WITH_PHP=5 54
USE_PHP= ctype session filter mbstring json spl mysqli
.endif
diff --git a/devel/pecl-propro2/Makefile b/devel/pecl-propro2/Makefile
index de0021f6d352..402ee6c76a8a 100644
--- a/devel/pecl-propro2/Makefile
+++ b/devel/pecl-propro2/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTSCOUT= limit:^2.*
USES= gmake php:ext tar:tgz
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
CONFLICTS= pecl-propro-1*
.include <bsd.port.mk>
diff --git a/devel/pecl-raphf2/Makefile b/devel/pecl-raphf2/Makefile
index 54c55f11aa17..fd0bc6c421ca 100644
--- a/devel/pecl-raphf2/Makefile
+++ b/devel/pecl-raphf2/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTSCOUT= limit:^2.*
USES= gmake php:ext tar:tgz
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
CONFLICTS= pecl-raphf-1*
.include <bsd.port.mk>
diff --git a/devel/php-Psr_Log/Makefile b/devel/php-Psr_Log/Makefile
index 676db75583b4..258b26f90b2b 100644
--- a/devel/php-Psr_Log/Makefile
+++ b/devel/php-Psr_Log/Makefile
@@ -28,8 +28,6 @@ PLIST_FILES= share/pear/Psr/Log/AbstractLogger.php \
share/pear/Psr/Log/NullLogger.php \
share/pear/Psr/Log/Test/LoggerInterfaceTest.php
-IGNORE_WITH_PHP=52
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/pear/Psr/Log/Test
.for file in ${PLIST_FILES}
diff --git a/devel/php70-APCu/Makefile b/devel/php70-APCu/Makefile
index 0e5a6bff048d..705b93e59e3e 100644
--- a/devel/php70-APCu/Makefile
+++ b/devel/php70-APCu/Makefile
@@ -15,7 +15,7 @@ LICENSE= PHP301
CONFLICTS= pecl-APC-[0-9]*
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
PHP_VER= 70
USES= localbase php:ext tar:tgz
PHP_MODNAME= ${PORTNAME:tl}
diff --git a/lang/php56-extensions/Makefile b/lang/php56-extensions/Makefile
index 974a86e1c9e4..81ccccb8181a 100644
--- a/lang/php56-extensions/Makefile
+++ b/lang/php56-extensions/Makefile
@@ -11,7 +11,7 @@ COMMENT= "meta-port" to install PHP extensions
USES= metaport php
PHP_VER= 56
-IGNORE_WITH_PHP= 55 70
+IGNORE_WITH_PHP= 70
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM ENCHANT EXIF FILEINFO FILTER FTP GD GETTEXT \
diff --git a/lang/php70-extensions/Makefile b/lang/php70-extensions/Makefile
index 9da8f5a7fa80..619301865a02 100644
--- a/lang/php70-extensions/Makefile
+++ b/lang/php70-extensions/Makefile
@@ -11,7 +11,7 @@ COMMENT= "meta-port" to install PHP extensions
USES= metaport php
PHP_VER= 70
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM ENCHANT EXIF FILEINFO FILTER FTP GD GETTEXT \
diff --git a/math/pecl-bitset/Makefile b/math/pecl-bitset/Makefile
index 2d6b2ae2d357..a714439fc661 100644
--- a/math/pecl-bitset/Makefile
+++ b/math/pecl-bitset/Makefile
@@ -15,7 +15,7 @@ COMMENT= PECL extension for manipulating bitsets
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=55 56
+IGNORE_WITH_PHP=56
USES= php:ext tar:tgz
.include <bsd.port.mk>
diff --git a/math/pecl-stats2/Makefile b/math/pecl-stats2/Makefile
index 431bc68f4a25..37b4cf4ddb56 100644
--- a/math/pecl-stats2/Makefile
+++ b/math/pecl-stats2/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTSCOUT= limit:^2.*
USES= php:ext tar:tgz
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
CONFLICTS= pecl-stats-1*
.include <bsd.port.mk>
diff --git a/net-mgmt/zabbix24-server/Makefile b/net-mgmt/zabbix24-server/Makefile
index 0a4be0d95e49..3ef7f37249fb 100644
--- a/net-mgmt/zabbix24-server/Makefile
+++ b/net-mgmt/zabbix24-server/Makefile
@@ -16,7 +16,6 @@ LICENSE= GPLv2
CONFLICTS= ${PKGBASE}-1.[0-8]*
-IGNORE_WITH_PHP= 52
IGNORE_WITH_MYSQL= 41
.if ${PKGNAMESUFFIX} != "-agent"
diff --git a/net-mgmt/zabbix3-server/Makefile b/net-mgmt/zabbix3-server/Makefile
index d4ddd7935708..5164b00d8844 100644
--- a/net-mgmt/zabbix3-server/Makefile
+++ b/net-mgmt/zabbix3-server/Makefile
@@ -16,7 +16,6 @@ LICENSE= GPLv2
CONFLICTS= zabbix2${PKGNAMESUFFIX}-[0-9]* zabbix22${PKGNAMESUFFIX}-[0-9]* zabbix24${PKGNAMESUFFIX}-[0-9]* zabbix32${PKGNAMESUFFIX}-[0-9]*
-IGNORE_WITH_PHP= 52
IGNORE_WITH_MYSQL= 41
ZABBIX_BUILD= ${PKGNAMESUFFIX:S/^-//}
diff --git a/net-mgmt/zabbix32-server/Makefile b/net-mgmt/zabbix32-server/Makefile
index a4f521f1f387..ef10ba4a0fc4 100644
--- a/net-mgmt/zabbix32-server/Makefile
+++ b/net-mgmt/zabbix32-server/Makefile
@@ -16,7 +16,6 @@ LICENSE= GPLv2
CONFLICTS= zabbix2${PKGNAMESUFFIX}-[0-9]* zabbix22${PKGNAMESUFFIX}-[0-9]* zabbix24${PKGNAMESUFFIX}-[0-9]* zabbix3${PKGNAMESUFFIX}-[0-9]*
-IGNORE_WITH_PHP= 52
IGNORE_WITH_MYSQL= 41
ZABBIX_BUILD= ${PKGNAMESUFFIX:S/^-//}
diff --git a/net/pecl-oauth2/Makefile b/net/pecl-oauth2/Makefile
index 16646cb99c37..5c79424e5897 100644
--- a/net/pecl-oauth2/Makefile
+++ b/net/pecl-oauth2/Makefile
@@ -23,7 +23,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
USES= php:ext tar:tgz
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
CONFLICTS= pecl-oauth-1*
.include <bsd.port.mk>
diff --git a/sysutils/pcbsd-appweb/Makefile b/sysutils/pcbsd-appweb/Makefile
index c4359ef0ab72..4b860bddb2eb 100644
--- a/sysutils/pcbsd-appweb/Makefile
+++ b/sysutils/pcbsd-appweb/Makefile
@@ -15,7 +15,6 @@ RUN_DEPENDS= syscache:sysutils/pcbsd-syscache \
warden:sysutils/warden \
nginx:www/nginx
-IGNORE_WITH_PHP=5 54
USE_PHP= filter gd json session
WRKSRC_SUBDIR= src-webui
USES= pkgconfig tar:xz
diff --git a/textproc/pecl-xdiff2/Makefile b/textproc/pecl-xdiff2/Makefile
index e6de5e79b5b3..9fb4b3f28700 100644
--- a/textproc/pecl-xdiff2/Makefile
+++ b/textproc/pecl-xdiff2/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libxdiff.so:textproc/libxdiff
PORTSCOUT= limit:^2.*
USES= php:ext tar:tgz
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
CONFLICTS= pecl-xdiff-1*
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index e48323e1297d..3f589a2078b7 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2 \
LIB_DEPENDS= libcurl.so:ftp/curl \
libevent.so:devel/libevent2
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 56
USES= php:ext tar:tgz
CONFLICTS= pecl-http[12]*
diff --git a/www/zikula/Makefile b/www/zikula/Makefile
index 13f22e18a1dc..1bfb2d9729b4 100644
--- a/www/zikula/Makefile
+++ b/www/zikula/Makefile
@@ -18,7 +18,6 @@ NO_BUILD= yes
USE_MYSQL= yes
USE_PHP= ctype tokenizer pdo mysql filter mbstring session json pdo_mysql hash
WANT_PHP_WEB= yes
-IGNORE_WITH_PHP=52
IGNORE_WITH_MYSQL= 41 50
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"