aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/py-soapy/Makefile25
-rw-r--r--net/py-soapy/pkg-descr13
-rw-r--r--net/py-soapy/pkg-plist16
3 files changed, 30 insertions, 24 deletions
diff --git a/net/py-soapy/Makefile b/net/py-soapy/Makefile
index 6cc5fa72b6bd..44aa45c69567 100644
--- a/net/py-soapy/Makefile
+++ b/net/py-soapy/Makefile
@@ -10,19 +10,30 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sbz@FreeBSD.org
COMMENT= SOAP/XML schema library for Python
+LICENSE= PSFL
+
RUN_DEPENDS= ${PYXML}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-NO_STAGE= yes
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @ ${MKDIR} ${EXAMPLESDIR}/test
- @ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}/test
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/test
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${STAGEDIR}${EXAMPLESDIR}/test
.endif
.include <bsd.port.mk>
diff --git a/net/py-soapy/pkg-descr b/net/py-soapy/pkg-descr
index 321b656f91eb..e3e8be95430e 100644
--- a/net/py-soapy/pkg-descr
+++ b/net/py-soapy/pkg-descr
@@ -1,10 +1,5 @@
-From the website:
+SOAPy is a SOAP-1.1 library for Python which uses WSDL and SDL documents to
+discover SOAP-based service APIs. It also includes an XML Schema parser which
+can parse a subset of the XML Schema standard.
- SOAPy is a SOAP/XML Schema Library for Python. Given either a WSDL or SDL
- document, SOAPy discovers the published API for a web service and exposes
- it to Python applications as transparently as possible. SOAPy is designed
- to support WSDL 1.0 and SOAP 1.1, and whatever version of SDL is being used
- to power Microsoft's TerraService web service. :)
-
-Author: Adam Elman <aelman@users.sourceforge.net>
-WWW: http://soapy.sourceforge.net/
+WWW: http://soapy.sourceforge.net
diff --git a/net/py-soapy/pkg-plist b/net/py-soapy/pkg-plist
index fe4a44dedbfd..22f2d02174c3 100644
--- a/net/py-soapy/pkg-plist
+++ b/net/py-soapy/pkg-plist
@@ -1,14 +1,14 @@
-%%PORTDOCS%%share/doc/soapy/README
-%%PORTDOCS%%share/examples/soapy/README.txt
-%%PORTDOCS%%share/examples/soapy/get_temperature.py
-%%PORTDOCS%%share/examples/soapy/terraserver_image.py
-%%PORTDOCS%%share/examples/soapy/test/testsoap.py
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTEXAMPLES%%share/examples/py-soapy/README.txt
+%%PORTEXAMPLES%%share/examples/py-soapy/get_temperature.py
+%%PORTEXAMPLES%%share/examples/py-soapy/terraserver_image.py
+%%PORTEXAMPLES%%share/examples/py-soapy/test/testsoap.py
%%PYTHON_SITELIBDIR%%/schema.py
%%PYTHON_SITELIBDIR%%/schema.pyc
%%PYTHON_SITELIBDIR%%/schema.pyo
%%PYTHON_SITELIBDIR%%/soap.py
%%PYTHON_SITELIBDIR%%/soap.pyc
%%PYTHON_SITELIBDIR%%/soap.pyo
-%%PORTDOCS%%@dirrm share/examples/soapy/test
-%%PORTDOCS%%@dirrm share/examples/soapy
-%%PORTDOCS%%@dirrm share/doc/soapy
+%%PORTEXAMPLES%%@dirrm share/examples/py-soapy/test
+%%PORTEXAMPLES%%@dirrm share/examples/py-soapy
+%%PORTDOCS%%@dirrm %%DOCSDIR%%