aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/i3status/Makefile14
-rw-r--r--x11/i3status/distinfo6
-rw-r--r--x11/i3status/files/patch-meson.build21
-rw-r--r--x11/i3status/files/patch-src_print__battery__info.c11
-rw-r--r--x11/i3status/files/patch-src_print__disk__info.c32
-rw-r--r--x11/i3status/files/patch-src_print__volume.c34
-rw-r--r--x11/i3status/files/patch-src_pulse.c12
7 files changed, 99 insertions, 31 deletions
diff --git a/x11/i3status/Makefile b/x11/i3status/Makefile
index b23feac969f5..7245ec74328d 100644
--- a/x11/i3status/Makefile
+++ b/x11/i3status/Makefile
@@ -1,5 +1,5 @@
PORTNAME= i3status
-PORTVERSION= 2.13
+PORTVERSION= 2.14
CATEGORIES= x11
MASTER_SITES= http://i3wm.org/i3status/
@@ -12,19 +12,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libconfuse.so:devel/libconfuse \
libyajl.so:devel/yajl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_path_PATH_ASCIIDOC=${TRUE} \
- ac_cv_path_PATH_XMLTO=${TRUE} \
- --disable-dependency-tracking
-USES= gmake pkgconfig tar:bzip2
-BUILD_WRKSRC= ${WRKSRC}/${CONFIGURE_TARGET}
-INSTALL_WRKSRC= ${WRKSRC}/${CONFIGURE_TARGET}
+USES= meson pkgconfig tar:xz perl5
+MESON_ARGS= -Dpulseaudio=false
+USE_PERL5= build
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/i3status.c
post-install:
- ${INSTALL_DATA} ${WRKSRC}/i3status.conf \
+ ${INSTALL_DATA} ${WRKSRC}/etc/i3status.conf \
${STAGEDIR}${PREFIX}/etc/i3status.conf.sample
.include <bsd.port.mk>
diff --git a/x11/i3status/distinfo b/x11/i3status/distinfo
index d2151d833382..dbf824523e13 100644
--- a/x11/i3status/distinfo
+++ b/x11/i3status/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1564643344
-SHA256 (i3status-2.13.tar.bz2) = ce89c9ff8565f62e88299f1a611229afdfc356b4e97368a5f8c4f06ad2fa1466
-SIZE (i3status-2.13.tar.bz2) = 201409
+TIMESTAMP = 1636561077
+SHA256 (i3status-2.14.tar.xz) = 5c4d0273410f9fa3301fd32065deda32e9617fcae8b3cb34793061bf21644924
+SIZE (i3status-2.14.tar.xz) = 68900
diff --git a/x11/i3status/files/patch-meson.build b/x11/i3status/files/patch-meson.build
new file mode 100644
index 000000000000..c6bb9218ca60
--- /dev/null
+++ b/x11/i3status/files/patch-meson.build
@@ -0,0 +1,21 @@
+--- meson.build.orig 2021-11-12 10:03:11 UTC
++++ meson.build
+@@ -222,15 +222,15 @@ install_subdir(
+ # because configure_file strips the backslash in e.g. \@display,
+ # resulting in @display, breaking our Perl code:
+ # https://github.com/mesonbuild/meson/issues/7165
+-bash = find_program('bash')
++sh = find_program('sh')
+ replace_dirs = [
+- bash, '-c', # Use bash to capture output and mark as executable
++ sh, '-c', # Use bash to capture output and mark as executable
+ 'sed -e \'s,@abs_top_builddir@,'
+ + meson.current_build_dir()
+ + ',g;s,@abs_top_srcdir@,'
+ + meson.current_source_dir()+',g\''
+ # Only mark files ending in .pl as executables
+- + ' "$0" > "$1" && { [[ "${1##*.}" == pl ]] && chmod +x "$1" || true; }',
++ + ' "$0" > "$1" && { [ "${1##*.}" = pl ] && chmod +x "$1" || true; }',
+ '@INPUT0@', # $0
+ '@OUTPUT0@', # $1
+ ]
diff --git a/x11/i3status/files/patch-src_print__battery__info.c b/x11/i3status/files/patch-src_print__battery__info.c
new file mode 100644
index 000000000000..e038c2b2c491
--- /dev/null
+++ b/x11/i3status/files/patch-src_print__battery__info.c
@@ -0,0 +1,11 @@
+--- src/print_battery_info.c.orig 2021-11-09 07:27:11 UTC
++++ src/print_battery_info.c
+@@ -595,7 +595,7 @@ void print_battery_info(battery_info_ctx_t *ctx) {
+ #endif
+ #if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__) || defined(__OpenBSD__)
+ /* These OSes report battery time in minutes. */
+- hide_seconds = true;
++ ctx->hide_seconds = true;
+ #endif
+
+ if (ctx->number < 0) {
diff --git a/x11/i3status/files/patch-src_print__disk__info.c b/x11/i3status/files/patch-src_print__disk__info.c
new file mode 100644
index 000000000000..cf8308f5e2e0
--- /dev/null
+++ b/x11/i3status/files/patch-src_print__disk__info.c
@@ -0,0 +1,32 @@
+--- src/print_disk_info.c.orig 2021-11-10 16:46:42 UTC
++++ src/print_disk_info.c
+@@ -63,7 +63,7 @@ static int print_bytes_human(char *outwalk, uint64_t b
+ * Determines whether remaining bytes are below given threshold.
+ *
+ */
+-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
++#if defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
+ static bool below_threshold(struct statfs buf, const char *prefix_type, const char *threshold_type, const double low_threshold) {
+ #else
+ static bool below_threshold(struct statvfs buf, const char *prefix_type, const char *threshold_type, const double low_threshold) {
+@@ -124,17 +124,17 @@ void print_disk_info(disk_info_ctx_t *ctx) {
+
+ INSTANCE(ctx->path);
+
+-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
++#if defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
+ struct statfs buf;
+
+ if (statfs(path, &buf) == -1)
+ return;
+
+ mounted = true;
+-#elif defined(__NetBSD__)
++#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+ struct statvfs buf;
+
+- if (statvfs(path, &buf) == -1)
++ if (statvfs(ctx->path, &buf) == -1)
+ return;
+
+ mounted = true;
diff --git a/x11/i3status/files/patch-src_print__volume.c b/x11/i3status/files/patch-src_print__volume.c
index a15fc4ed6fd0..a553383ad098 100644
--- a/x11/i3status/files/patch-src_print__volume.c
+++ b/x11/i3status/files/patch-src_print__volume.c
@@ -1,11 +1,31 @@
---- src/print_volume.c.orig 2019-01-23 08:03:56 UTC
+--- src/print_volume.c.orig 2021-11-09 07:27:11 UTC
+++ src/print_volume.c
-@@ -86,7 +86,7 @@ void print_volume(yajl_gen json_gen, char *buffer, con
- free(instance);
+@@ -250,8 +250,8 @@ void print_volume(volume_ctx_t *ctx) {
+ const char *devicename = "UNSUPPORTED"; /* TODO: implement support for this */
+ pbval = 1;
+
+- if (mixer_idx > 0)
+- asprintf(&mixerpath, "/dev/mixer%d", mixer_idx);
++ if (ctx->mixer_idx > 0)
++ asprintf(&mixerpath, "/dev/mixer%d", ctx->mixer_idx);
+ else
+ mixerpath = defaultmixer;
+
+@@ -264,7 +264,7 @@ void print_volume(volume_ctx_t *ctx) {
+ goto out;
}
--#if !defined(__DragonFly__) && !defined(__OpenBSD__)
-+#if !defined(__DragonFly__) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
- /* Try PulseAudio first */
+- if (mixer_idx > 0)
++ if (ctx->mixer_idx > 0)
+ free(mixerpath);
+
+ #if defined(__NetBSD__) || defined(__OpenBSD__)
+@@ -351,7 +351,7 @@ void print_volume(volume_ctx_t *ctx) {
+ }
- /* If the device name has the format "pulse[:N]" where N is the
+ #endif
+- buffer = apply_volume_format(fmt, buffer, vol & 0x7f, devicename);
++ ctx->buf = apply_volume_format(ctx->fmt, vol & 0x7f, devicename);
+ close(mixfd);
+ goto out_with_format;
+ #endif
diff --git a/x11/i3status/files/patch-src_pulse.c b/x11/i3status/files/patch-src_pulse.c
deleted file mode 100644
index c7bdcb952a75..000000000000
--- a/x11/i3status/files/patch-src_pulse.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/pulse.c.orig 2019-01-23 08:03:56 UTC
-+++ src/pulse.c
-@@ -1,3 +1,4 @@
-+#ifndef __FreeBSD__
- // vim:ts=4:sw=4:expandtab
- #include <config.h>
- #include <string.h>
-@@ -337,3 +338,4 @@ bool pulse_initialize(void) {
- }
- return true;
- }
-+#endif