aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/perl5-devel/Makefile2
-rw-r--r--lang/perl5.24/Makefile2
-rw-r--r--lang/perl5.26/Makefile2
-rw-r--r--lang/perl5.28/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/lang/perl5-devel/Makefile b/lang/perl5-devel/Makefile
index e6d5fd14c6b1..36c901c96cf9 100644
--- a/lang/perl5-devel/Makefile
+++ b/lang/perl5-devel/Makefile
@@ -184,6 +184,8 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
# XXX Remove and change to PERL_VERSION in the plist.
PLIST_SUB+= LIBPERL_VER=${LIBPERL_VER}
+# Why this is required is explained in:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227356#c5
_PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
# Get the default version, and possibly, overwrite it.
diff --git a/lang/perl5.24/Makefile b/lang/perl5.24/Makefile
index fbcf55ae7e5b..b3bad6f8d81d 100644
--- a/lang/perl5.24/Makefile
+++ b/lang/perl5.24/Makefile
@@ -158,6 +158,8 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PKGNAMESUFFIX=${PKGNAMESUFFIX} \
ARCH_LIB=${_ARCH_LIB}
+# Why this is required is explained in:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227356#c5
_PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
# Get the default version, and possibly, overwrite it.
diff --git a/lang/perl5.26/Makefile b/lang/perl5.26/Makefile
index 75a3d2832daa..aa6455a84902 100644
--- a/lang/perl5.26/Makefile
+++ b/lang/perl5.26/Makefile
@@ -159,6 +159,8 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PKGNAMESUFFIX=${PKGNAMESUFFIX} \
ARCH_LIB=${_ARCH_LIB}
+# Why this is required is explained in:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227356#c5
_PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
# Get the default version, and possibly, overwrite it.
diff --git a/lang/perl5.28/Makefile b/lang/perl5.28/Makefile
index dc7b42745676..c9e1f0d83d41 100644
--- a/lang/perl5.28/Makefile
+++ b/lang/perl5.28/Makefile
@@ -160,6 +160,8 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PKGNAMESUFFIX=${PKGNAMESUFFIX} \
ARCH_LIB=${_ARCH_LIB}
+# Why this is required is explained in:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227356#c5
_PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
# Get the default version, and possibly, overwrite it.