aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/firefox/Makefile8
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug177942548
3 files changed, 7 insertions, 55 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 57f008a46fe3..839e21af6b22 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,5 +1,5 @@
PORTNAME= firefox
-DISTVERSION= 103.0.2
+DISTVERSION= 104.0
PORTEPOCH= 2
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}${DISTVERSIONSUFFIX}/source \
@@ -10,14 +10,14 @@ MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.32:devel/nspr \
- nss>=3.80:security/nss \
+ nss>=3.81:security/nss \
icu>=71.1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=4.3.0:print/harfbuzz \
+ harfbuzz>=4.4.1:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
dav1d>=1.0.0:multimedia/dav1d \
- libvpx>=1.11.0:multimedia/libvpx \
+ libvpx>=1.12.0:multimedia/libvpx \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
v4l_compat>0:multimedia/v4l_compat \
autoconf2.13:devel/autoconf2.13 \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 6765dc3c5daa..d7343b718dfe 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659975173
-SHA256 (firefox-103.0.2.source.tar.xz) = 766183e8e39c17a84305a85da3237919ffaeb018c6c9d97a7324aea51bd453aa
-SIZE (firefox-103.0.2.source.tar.xz) = 481280156
+TIMESTAMP = 1660590251
+SHA256 (firefox-104.0.source.tar.xz) = 939d2eafadcc6fa61b1ae415f340d38f53fea1c7136e5667bfb0f6075c6fca28
+SIZE (firefox-104.0.source.tar.xz) = 478706356
diff --git a/www/firefox/files/patch-bug1779425 b/www/firefox/files/patch-bug1779425
deleted file mode 100644
index 9ab5f99d3b6d..000000000000
--- a/www/firefox/files/patch-bug1779425
+++ /dev/null
@@ -1,48 +0,0 @@
-commit 9583d02e454318568191e5c31c51c34fd1332182
-Author: Robert Mader <robert.mader@posteo.de>
-Date: Tue Jul 19 21:52:04 2022 +0000
-
- Bug 1779425 - Check for GbmDevice before using it, r=stransky,jgilbert
-
- In some non-standard configurations we unexpectedly end up in this paths
- without a GBM device - one example being the GPU process. Fail cleanly
- instead of crashing in those cases, triggering fallback paths.
-
- Context: in the past DMABuf usage was tightly coupled to GBM. Since the
- introduction of the surfaceless and device EGL platforms that is not
- longer the case, thus we can't make checks like `IsDMABufWebGLEnabled()`
- depend on the presence of a GBM device.
-
- Optimally all affected cases get fixed eventually. Until then and also
- for future cases it makes sense to fail softly.
-
- Differential Revision: https://phabricator.services.mozilla.com/D152173
-
-diff --git widget/gtk/DMABufSurface.cpp widget/gtk/DMABufSurface.cpp
-index 92c8e75218f8..7fddb32c7cda 100644
---- widget/gtk/DMABufSurface.cpp
-+++ widget/gtk/DMABufSurface.cpp
-@@ -382,6 +382,11 @@ bool DMABufSurfaceRGBA::Create(int aWidth, int aHeight,
- LOGDMABUF(("DMABufSurfaceRGBA::Create() UID %d size %d x %d\n", mUID, mWidth,
- mHeight));
-
-+ if (!GetDMABufDevice()->GetGbmDevice()) {
-+ LOGDMABUF((" Missing GbmDevice!"));
-+ return false;
-+ }
-+
- mGmbFormat = GetDMABufDevice()->GetGbmFormat(mSurfaceFlags & DMABUF_ALPHA);
- if (!mGmbFormat) {
- // Requested DRM format is not supported.
-@@ -1025,6 +1030,11 @@ bool DMABufSurfaceYUV::CreateYUVPlane(int aPlane, int aWidth, int aHeight,
- LOGDMABUF(("DMABufSurfaceYUV::CreateYUVPlane() UID %d size %d x %d", mUID,
- aWidth, aHeight));
-
-+ if (!GetDMABufDevice()->GetGbmDevice()) {
-+ LOGDMABUF((" Missing GbmDevice!"));
-+ return false;
-+ }
-+
- mWidth[aPlane] = aWidth;
- mHeight[aPlane] = aHeight;
- mDrmFormats[aPlane] = aDrmFormat;