aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pdsh/Makefile40
-rw-r--r--sysutils/pdsh/distinfo3
-rw-r--r--sysutils/pdsh/pkg-descr6
-rw-r--r--sysutils/pdsh/pkg-plist23
6 files changed, 73 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index f4ed42c559a6..95f660e1f6cd 100644
--- a/MOVED
+++ b/MOVED
@@ -9128,7 +9128,6 @@ sysutils/sievelog||2017-04-30|Has expired: Unfetchable for more than six months
sysutils/ldapenter||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
sysutils/py-danzfs||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
sysutils/plasma-applet-apcups||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
-sysutils/pdsh||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
deskutils/superswitcher||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
deskutils/plasma-applet-playwolf||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
deskutils/nagaina||2017-04-30|Has expired: Unfetchable for more than six months (google code has gone away)
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1d2a890c5f8a..23ca755b171b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -927,6 +927,7 @@
SUBDIR += pciutils
SUBDIR += pcpustat
SUBDIR += pdixtract
+ SUBDIR += pdsh
SUBDIR += pdumpfs
SUBDIR += pear-Cache
SUBDIR += pear-Cache_Lite
diff --git a/sysutils/pdsh/Makefile b/sysutils/pdsh/Makefile
new file mode 100644
index 000000000000..e61679e14b53
--- /dev/null
+++ b/sysutils/pdsh/Makefile
@@ -0,0 +1,40 @@
+# Created by: Mykola Dzham <i@levsha.me>
+
+PORTNAME= pdsh
+PORTVERSION= 2.34
+DISTVERSIONPREFIX= ${PORTNAME}-
+CATEGORIES= sysutils
+
+MAINTAINER= i@levsha.me
+COMMENT= Parallel Distributed Shell
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+# :keepla because port uses lt_dlopen
+USES= autoreconf gmake libtool:keepla shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= chaos
+USE_PERL5= run
+SHEBANG_FILES= scripts/dshbak
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+
+OPTIONS_DEFINE= SSH DSHGROUPS NETGROUP READLINE RSH
+OPTIONS_DEFAULT= SSH DSHGROUPS
+OPTIONS_SUB= yes
+DSHGROUPS_DESC= DSH groups support
+DSHGROUPS_CONFIGURE_WITH= dshgroups
+NETGROUP_DESC= NIS Netgroup support
+NETGROUP_CONFIGURE_WITH=netgroup
+READLINE_CONFIGURE_WITH=readline
+READLINE_USES= readline
+RSH_DESC= RSH support
+RSH_CONFIGURE_WITH= rsh
+SSH_CONFIGURE_WITH= ssh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,m4_esyscmd.*,[${PORTVERSION}]),' \
+ ${WRKSRC}/configure.ac
+
+.include <bsd.port.mk>
diff --git a/sysutils/pdsh/distinfo b/sysutils/pdsh/distinfo
new file mode 100644
index 000000000000..d01fb2b8fe63
--- /dev/null
+++ b/sysutils/pdsh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578433486
+SHA256 (chaos-pdsh-pdsh-2.34_GH0.tar.gz) = 36e1b3c734ae9b4baf054c656b9735206cc56b290d2c0ec4f7825cdd9f7dff54
+SIZE (chaos-pdsh-pdsh-2.34_GH0.tar.gz) = 215708
diff --git a/sysutils/pdsh/pkg-descr b/sysutils/pdsh/pkg-descr
new file mode 100644
index 000000000000..1c2b21ce2f76
--- /dev/null
+++ b/sysutils/pdsh/pkg-descr
@@ -0,0 +1,6 @@
+Pdsh is a high-performance, parallel remote shell utility. It uses a sliding
+window of threads to execute remote commands, conserving socket resources while
+allowing some connections to timeout if needed. It was originally written as a
+replacement for IBM's DSH on clusters at LLNL.
+
+WWW: https://github.com/chaos/pdsh
diff --git a/sysutils/pdsh/pkg-plist b/sysutils/pdsh/pkg-plist
new file mode 100644
index 000000000000..5f21f457e088
--- /dev/null
+++ b/sysutils/pdsh/pkg-plist
@@ -0,0 +1,23 @@
+bin/dshbak
+bin/pdcp
+bin/pdsh
+bin/rpdcp
+lib/pdsh/execcmd.a
+lib/pdsh/execcmd.la
+lib/pdsh/execcmd.so
+%%DSHGROUPS%%lib/pdsh/dshgroup.a
+%%DSHGROUPS%%lib/pdsh/dshgroup.la
+%%DSHGROUPS%%lib/pdsh/dshgroup.so
+%%NETGROUP%%lib/pdsh/netgroup.a
+%%NETGROUP%%lib/pdsh/netgroup.la
+%%NETGROUP%%lib/pdsh/netgroup.so
+%%SSH%%lib/pdsh/sshcmd.a
+%%SSH%%lib/pdsh/sshcmd.la
+%%SSH%%lib/pdsh/sshcmd.so
+%%RSH%%lib/pdsh/xrcmd.a
+%%RSH%%lib/pdsh/xrcmd.la
+%%RSH%%lib/pdsh/xrcmd.so
+man/man1/dshbak.1.gz
+man/man1/pdcp.1.gz
+man/man1/pdsh.1.gz
+man/man1/rpdcp.1.gz