aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/php.mk6
-rw-r--r--lang/php82/Makefile23
-rw-r--r--lang/php82/distinfo6
-rw-r--r--lang/php82/files/patch-build_Makefile.global4
-rw-r--r--lang/php82/files/patch-configure.ac10
-rw-r--r--lang/php82/files/patch-ext_hash_xxhash_xxhash.h4
-rw-r--r--lang/php82/files/patch-ext_mysqli_mysqli__nonapi.c6
-rw-r--r--lang/php82/files/patch-ext_mysqli_mysqli__prop.c6
-rw-r--r--lang/php82/files/patch-ext_pcre_pcre2lib_sljit_sljitConfigInternal.h21
-rw-r--r--lang/php82/pkg-plist1
10 files changed, 54 insertions, 33 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index a17c82ac344d..b4cc5a376b6c 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -185,7 +185,7 @@ PHP_VER= ${FLAVOR:S/^php//}
# Mk/bsd.default-versions.mk in sync.
. if ${PHP_VER} == 82
PHP_EXT_DIR= 20210903
-PHP_EXT_INC= hash json openssl pcre spl
+PHP_EXT_INC= hash json openssl pcre random spl
. elif ${PHP_VER} == 81
PHP_EXT_DIR= 20210902
PHP_EXT_INC= hash json openssl pcre spl
@@ -387,8 +387,8 @@ _USE_PHP_ALL= bcmath bitset bz2 calendar ctype curl dba dom \
memcache memcached mysqli odbc opcache \
openssl pcntl pcre pdo pdo_dblib pdo_firebird pdo_mysql \
pdo_odbc pdo_pgsql pdo_sqlite phar pgsql posix \
- pspell radius readline redis session shmop simplexml snmp soap\
- sockets sodium spl sqlite3 sysvmsg sysvsem sysvshm \
+ pspell radius random readline redis session shmop simplexml snmp \
+ soap sockets sodium spl sqlite3 sysvmsg sysvsem sysvshm \
tidy tokenizer xml xmlreader xmlrpc xmlwriter xsl zip zlib
# version specific components
_USE_PHP_VER74= ${_USE_PHP_ALL} pdf
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index df244e8f6d73..ba2eab28a95b 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php82
-DISTVERSION= 8.2.0alpha3
+DISTVERSION= 8.2.0beta2
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= https://downloads.php.net/~sergey/
@@ -142,19 +142,30 @@ post-build:
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} -n "PHP_EXT_DIR=" >> ${WRKDIR}/php.conf
@${SH} ${WRKSRC}/scripts/php-config --extension-dir | ${SED} -ne 's,^${PREFIX}/lib/php/,,p' >> ${WRKDIR}/php.conf
- @${ECHO_CMD} "PHP_EXT_INC=hash json openssl pcre spl" >> ${WRKDIR}/php.conf
+ @${ECHO_CMD} "PHP_EXT_INC=hash json openssl pcre random spl" >> ${WRKDIR}/php.conf
test: build
@(cd ${WRKSRC} && ${MAKE} test)
post-install:
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php-cgi
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/phpdbg
+ ${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
+ ${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
+
+post-install-CLI-on:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php
+
+post-install-CGI-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php-cgi
+
+post-install-EMBED-on:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libphp.so
+
+post-install-FPM-on:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/sbin/php-fpm
- ${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
- ${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
+
+post-install-PHPDBG-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/phpdbg
+
.else
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
diff --git a/lang/php82/distinfo b/lang/php82/distinfo
index dc064f4bb8d6..5038b2418f14 100644
--- a/lang/php82/distinfo
+++ b/lang/php82/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1657140674
-SHA256 (php-8.2.0alpha3.tar.xz) = 8960799d88319fedb6a4b6be16a9fa08069116169b6b34aec50eb418a411a2e8
-SIZE (php-8.2.0alpha3.tar.xz) = 11743380
+TIMESTAMP = 1659606224
+SHA256 (php-8.2.0beta2.tar.xz) = cffb46d5458b52e93876584c77631620003e420cbe119fe864925fca188e01bd
+SIZE (php-8.2.0beta2.tar.xz) = 11828116
diff --git a/lang/php82/files/patch-build_Makefile.global b/lang/php82/files/patch-build_Makefile.global
index 4b838d157941..266f29958043 100644
--- a/lang/php82/files/patch-build_Makefile.global
+++ b/lang/php82/files/patch-build_Makefile.global
@@ -1,6 +1,6 @@
---- build/Makefile.global.orig 2019-08-06 06:54:07 UTC
+--- build/Makefile.global.orig 2022-08-02 13:57:03 UTC
+++ build/Makefile.global
-@@ -89,14 +89,14 @@ test: all
+@@ -92,14 +92,14 @@ test: all
@if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
if test "$$INI_FILE"; then \
diff --git a/lang/php82/files/patch-configure.ac b/lang/php82/files/patch-configure.ac
index b8c26f6c43f1..edf17428ebee 100644
--- a/lang/php82/files/patch-configure.ac
+++ b/lang/php82/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2021-12-15 02:00:45 UTC
+--- configure.ac.orig 2022-08-02 13:57:03 UTC
+++ configure.ac
@@ -55,6 +55,7 @@ AH_BOTTOM([
@@ -8,7 +8,7 @@
#endif /* PHP_CONFIG_H */
])
-@@ -273,7 +274,6 @@ sinclude(Zend/Zend.m4)
+@@ -279,7 +280,6 @@ dnl --------------------------------------------------
dnl ----------------------------------------------------------------------------
@@ -16,7 +16,7 @@
PHP_HELP_SEPARATOR([SAPI modules:])
PHP_SHLIB_SUFFIX_NAMES
PHP_BUILD_PROGRAM
-@@ -614,7 +614,7 @@ memmem \
+@@ -627,7 +627,7 @@ dnl Some systems (like OpenSolaris) do not have nanosl
AX_FUNC_WHICH_GETHOSTBYNAME_R
dnl Some systems (like OpenSolaris) do not have nanosleep in libc.
@@ -25,7 +25,7 @@
dnl Haiku does not have network api in libc.
PHP_CHECK_FUNC_LIB(setsockopt, network)
-@@ -1360,7 +1360,7 @@ EXPANDED_SYSCONFDIR=`eval echo $sysconfdir`
+@@ -1375,7 +1375,7 @@ EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CON
EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
@@ -34,7 +34,7 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1579,7 +1579,7 @@ PHP_SUBST(all_targets)
+@@ -1600,7 +1600,7 @@ PHP_SUBST(install_binary_targets)
PHP_SUBST(install_targets)
PHP_SUBST(install_binary_targets)
diff --git a/lang/php82/files/patch-ext_hash_xxhash_xxhash.h b/lang/php82/files/patch-ext_hash_xxhash_xxhash.h
index 27abdbc2af76..714a074f7050 100644
--- a/lang/php82/files/patch-ext_hash_xxhash_xxhash.h
+++ b/lang/php82/files/patch-ext_hash_xxhash_xxhash.h
@@ -1,6 +1,6 @@
---- ext/hash/xxhash/xxhash.h.orig 2022-01-04 18:37:17 UTC
+--- ext/hash/xxhash/xxhash.h.orig 2022-08-02 13:57:03 UTC
+++ ext/hash/xxhash/xxhash.h
-@@ -2395,22 +2395,32 @@ XXH_PUBLIC_API XXH64_hash_t XXH64_hashFromCanonical(co
+@@ -3048,22 +3048,32 @@ enum XXH_VECTOR_TYPE /* fake enum */ {
* inconsistent intrinsics, spotty coverage, and multiple endiannesses.
*/
#if XXH_VECTOR == XXH_VSX
diff --git a/lang/php82/files/patch-ext_mysqli_mysqli__nonapi.c b/lang/php82/files/patch-ext_mysqli_mysqli__nonapi.c
index 9baa04218bf9..83d0d8dfc8cb 100644
--- a/lang/php82/files/patch-ext_mysqli_mysqli__nonapi.c
+++ b/lang/php82/files/patch-ext_mysqli_mysqli__nonapi.c
@@ -1,6 +1,6 @@
---- ext/mysqli/mysqli_nonapi.c.orig 2020-01-09 11:40:57 UTC
+--- ext/mysqli/mysqli_nonapi.c.orig 2022-08-02 13:57:03 UTC
+++ ext/mysqli/mysqli_nonapi.c
-@@ -28,7 +28,9 @@
+@@ -26,7 +26,9 @@
#include "php_ini.h"
#include "ext/standard/info.h"
#include "zend_smart_str.h"
@@ -8,5 +8,5 @@
#include "php_mysqli_structs.h"
+#endif
#include "mysqli_priv.h"
+ #define ERROR_ARG_POS(arg_num) (getThis() ? (arg_num-1) : (arg_num))
- #define SAFE_STR(a) ((a)?a:"")
diff --git a/lang/php82/files/patch-ext_mysqli_mysqli__prop.c b/lang/php82/files/patch-ext_mysqli_mysqli__prop.c
index 37d47a304440..bc201d57981e 100644
--- a/lang/php82/files/patch-ext_mysqli_mysqli__prop.c
+++ b/lang/php82/files/patch-ext_mysqli_mysqli__prop.c
@@ -1,6 +1,6 @@
---- ext/mysqli/mysqli_prop.c.orig 2020-01-09 11:40:11 UTC
+--- ext/mysqli/mysqli_prop.c.orig 2022-08-02 13:57:03 UTC
+++ ext/mysqli/mysqli_prop.c
-@@ -26,7 +26,9 @@
+@@ -24,7 +24,9 @@
#include "php.h"
#include "php_ini.h"
#include "ext/standard/info.h"
@@ -9,4 +9,4 @@
+#endif
#include "mysqli_priv.h"
- #define CHECK_STATUS(value) \
+ #define CHECK_STATUS(value, quiet) \
diff --git a/lang/php82/files/patch-ext_pcre_pcre2lib_sljit_sljitConfigInternal.h b/lang/php82/files/patch-ext_pcre_pcre2lib_sljit_sljitConfigInternal.h
index 9a75bc3e86c1..12705b62543e 100644
--- a/lang/php82/files/patch-ext_pcre_pcre2lib_sljit_sljitConfigInternal.h
+++ b/lang/php82/files/patch-ext_pcre_pcre2lib_sljit_sljitConfigInternal.h
@@ -1,11 +1,20 @@
---- ext/pcre/pcre2lib/sljit/sljitConfigInternal.h.orig 2022-03-25 09:54:56 UTC
+--- ext/pcre/pcre2lib/sljit/sljitConfigInternal.h.orig 2022-08-02 13:57:03 UTC
+++ ext/pcre/pcre2lib/sljit/sljitConfigInternal.h
-@@ -283,7 +283,7 @@
- /* Instruction cache flush. */
- /****************************/
+@@ -303,7 +303,7 @@ extern "C" {
+ /* Type of public API functions. */
+ /*********************************/
+-#ifndef SLJIT_API_FUNC_ATTRIBUTE
++#ifndef SLJIT_API_FUNC_ATTRIBUTE
+ #if (defined SLJIT_CONFIG_STATIC && SLJIT_CONFIG_STATIC)
+ /* Static ABI functions. For all-in-one programs. */
+
+@@ -333,7 +333,7 @@ extern "C" {
+ * beware APPLE is known to have removed the code in iOS so
+ * it will need to be excempted or result in broken builds
+ */
-#if (!defined SLJIT_CACHE_FLUSH && defined __has_builtin)
+#if (!defined SLJIT_CACHE_FLUSH && defined __has_builtin && !defined SLJIT_CONFIG_PPC_32)
- #if __has_builtin(__builtin___clear_cache)
+ #if __has_builtin(__builtin___clear_cache) && !defined(__clang__)
- #define SLJIT_CACHE_FLUSH(from, to) \
+ /*
diff --git a/lang/php82/pkg-plist b/lang/php82/pkg-plist
index 5431942e973b..215399f5b9ad 100644
--- a/lang/php82/pkg-plist
+++ b/lang/php82/pkg-plist
@@ -172,6 +172,7 @@ include/php/ext/pcre/pcre2lib/pcre2_jit_neon_inc.h
include/php/ext/pcre/pcre2lib/pcre2_jit_simd_inc.h
include/php/ext/pcre/pcre2lib/pcre2_ucp.h
include/php/ext/pcre/php_pcre.h
+include/php/ext/random/php_random.h
include/php/ext/spl/php_spl.h
include/php/ext/spl/spl_array.h
include/php/ext/spl/spl_directory.h