aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--security/greenbone-security-assistant/Makefile64
-rw-r--r--security/greenbone-security-assistant/distinfo5
-rw-r--r--security/greenbone-security-assistant/files/gsad.in27
-rw-r--r--security/greenbone-security-assistant/files/patch-CMakeLists.txt11
-rw-r--r--security/greenbone-security-assistant/files/patch-gsa_CMakeLists.txt11
-rw-r--r--security/greenbone-security-assistant/files/patch-gsad-src_gsad_gmp.c13
-rw-r--r--security/greenbone-security-assistant/files/patch-gsad_CMakeLists.txt40
-rw-r--r--security/greenbone-security-assistant/pkg-descr10
9 files changed, 1 insertions, 181 deletions
diff --git a/MOVED b/MOVED
index 25b554172cbc..74b40bdc9081 100644
--- a/MOVED
+++ b/MOVED
@@ -17167,3 +17167,4 @@ devel/rubygem-cucumber-messages4|devel/rubygem-cucumber-messages|2022-05-22|Remo
devel/rubygem-cucumber-messages17|devel/rubygem-cucumber-messages|2022-05-22|Remove obsoleted port. Use devel/rubygem-cucumber-messages instead
textproc/rubygem-cucumber-gherkin22|textproc/rubygem-cucumber-gherkin|2022-05-22|Remove obsoleted port. Use textproc/rubygem-cucumber-gherkin instead
textproc/rubygem-cucumber-html-formatter17|textproc/rubygem-cucumber-html-formatter|2022-05-22|Remove obsoleted port. Use textproc/rubygem-cucumber-html-formatter instead
+security/greenbone-security-assistant|security/gsa|2022-05-22|It was splitted into security/gsad and security/gsa
diff --git a/security/greenbone-security-assistant/Makefile b/security/greenbone-security-assistant/Makefile
deleted file mode 100644
index 88fdc5a8a447..000000000000
--- a/security/greenbone-security-assistant/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-PORTNAME= greenbone-security-assistant
-DISTVERSIONPREFIX= v
-DISTVERSION= 21.4.3
-PORTREVISION= 5
-CATEGORIES= security
-MASTER_SITES= LOCAL/acm/gsa/:yarn_cache
-DISTFILES= ${PORTNAME}-cache${EXTRACT_SUFX}:yarn_cache
-
-MAINTAINER= acm@FreeBSD.org
-COMMENT= Libraries module for the GVM solution
-
-LICENSE= AGPLv3+
-
-BUILD_DEPENDS= yarn:www/yarn
-LIB_DEPENDS= libgvm_base.so:security/gvm-libs \
- libgnutls.so:security/gnutls \
- libgcrypt.so:security/libgcrypt \
- libgpg-error.so:security/libgpg-error \
- libmicrohttpd.so:www/libmicrohttpd
-RUN_DEPENDS= doxygen>0:devel/doxygen \
- ${PYTHON_PKGNAMEPREFIX}polib>=0:devel/py-polib@${PY_FLAVOR}
-
-USES= cmake gettext-runtime gnome nodejs:build pkgconfig python
-USE_GNOME= glib20 libxml2
-
-USE_GITHUB= yes
-GH_ACCOUNT= greenbone
-GH_PROJECT= gsa
-
-CMAKE_ARGS+= -DINSTALLER_ARGS="--offline"
-
-USERS= gvm
-GROUPS= ${USERS}
-
-USE_RC_SUBR= gsad
-
-LDFLAGS+= -lm
-
-ETCDIR= ${PREFIX}/etc/gvm
-
-post-extract:
- @${MV} ${WRKSRC}/gsad/src/gsad_log_conf.cmake_in ${WRKSRC}/gsad/src/gsad_log.conf.sample
-
-post-patch:
- ${ECHO_CMD} 'yarn-offline-mirror "${WRKDIR}/yarn-offline-cache"' >> \
- ${WRKSRC}/.yarnrc
- ${REINPLACE_CMD} -e 's|$${GVM_LOG_DIR}|/var/log/gvm|g' ${WRKSRC}/gsad/src/gsad_log.conf.sample
-
-post-install:
- @${MKDIR} ${STAGEDIR}/var/run/gvm
- @${MKDIR} ${STAGEDIR}${ETCDIR}
- @${INSTALL_DATA} ${WRKSRC}/gsad/src/gsad_log.conf.sample ${STAGEDIR}${ETCDIR}
-
- @${ECHO_CMD} "@sample etc/gvm/gsad_log.conf.sample" >> ${TMPPLIST}
- @${ECHO_CMD} "sbin/gsad" >> ${TMPPLIST} >> ${TMPPLIST}
- @${ECHO_CMD} "share/gvm/gsad/web/index.html" >> ${TMPPLIST}
- @${ECHO_CMD} "share/gvm/gsad/web/robots.txt" >> ${TMPPLIST}
- @cd ${WRKSRC}/gsa/build && \
- ${FIND} -s img locales static -not -type d \
- -exec ${ECHO_CMD} "share/gvm/gsad/web/{}" \; >> ${TMPPLIST}
- @${ECHO_CMD} "share/man/man8/gsad.8.gz" >> ${TMPPLIST}
- @${ECHO_CMD} "@dir(gvm,gvm,750) /var/run/gvm" >> ${TMPPLIST}
-
-.include <bsd.port.mk>
diff --git a/security/greenbone-security-assistant/distinfo b/security/greenbone-security-assistant/distinfo
deleted file mode 100644
index 5572ffb164cf..000000000000
--- a/security/greenbone-security-assistant/distinfo
+++ /dev/null
@@ -1,5 +0,0 @@
-TIMESTAMP = 1636050519
-SHA256 (greenbone-security-assistant-cache.tar.gz) = 3e54c1f845f64064f590a99b2229da8d72a638e210288890b1adb26ed6c41580
-SIZE (greenbone-security-assistant-cache.tar.gz) = 61974237
-SHA256 (greenbone-gsa-v21.4.3_GH0.tar.gz) = 7b30416fb76cfbec2f2e409706e0ebb40a123d197c8ff7d6c12b71f1572047a3
-SIZE (greenbone-gsa-v21.4.3_GH0.tar.gz) = 2683994
diff --git a/security/greenbone-security-assistant/files/gsad.in b/security/greenbone-security-assistant/files/gsad.in
deleted file mode 100644
index 8de12ff99fa6..000000000000
--- a/security/greenbone-security-assistant/files/gsad.in
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-# PROVIDE: gsad
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following to /etc/rc.conf[.local] to enable this service
-#
-# gsad_enable (bool): Set to NO by default.
-# Set it to YES to enable gsad.
-# gsad_flags (params): Set params used to start gsad.
-#
-
-. /etc/rc.subr
-
-load_rc_config $name
-
-: ${gsad_enable="NO"}
-: ${gsad_flags="--http-cors="http://127.0.0.1" -k /var/lib/gvm/private/CA/serverkey.pem -c /var/lib/gvm/CA/servercert.pem --munix-socket=/var/run/gvm/gvmd.sock"}
-
-name=gsad
-rcvar=${name}_enable
-command="%%PREFIX%%/sbin/gsad"
-command_args="${gsad_flags}"
-pidfile=/var/run/gvm/gsad.pid
-
-run_rc_command "$1"
diff --git a/security/greenbone-security-assistant/files/patch-CMakeLists.txt b/security/greenbone-security-assistant/files/patch-CMakeLists.txt
deleted file mode 100644
index 2ea3d5a87997..000000000000
--- a/security/greenbone-security-assistant/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt 2021-01-04 10:09:59.295410000 -0500
-+++ CMakeLists.txt 2021-01-04 10:10:43.087240000 -0500
-@@ -60,7 +60,7 @@
- endif (NOT LIBDIR)
-
- if (NOT LOCALSTATEDIR)
-- set (LOCALSTATEDIR "${CMAKE_INSTALL_PREFIX}/var")
-+ set (LOCALSTATEDIR "/var")
- endif (NOT LOCALSTATEDIR)
-
- if (NOT INCLUDEDIR)
diff --git a/security/greenbone-security-assistant/files/patch-gsa_CMakeLists.txt b/security/greenbone-security-assistant/files/patch-gsa_CMakeLists.txt
deleted file mode 100644
index 2183c1c029da..000000000000
--- a/security/greenbone-security-assistant/files/patch-gsa_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- gsa/CMakeLists.txt 2021-01-05 00:32:41.516624000 -0500
-+++ gsa/CMakeLists.txt 2021-01-05 00:32:59.477060000 -0500
-@@ -1187,7 +1187,7 @@
-
-
- add_custom_command (OUTPUT bundle.stamp
-- COMMAND ${CMAKE_COMMAND} -E env REACT_APP_VERSION=${PROJECT_VERSION_STRING} ${INSTALLER} "${INSTALLER_ARGS}" run build
-+ COMMAND ${CMAKE_COMMAND} -E env REACT_APP_VERSION=${PROJECT_VERSION_STRING} ${INSTALLER} "${INSTALLER_ARGS}" react-scripts build
- COMMAND ${CMAKE_COMMAND} -E touch ${CMAKE_CURRENT_BINARY_DIR}/bundle.stamp
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/node-modules.stamp
diff --git a/security/greenbone-security-assistant/files/patch-gsad-src_gsad_gmp.c b/security/greenbone-security-assistant/files/patch-gsad-src_gsad_gmp.c
deleted file mode 100644
index 69a7359b2392..000000000000
--- a/security/greenbone-security-assistant/files/patch-gsad-src_gsad_gmp.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- gsad/src/gsad_gmp.c 2021-01-03 19:47:56.782208000 -0500
-+++ gsad/src/gsad_gmp.c 2021-01-03 19:49:29.616531000 -0500
-@@ -16573,8 +16573,8 @@
- /* Connect to server. */
-
- address.sun_family = AF_UNIX;
-- strncpy (address.sun_path, path, sizeof (address.sun_path) - 1);
-- if (connect (sock, (struct sockaddr *) &address, sizeof (address)) == -1)
-+ strcpy (address.sun_path, path);
-+ if (connect (sock, (struct sockaddr *) &address, sizeof (struct sockaddr_un)) == -1)
- {
- g_warning ("Failed to connect to server at %s: %s", path,
- strerror (errno));
diff --git a/security/greenbone-security-assistant/files/patch-gsad_CMakeLists.txt b/security/greenbone-security-assistant/files/patch-gsad_CMakeLists.txt
deleted file mode 100644
index c618539ad955..000000000000
--- a/security/greenbone-security-assistant/files/patch-gsad_CMakeLists.txt
+++ /dev/null
@@ -1,40 +0,0 @@
---- gsad/CMakeLists.txt 2021-10-12 07:16:06.000000000 -0500
-+++ gsad/CMakeLists.txt 2021-11-04 16:33:45.783190000 -0500
-@@ -61,7 +61,7 @@
- endif (CLANG_FORMAT)
-
- if (NOT SYSCONFDIR)
-- set (SYSCONFDIR "/etc")
-+ set (SYSCONFDIR "${CMAKE_INSTALL_PREFIX}/etc")
- endif (NOT SYSCONFDIR)
-
- if (NOT EXEC_PREFIX)
-@@ -96,7 +96,7 @@
- set (GSAD_CONFIG_DIR "${SYSCONFDIR}/gvm/")
-
- if (NOT GVM_RUN_DIR)
-- set (GVM_RUN_DIR "/run/gvm")
-+ set (GVM_RUN_DIR "${LOCALSTATEDIR}/run/gvm")
- endif (NOT GVM_RUN_DIR)
-
- if (NOT GSAD_PID_DIR)
-@@ -135,15 +135,15 @@
- endif (NOT GVM_CA_CERTIFICATE)
-
-
--configure_file (src/gsad_log_conf.cmake_in src/gsad_log.conf)
-+#configure_file (src/gsad_log_conf.cmake_in src/gsad_log.conf)
-
- ## Install
-
--install (FILES ${CMAKE_CURRENT_BINARY_DIR}/src/gsad_log.conf
-- DESTINATION ${GSAD_CONFIG_DIR})
-+#install (FILES ${CMAKE_CURRENT_BINARY_DIR}/src/gsad_log.conf
-+# DESTINATION ${GSAD_CONFIG_DIR})
-
- add_subdirectory (src)
--add_subdirectory (config)
-+#add_subdirectory (config)
-
- add_subdirectory (doc)
-
diff --git a/security/greenbone-security-assistant/pkg-descr b/security/greenbone-security-assistant/pkg-descr
deleted file mode 100644
index 144d7fad51cf..000000000000
--- a/security/greenbone-security-assistant/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-The Greenbone Security Assistant is the web interface developed for the
-Greenbone Security Manager appliances.
-
-It connects to the Greenbone Vulnerability Manager GVM to provide a
-full-featured user interface for vulnerability management.
-
-Greenbone Security Assistant consists of GSA - The webpage written in React
-and GSAD - The HTTP server talking to the GVM daemon
-
-WWW: https://github.com/greenbone/gsa