aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/py-google-cloud-vision/Makefile9
-rw-r--r--www/py-google-cloud-vision/distinfo6
-rw-r--r--www/py-google-cloud-vision/pkg-descr22
3 files changed, 17 insertions, 20 deletions
diff --git a/www/py-google-cloud-vision/Makefile b/www/py-google-cloud-vision/Makefile
index cb5f668616e8..209e012ca554 100644
--- a/www/py-google-cloud-vision/Makefile
+++ b/www/py-google-cloud-vision/Makefile
@@ -1,17 +1,18 @@
PORTNAME= google-cloud-vision
-PORTVERSION= 0.35.1
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Python Client for Google Cloud Vision
+COMMENT= Cloud Vision API API client library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-core>=0.1.1:www/py-google-api-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-core>=1.22.0<2.0.0:www/py-google-api-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libcst>=0.2.5:devel/py-libcst@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}proto-plus>=1.4.0:devel/py-proto-plus@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/www/py-google-cloud-vision/distinfo b/www/py-google-cloud-vision/distinfo
index 259362c31f4d..188438a34eea 100644
--- a/www/py-google-cloud-vision/distinfo
+++ b/www/py-google-cloud-vision/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1543424426
-SHA256 (google-cloud-vision-0.35.1.tar.gz) = a88ddadbc70676ec6e99446ac2d45229d89161133d76b0e19e403f961106a843
-SIZE (google-cloud-vision-0.35.1.tar.gz) = 1822988
+TIMESTAMP = 1618320306
+SHA256 (google-cloud-vision-2.2.0.tar.gz) = 9a205be275739c141873fa9fbd7c3f9ec6170972c85d5c75e9b4c53b5db839a3
+SIZE (google-cloud-vision-2.2.0.tar.gz) = 706636
diff --git a/www/py-google-cloud-vision/pkg-descr b/www/py-google-cloud-vision/pkg-descr
index 5be9e8e9b518..90137139c529 100644
--- a/www/py-google-cloud-vision/pkg-descr
+++ b/www/py-google-cloud-vision/pkg-descr
@@ -1,14 +1,10 @@
-Google Cloud Vision API enables developers to understand
-the content of an image by encapsulating powerful
-machine learning models in an easy to use REST API. It
-quickly classifies images into thousands of categories
-(e.g., sailboat, lion, Eiffel Tower), detects individual
-objects and faces within images, and finds and reads
-printed words contained within images. You can build
-metadata on your image catalog, moderate offensive
-content, or enable new marketing scenarios through image
-sentiment analysis. Analyze images uploaded in the
-request or integrate with your image storage on Google
-Cloud Storage.
+The Google Cloud Vision API enables developers to understand the content of an
+image by encapsulating powerful machine learning models in an easy to use REST
+API. It quickly classifies images into thousands of categories (e.g.,
+"sailboat", "lion", "Eiffel Tower"), detects individual objects and faces within
+images, and finds and reads printed words contained within images. You can build
+metadata on your image catalog, moderate offensive content, or enable new
+marketing scenarios through image sentiment analysis. Analyze images uploaded in
+the request or integrate with your image storage on Google Cloud Storage.
-WWW: https://pypi.org/project/google-cloud-vision/
+WWW: https://github.com/googleapis/python-vision