aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-zope.i18nmessageid/Makefile21
-rw-r--r--textproc/py-zope.i18nmessageid/distinfo2
-rw-r--r--textproc/py-zope.i18nmessageid/pkg-descr5
-rw-r--r--textproc/py-zope.i18nmessageid/pkg-plist30
5 files changed, 59 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6bfe641901a8..87d5ae36cb70 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1057,6 +1057,7 @@
SUBDIR += py-xml
SUBDIR += py-xmltools
SUBDIR += py-xmltv
+ SUBDIR += py-zope.i18nmessageid
SUBDIR += py-zpt
SUBDIR += py2html
SUBDIR += pybook
diff --git a/textproc/py-zope.i18nmessageid/Makefile b/textproc/py-zope.i18nmessageid/Makefile
new file mode 100644
index 000000000000..9376ce534d55
--- /dev/null
+++ b/textproc/py-zope.i18nmessageid/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-zope.i18nmessageid
+# Date created: 2011-03-21
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zope.i18nmessageid
+PORTVERSION= 3.5.3
+CATEGORIES= textproc www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Message Identifiers for internationalization
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP=yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-zope.i18nmessageid/distinfo b/textproc/py-zope.i18nmessageid/distinfo
new file mode 100644
index 000000000000..457e7398b1b0
--- /dev/null
+++ b/textproc/py-zope.i18nmessageid/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zope.i18nmessageid-3.5.3.tar.gz) = 7f423e40969de31ad9b93e7e0241ff1d9d9e02ff15c3309fa9fa69daedd9c71b
+SIZE (zope.i18nmessageid-3.5.3.tar.gz) = 13307
diff --git a/textproc/py-zope.i18nmessageid/pkg-descr b/textproc/py-zope.i18nmessageid/pkg-descr
new file mode 100644
index 000000000000..830c0b4dff29
--- /dev/null
+++ b/textproc/py-zope.i18nmessageid/pkg-descr
@@ -0,0 +1,5 @@
+zope.i18nmessageid provides facilities for declaring such messages
+within program source text; translation of the messages is the
+responsiblitiy of the 'zope.i18n' package.
+
+WWW: http://www.python.org/pypi/zope.i18nmessageid
diff --git a/textproc/py-zope.i18nmessageid/pkg-plist b/textproc/py-zope.i18nmessageid/pkg-plist
new file mode 100644
index 000000000000..b4b20849bfcf
--- /dev/null
+++ b/textproc/py-zope.i18nmessageid/pkg-plist
@@ -0,0 +1,30 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/namespace_packages.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/native_libs.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/_zope_i18nmessageid_message.c
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/_zope_i18nmessageid_message.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/_zope_i18nmessageid_message.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/_zope_i18nmessageid_message.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/_zope_i18nmessageid_message.so
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/message.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/message.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/message.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/messages.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/tests.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/tests.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid/tests.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/i18nmessageid
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%