aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/py-fail2ban/Makefile1
-rw-r--r--security/py-fail2ban/files/fail2ban.in9
2 files changed, 10 insertions, 0 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index a5663f9d696f..2e91fdc9b048 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,6 +1,7 @@
PORTNAME= fail2ban
PORTVERSION= 0.11.2
+PORTREVISION= 1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/files/fail2ban.in b/security/py-fail2ban/files/fail2ban.in
index b20c0106dba5..a0cd0de97f5c 100644
--- a/security/py-fail2ban/files/fail2ban.in
+++ b/security/py-fail2ban/files/fail2ban.in
@@ -7,6 +7,9 @@
# Add the following lines to /etc/rc.conf to enable fail2ban:
# fail2ban_enable="YES"
# fail2ban_flags="<set as needed>"
+# fail2ban_pidfile="<same as in fail2ban.local>"
+
+# Make sure pidfile and socket point to the same directory
. /etc/rc.subr
@@ -15,12 +18,18 @@ PATH=${PATH}:%%PREFIX%%/sbin:%%PREFIX%%/bin
name="fail2ban"
rcvar=fail2ban_enable
+start_precmd="fail2ban_prestart"
command="%%PREFIX%%/bin/fail2ban-server"
command_interpreter="%%PYTHON_CMD%%"
client="%%PREFIX%%/bin/fail2ban-client"
extra_commands="reload jailstatus"
+fail2ban_prestart()
+{
+ install -d -m 0755 "$(dirname ${pidfile})"
+}
+
load_rc_config ${name}
#