aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-atomiclong/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/py-atomiclong/Makefile b/devel/py-atomiclong/Makefile
index a9bb7c5da2f6..1c77fafc3014 100644
--- a/devel/py-atomiclong/Makefile
+++ b/devel/py-atomiclong/Makefile
@@ -12,18 +12,14 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.6+ pytest
USE_PYTHON= autoplist distutils
post-patch:
@${REINPLACE_CMD} '/setup_requires/d' ${WRKSRC}/${PYSETUP}
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_cffi__*.so
-
-do-test:
- @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_cffi__*.so
.include <bsd.port.mk>