aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/shared-mime-info/Makefile21
-rw-r--r--misc/shared-mime-info/distinfo10
-rw-r--r--misc/shared-mime-info/files/patch-data_freedesktop.org.xml.in10
-rw-r--r--misc/shared-mime-info/files/patch-data_freedesktop__generate.sh10
-rw-r--r--misc/shared-mime-info/files/patch-meson.build11
5 files changed, 40 insertions, 22 deletions
diff --git a/misc/shared-mime-info/Makefile b/misc/shared-mime-info/Makefile
index 27ef57f630de..d11046785b6f 100644
--- a/misc/shared-mime-info/Makefile
+++ b/misc/shared-mime-info/Makefile
@@ -1,8 +1,7 @@
# Created by: olgeni@FreeBSD.org
PORTNAME= shared-mime-info
-DISTVERSION= 2.0
-PORTREVISION= 3
+DISTVERSION= 2.2
CATEGORIES= misc gnome
MAINTAINER= desktop@FreeBSD.org
@@ -12,10 +11,9 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gmake:devel/gmake \
- itstool:textproc/itstool \
minixmlto:textproc/minixmlto
-USES= gettext gnome localbase meson pathfix pkgconfig shebangfix \
+USES= gettext gnome localbase meson pathfix pkgconfig python:build shebangfix \
tar:xz trigger
CONFIGURE_ARGS= -Dupdate-mimedb=false \
-Dxdgmime-path=${WRKSRC}/src/xdgmime
@@ -24,10 +22,17 @@ USE_GITLAB= YES
GL_SITE= https://gitlab.freedesktop.org/
GL_ACCOUNT= xdg
GL_PROJECT= shared-mime-info
-GL_COMMIT= ef58b2b2f7ad4070171c6e45e3b3764daa3ff2c1
-GL_TUPLE= xdg:xdgmime:6663a2288d11b37bc07f5a01b4b85dcd377787e1:xdgmime/src/xdgmime
+GL_COMMIT= 13695c7225c2f525a435e72739c33ac32bbfbbb9
+GL_TUPLE= xdg:xdgmime:de283fc430460b9b3a7e61432a6d273cd64cb102:xdgmime/src/xdgmime
bash_CMD= /bin/sh
-SHEBANG_FILES= ${WRKSRC}/data/freedesktop_generate.sh
+SHEBANG_FILES= ${WRKSRC}/tests/compare_iana.py \
+ ${WRKSRC}/tests/mime-detection/pyside.py \
+ ${WRKSRC}/tests/mime-detection/pyside.py \
+ ${WRKSRC}/tests/mime-detection/test.py \
+ ${WRKSRC}/tests/mime-detection/test.py3 \
+ ${WRKSRC}/tests/mime-detection/test3.py \
+ ${WRKSRC}/tests/test_case.py \
+ ${WRKSRC}/tests/test_sub_class_ofs.py
MIMESUBDIRS= application audio image inode message model multipart \
packages text video x-epoc x-content font
@@ -38,6 +43,8 @@ post-patch:
${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/src/xdgmime/src/xdgmime.c \
${WRKSRC}/src/update-mime-database.c
+ ${REINPLACE_CMD} 's|%%PYTHON_CMD%%|${PYTHON_CMD}|g' \
+ ${WRKSRC}/data/freedesktop.org.xml.in
pre-configure:
cd ${WRKSRC}/src/xdgmime/src && ${SETENV} ${MAKE_ENV} ${GMAKE}
diff --git a/misc/shared-mime-info/distinfo b/misc/shared-mime-info/distinfo
index 95b29c3b9567..b582e8054258 100644
--- a/misc/shared-mime-info/distinfo
+++ b/misc/shared-mime-info/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1617891556
-SHA256 (xdg-shared-mime-info-ef58b2b2f7ad4070171c6e45e3b3764daa3ff2c1_GL0.tar.gz) = 8ed0c0877d2f77663336f894899a69804779361fb44787e10392353381667ba7
-SIZE (xdg-shared-mime-info-ef58b2b2f7ad4070171c6e45e3b3764daa3ff2c1_GL0.tar.gz) = 6514756
-SHA256 (xdg-xdgmime-6663a2288d11b37bc07f5a01b4b85dcd377787e1_GL0.tar.gz) = dce208f8bc3fd2964893d209a3d0c78e839d0df9f10d4820bdca0ef5a7116710
-SIZE (xdg-xdgmime-6663a2288d11b37bc07f5a01b4b85dcd377787e1_GL0.tar.gz) = 32289
+TIMESTAMP = 1648442982
+SHA256 (xdg-shared-mime-info-13695c7225c2f525a435e72739c33ac32bbfbbb9_GL0.tar.gz) = 206169d8f3aa428040ae706e7693fa4aa1599e304856fb797f89fe737c93b961
+SIZE (xdg-shared-mime-info-13695c7225c2f525a435e72739c33ac32bbfbbb9_GL0.tar.gz) = 7067213
+SHA256 (xdg-xdgmime-de283fc430460b9b3a7e61432a6d273cd64cb102_GL0.tar.gz) = 9856934132a561c6c669b92839604b631ff92acdfe5876606290f785f86f865d
+SIZE (xdg-xdgmime-de283fc430460b9b3a7e61432a6d273cd64cb102_GL0.tar.gz) = 32249
diff --git a/misc/shared-mime-info/files/patch-data_freedesktop.org.xml.in b/misc/shared-mime-info/files/patch-data_freedesktop.org.xml.in
new file mode 100644
index 000000000000..ae802ea438e7
--- /dev/null
+++ b/misc/shared-mime-info/files/patch-data_freedesktop.org.xml.in
@@ -0,0 +1,10 @@
+--- data/freedesktop.org.xml.in.orig 2022-03-27 10:19:00 UTC
++++ data/freedesktop.org.xml.in
+@@ -6638,6 +6638,7 @@ -->
+ <comment>Python 3 script</comment>
+ <sub-class-of type='text/x-python'/>
+ <magic priority="60"><!-- higher priority than text/x-python -->
++ <match type="string" value="#!/usr/local/bin/python3.8" offset="0" />
+ <match type="string" value="#!/bin/python3" offset="0"/>
+ <match type="string" value="#! /bin/python3" offset="0"/>
+ <match type="string" value='eval \"exec /bin/python3' offset="0"/>
diff --git a/misc/shared-mime-info/files/patch-data_freedesktop__generate.sh b/misc/shared-mime-info/files/patch-data_freedesktop__generate.sh
deleted file mode 100644
index 87d0432ad90e..000000000000
--- a/misc/shared-mime-info/files/patch-data_freedesktop__generate.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/170
-
---- data/freedesktop_generate.sh.orig 2021-10-19 15:24:23 UTC
-+++ data/freedesktop_generate.sh
-@@ -9,4 +9,4 @@ itstool \
- --its "${src_root}/data/its/shared-mime-info.its" \
- --join "${src_root}/data/freedesktop.org.xml.in" \
- -o "${build_root}/data/freedesktop.org.xml" \
-- "${build_root}/po/"*".gmo"
-+ "${build_root}/po/"*"/LC_MESSAGES/"*".mo"
diff --git a/misc/shared-mime-info/files/patch-meson.build b/misc/shared-mime-info/files/patch-meson.build
new file mode 100644
index 000000000000..37f611011ac1
--- /dev/null
+++ b/misc/shared-mime-info/files/patch-meson.build
@@ -0,0 +1,11 @@
+--- meson.build.orig 2022-03-28 04:52:01 UTC
++++ meson.build
+@@ -74,7 +74,7 @@ configure_file(
+ 'prefix': get_option('prefix'),
+ 'VERSION': meson.project_version()
+ },
+- install_dir: get_option('datadir') / 'pkgconfig'
++ install_dir: join_paths(get_option('prefix'), 'libdata/pkgconfig')
+ )
+
+ if get_option('update-mimedb')