aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/thunderbird/Makefile3
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-bug174556026
3 files changed, 4 insertions, 31 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 26b37145c871..24ec5fec4b12 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -1,8 +1,7 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
PORTNAME= thunderbird
-DISTVERSION= 91.5.1
-PORTREVISION= 1
+DISTVERSION= 91.6.0
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index 7b34ea959aa0..4dd2409cd985 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643137893
-SHA256 (thunderbird-91.5.1.source.tar.xz) = 15918d48c59988ddeba3c7b5d98cf483db9c38a782dfbf6472dc889fed9b9c8a
-SIZE (thunderbird-91.5.1.source.tar.xz) = 405332676
+TIMESTAMP = 1644089737
+SHA256 (thunderbird-91.6.0.source.tar.xz) = e9c6a82a41c869ce291d50352250856cbb3e9be8e603038be72cd5bc52438afb
+SIZE (thunderbird-91.6.0.source.tar.xz) = 404738672
diff --git a/mail/thunderbird/files/patch-bug1745560 b/mail/thunderbird/files/patch-bug1745560
deleted file mode 100644
index 15cfb73d5fae..000000000000
--- a/mail/thunderbird/files/patch-bug1745560
+++ /dev/null
@@ -1,26 +0,0 @@
-https://hg.mozilla.org/mozilla-central/rev/f7e2cf808d30
-
-ld: warning: undefined symbol: wl_proxy_marshal_flags
->>> referenced by Unified_cpp_gfx_gl0.cpp
->>> objdir/gfx/gl/Unified_cpp_gfx_gl0.o:(mozilla::gl::DeleteWaylandGLSurface(void*))
->>> referenced by Unified_cpp_gfx_gl0.cpp
->>> objdir/gfx/gl/Unified_cpp_gfx_gl0.o:(mozilla::gl::GLContextEGL::CreateWaylandBufferSurface(mozilla::gl::EglDisplay&, void*, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits>&))
->>> referenced by Unified_cpp_gfx_layers1.cpp
->>> objdir/gfx/layers/Unified_cpp_gfx_layers1.o:(mozilla::layers::NativeLayerRootWayland::CommitToScreen(mozilla::detail::BaseAutoLock<mozilla::Mutex&> const&))
->>> referenced 84 more times
-
-diff --git widget/gtk/mozwayland/mozwayland.c widget/gtk/mozwayland/mozwayland.c
-index 7a448e6321e2..1a86468b4f3d 100644
---- widget/gtk/mozwayland/mozwayland.c
-+++ widget/gtk/mozwayland/mozwayland.c
-@@ -200,3 +200,10 @@ MOZ_EXPORT int wl_list_empty(const struct wl_list* list) { return -1; }
-
- MOZ_EXPORT void wl_list_insert_list(struct wl_list* list,
- struct wl_list* other) {}
-+
-+MOZ_EXPORT struct wl_proxy* wl_proxy_marshal_flags(
-+ struct wl_proxy* proxy, uint32_t opcode,
-+ const struct wl_interface* interface, uint32_t version, uint32_t flags,
-+ ...) {
-+ return NULL;
-+}