aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/py-libnacl/Makefile6
-rw-r--r--security/py-libnacl/distinfo6
-rw-r--r--security/py-libnacl/pkg-descr13
3 files changed, 13 insertions, 12 deletions
diff --git a/security/py-libnacl/Makefile b/security/py-libnacl/Makefile
index 8e9fcb3d5bb5..dd1b8aa44aec 100644
--- a/security/py-libnacl/Makefile
+++ b/security/py-libnacl/Makefile
@@ -1,7 +1,7 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= libnacl
-PORTVERSION= 1.6.1
+PORTVERSION= 1.8.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,11 +15,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libsodium.so:security/libsodium
USES= python:3.6+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m unittest discover --start-directory tests -v
+ cd ${WRKSRC} && ${PYTHON_CMD} -m unittest discover -s tests -v
.include <bsd.port.mk>
diff --git a/security/py-libnacl/distinfo b/security/py-libnacl/distinfo
index bbae43bc5dc9..c8b4b57530c0 100644
--- a/security/py-libnacl/distinfo
+++ b/security/py-libnacl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557115419
-SHA256 (libnacl-1.6.1.tar.gz) = 9bac3d8867678c457d0c018f028052996ab567a6b4964e82a17072ed2cb2675b
-SIZE (libnacl-1.6.1.tar.gz) = 65443
+TIMESTAMP = 1652471215
+SHA256 (libnacl-1.8.0.tar.gz) = f1037b85ca31fd8b02c43d66f78c2049bc58480e6a395dc9d27e6821b5fe185d
+SIZE (libnacl-1.8.0.tar.gz) = 41331
diff --git a/security/py-libnacl/pkg-descr b/security/py-libnacl/pkg-descr
index 15009a0e13c4..adfada554579 100644
--- a/security/py-libnacl/pkg-descr
+++ b/security/py-libnacl/pkg-descr
@@ -1,7 +1,8 @@
-This library is used to gain direct access to the functions exposed by Daniel
-J. Bernstein's nacl library via libsodium or tweetnacl. It has been constructed
-to maintain extensive documentation on how to use nacl as well as being
-completely portable. The file in libnacl/__init__.py can be pulled out and
-placed directly in any project to give a single file binding to all of nacl.
+This library is used to gain direct access to the functions exposed by Daniel J.
+Bernstein's nacl library via libsodium. It has been constructed to maintain
+extensive documentation on how to use nacl as well as being completely portable.
+The file in libnacl/__init__.py can be pulled out and placed directly in any
+project to give a single file binding to all of nacl.
-WWW: https://libnacl.readthedocs.org
+WWW: https://libnacl.readthedocs.io/en/latest/
+WWW: https://github.com/saltstack/libnacl