aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/omega/Makefile3
-rw-r--r--games/omega/files/patch-inv.c14
2 files changed, 14 insertions, 3 deletions
diff --git a/games/omega/Makefile b/games/omega/Makefile
index a77f6a43b0e1..89c94899c7c2 100644
--- a/games/omega/Makefile
+++ b/games/omega/Makefile
@@ -2,11 +2,12 @@
PORTNAME= omega
PORTVERSION= 0.90.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.alcyone.com/binaries/omega/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= r7st.guru@gmail.com
COMMENT= Complex rogue-style game of dungeon exploration
USES= gmake ncurses
diff --git a/games/omega/files/patch-inv.c b/games/omega/files/patch-inv.c
index 932cae631cd6..8403f5f9a264 100644
--- a/games/omega/files/patch-inv.c
+++ b/games/omega/files/patch-inv.c
@@ -1,5 +1,5 @@
---- inv.c Fri Jan 1 03:08:33 1999
-+++ /home/andy/tmp/wrk/inv.c Fri May 14 20:28:52 1999
+--- inv.c.orig 2021-11-11 18:12:35.355855000 -0500
++++ inv.c 2021-11-11 18:13:11.096005000 -0500
@@ -8,7 +8,11 @@
# ifdef AMIGA
# include <curses210.h>
@@ -13,3 +13,13 @@
# endif
#endif
+@@ -840,8 +844,7 @@
+ use_pack_item(response - 'a',slot);
+ }
+ }
+- if ( optionp(TOPINV) )
+- display_possessions();
++ display_possessions();
+ return slot;
+ }
+