aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/gstreamer-plugins-spc/Makefile2
-rw-r--r--audio/py-sdl_mixer/Makefile2
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--chinese/stardict2-dict-zh_TW/Makefile2
-rw-r--r--databases/mysqlbigram/Makefile2
-rw-r--r--deskutils/remember.el/Makefile2
-rw-r--r--devel/hs-hat/Makefile2
-rw-r--r--devel/hs-hpl/Makefile2
-rw-r--r--devel/py-coro/Makefile2
-rw-r--r--games/emacs-chess/Makefile2
-rw-r--r--graphics/qgis/Makefile2
-rw-r--r--java/cacao/Makefile2
-rw-r--r--java/dbvis/Makefile2
-rw-r--r--lang/quack/Makefile2
-rw-r--r--mail/claws-mail-clamav/Makefile2
-rw-r--r--mail/sylpheed2-devel/Makefile2
-rw-r--r--misc/pybliographer/Makefile2
-rw-r--r--multimedia/helixplayer/Makefile2
-rw-r--r--multimedia/mjpegtools-yuvfilters/Makefile2
-rw-r--r--net-im/sulci/Makefile2
-rw-r--r--net-mgmt/NeTraMet/Makefile2
-rw-r--r--net/gnometelnet/Makefile2
-rw-r--r--net/libunpipc/Makefile2
-rw-r--r--net/py-mantissa/Makefile2
-rw-r--r--net/versuch/Makefile2
-rw-r--r--palm/pdbc/Makefile2
-rw-r--r--print/ifhp/Makefile2
-rw-r--r--security/squidclam/Makefile2
-rw-r--r--sysutils/quicksynergy/Makefile2
-rw-r--r--textproc/htmlize.el/Makefile2
-rw-r--r--www/c-icap/Makefile2
-rw-r--r--www/cybercalendar/Makefile2
-rw-r--r--www/geneweb/Makefile2
-rw-r--r--www/ocaml-wdialog/Makefile2
-rw-r--r--www/ocsigen/Makefile2
-rw-r--r--www/pecl-mnogosearch/Makefile2
-rw-r--r--x11-themes/gtk-industrial-theme/Makefile2
-rw-r--r--x11-toolkits/wxmozilla/Makefile2
-rw-r--r--x11-wm/fluxspace/Makefile2
-rw-r--r--x11/bbuname/Makefile2
40 files changed, 80 insertions, 0 deletions
diff --git a/audio/gstreamer-plugins-spc/Makefile b/audio/gstreamer-plugins-spc/Makefile
index b2335ca29eeb..bdf04e54c730 100644
--- a/audio/gstreamer-plugins-spc/Makefile
+++ b/audio/gstreamer-plugins-spc/Makefile
@@ -15,5 +15,7 @@ GST_PLUGIN= spc
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
BROKEN= does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
.include "${MASTERDIR}/Makefile"
diff --git a/audio/py-sdl_mixer/Makefile b/audio/py-sdl_mixer/Makefile
index ccf35e293c64..17bd3a60480b 100644
--- a/audio/py-sdl_mixer/Makefile
+++ b/audio/py-sdl_mixer/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= pyrex>=0.9.6.2:${PORTSDIR}/devel/pyrex
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
BROKEN= does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
DIST_SUBDIR= python
USE_SDL= sdl mixer
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index c56537ee1141..87c31f0db748 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -26,6 +26,8 @@ LIB_DEPENDS= itcl.${ITCL_VER}:${PORTSDIR}/lang/itcl \
dps.0:${PORTSDIR}/x11/dgs
BROKEN= Does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_BZIP2= yes
USE_BISON= build
diff --git a/chinese/stardict2-dict-zh_TW/Makefile b/chinese/stardict2-dict-zh_TW/Makefile
index 89a061812765..0c3a5eefb20e 100644
--- a/chinese/stardict2-dict-zh_TW/Makefile
+++ b/chinese/stardict2-dict-zh_TW/Makefile
@@ -25,6 +25,8 @@ COMMENT= English-Chinese(T)/Chinese(T)-English dictionaries for StarDict
RUN_DEPENDS= stardict:${PORTSDIR}/textproc/stardict2
BROKEN= Checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
NO_BUILD= yes
USE_BZIP2= yes
diff --git a/databases/mysqlbigram/Makefile b/databases/mysqlbigram/Makefile
index 2927258e7d48..dd12e9288a34 100644
--- a/databases/mysqlbigram/Makefile
+++ b/databases/mysqlbigram/Makefile
@@ -15,6 +15,8 @@ MAINTAINER= gslin@gslin.org
COMMENT= Simple N-Gram (bi-gram) FULLTEXT parser plugin for MySQL 5.1+
BROKEN= does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
CFLAGS+= -I"${LOCALBASE}/include" -I"${LOCALBASE}/include/mysql"
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/deskutils/remember.el/Makefile b/deskutils/remember.el/Makefile
index 55cfa5eba6c0..d29efaa1e484 100644
--- a/deskutils/remember.el/Makefile
+++ b/deskutils/remember.el/Makefile
@@ -18,6 +18,8 @@ MAINTAINER= dryice@dryice.name
COMMENT= A Emacs mode for remembering data
BROKEN= Conflicting dependencies
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_EMACS= yes
USE_GMAKE= yes
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 8b5998639282..eefa87306b79 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -15,6 +15,8 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= A source-level tracer for Haskell 98
BROKEN= Does not build with recent ghc
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_GMAKE= yes
HAS_CONFIGURE= yes
diff --git a/devel/hs-hpl/Makefile b/devel/hs-hpl/Makefile
index d2b8c90ee6fa..9d896650aa75 100644
--- a/devel/hs-hpl/Makefile
+++ b/devel/hs-hpl/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
BROKEN= Does not build with current ghc
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
.include <bsd.port.pre.mk>
diff --git a/devel/py-coro/Makefile b/devel/py-coro/Makefile
index 7b2b8db7ebe4..9e005405ced8 100644
--- a/devel/py-coro/Makefile
+++ b/devel/py-coro/Makefile
@@ -18,6 +18,8 @@ COMMENT= Python coroutine implementation
BUILD_DEPENDS= ${LOCALBASE}/lib/libcoro.a:${PORTSDIR}/devel/libcoro
BROKEN= Does not build
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_PYTHON= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
diff --git a/games/emacs-chess/Makefile b/games/emacs-chess/Makefile
index c994d016c0ea..adf383cef7cb 100644
--- a/games/emacs-chess/Makefile
+++ b/games/emacs-chess/Makefile
@@ -20,6 +20,8 @@ MAINTAINER= dryice@dryice.name
COMMENT= Play chess with emacs
BROKEN= Conflicting dependencies
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 640592448d6a..965677c70e2d 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
BROKEN= Does not build with geos 3.x
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
diff --git a/java/cacao/Makefile b/java/cacao/Makefile
index c68075c691ef..5d38ec93c348 100644
--- a/java/cacao/Makefile
+++ b/java/cacao/Makefile
@@ -16,6 +16,8 @@ COMMENT= JIT compiler for JAVA
BUILD_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
BROKEN= does not configure
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_BZIP2= yes
USE_AUTOTOOLS= libltdl
diff --git a/java/dbvis/Makefile b/java/dbvis/Makefile
index 3276eae814f2..0f89888f5512 100644
--- a/java/dbvis/Makefile
+++ b/java/dbvis/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= contact@toha.org.ua
COMMENT= DbVisualizer database tool
BROKEN= Unfetchable
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_JAVA= yes
JAVA_VERSION= 1.5+
diff --git a/lang/quack/Makefile b/lang/quack/Makefile
index ac6d982c5448..03e2b04664d2 100644
--- a/lang/quack/Makefile
+++ b/lang/quack/Makefile
@@ -20,6 +20,8 @@ COMMENT= Enhanced support for editing and running Scheme code
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
BROKEN= Size mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
diff --git a/mail/claws-mail-clamav/Makefile b/mail/claws-mail-clamav/Makefile
index a9d2354a80bf..0525af71e103 100644
--- a/mail/claws-mail-clamav/Makefile
+++ b/mail/claws-mail-clamav/Makefile
@@ -31,5 +31,7 @@ PLIST_FILES= lib/claws-mail/plugins/clamav.a \
lib/claws-mail/plugins/clamav.so
BROKEN= Doesn't build with clamav-0.93 or higher
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
.include <bsd.port.mk>
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 032d00470512..60b2f922af2e 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -18,6 +18,8 @@ COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
BROKEN= does not link
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
#IGNORE= "is out-of-dated, use mail/sylpheed2 instead of this, until the next development starts."
diff --git a/misc/pybliographer/Makefile b/misc/pybliographer/Makefile
index 63e9bc3dddcb..89cf1e059f44 100644
--- a/misc/pybliographer/Makefile
+++ b/misc/pybliographer/Makefile
@@ -21,6 +21,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-1.2/_gnomemodule.so:${PORTSDIR}/x11-toolki
recode:${PORTSDIR}/converters/recode
BROKEN= does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_GNOME= glib12 gnomehack gnomeprefix
USE_PYTHON= yes
diff --git a/multimedia/helixplayer/Makefile b/multimedia/helixplayer/Makefile
index 5e0f34009b7a..d776aa6f3ac3 100644
--- a/multimedia/helixplayer/Makefile
+++ b/multimedia/helixplayer/Makefile
@@ -22,6 +22,8 @@ LIB_DEPENDS= theora.0:${PORTSDIR}/multimedia/libtheora \
jpeg:${PORTSDIR}/graphics/jpeg
BROKEN= Does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_BZIP2= yes
USE_OPENSSL= yes
diff --git a/multimedia/mjpegtools-yuvfilters/Makefile b/multimedia/mjpegtools-yuvfilters/Makefile
index de697d81e2df..7727b678f503 100644
--- a/multimedia/mjpegtools-yuvfilters/Makefile
+++ b/multimedia/mjpegtools-yuvfilters/Makefile
@@ -18,6 +18,8 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Mjpeg-tools YUV video stream processing tools
BROKEN= Does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
LIB_DEPENDS= lavjpeg-1.9.1:${PORTSDIR}/multimedia/mjpegtools
diff --git a/net-im/sulci/Makefile b/net-im/sulci/Makefile
index 53985f3d6d81..369ef8341b3e 100644
--- a/net-im/sulci/Makefile
+++ b/net-im/sulci/Makefile
@@ -39,6 +39,8 @@ SUB_FILES= pkg-message
OPTIONS= MUC_LOG "with muc_log plugin" on
BROKEN= don't work with ocaml 3.10
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} ${PREFIX}/sbin
diff --git a/net-mgmt/NeTraMet/Makefile b/net-mgmt/NeTraMet/Makefile
index c3c9835ee969..a22a3dfb8bf4 100644
--- a/net-mgmt/NeTraMet/Makefile
+++ b/net-mgmt/NeTraMet/Makefile
@@ -20,6 +20,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Implementation of the Internet Accounting Architecture
BROKEN= Checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
NETRAMET_DOCS= usguide.pdf srlguide.pdf ntmref.pdf nm_rc.pdf \
nifty.pdf fdutil.pdf
diff --git a/net/gnometelnet/Makefile b/net/gnometelnet/Makefile
index 2703eecc9f8a..f029d9924d28 100644
--- a/net/gnometelnet/Makefile
+++ b/net/gnometelnet/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A nice frontend to the telnet, ssh, and rlogin clients for GNOME
BROKEN= Size mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_AUTOTOOLS= automake:15:env libtool:15
USE_BZIP2= yes
diff --git a/net/libunpipc/Makefile b/net/libunpipc/Makefile
index e14a440feb9e..05a6e5de7bb7 100644
--- a/net/libunpipc/Makefile
+++ b/net/libunpipc/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The networking library used in UNIX Network Programming Volume 2 2e
BROKEN= checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/net/py-mantissa/Makefile b/net/py-mantissa/Makefile
index 896e958b6ec0..34b6011e5f6f 100644
--- a/net/py-mantissa/Makefile
+++ b/net/py-mantissa/Makefile
@@ -33,6 +33,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/nevow/__init__.py:${PORTSDIR}/www/py-nevow \
${PYTHON_SITELIBDIR}/twisted/conch/__init__.py:${PORTSDIR}/security/py-twistedConch
BROKEN= Leaves files behind after deinstallation
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/net/versuch/Makefile b/net/versuch/Makefile
index 603b9e023eda..315a4aec48b5 100644
--- a/net/versuch/Makefile
+++ b/net/versuch/Makefile
@@ -22,6 +22,8 @@ LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib \
pcre\\+\\+.0:${PORTSDIR}/devel/pcre++
BROKEN= Does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
WRKSRC= ${WRKDIR}/versuch
diff --git a/palm/pdbc/Makefile b/palm/pdbc/Makefile
index 8c92abb2f192..a2afb4bf1ef8 100644
--- a/palm/pdbc/Makefile
+++ b/palm/pdbc/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Palm DataBase Compiler/Decompiler
BROKEN= Checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_ZIP= YES
EXTRACT_BEFORE_ARGS= -q -a
diff --git a/print/ifhp/Makefile b/print/ifhp/Makefile
index d876912f1e3b..1dd72f4adcd7 100644
--- a/print/ifhp/Makefile
+++ b/print/ifhp/Makefile
@@ -21,6 +21,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= IFHP - A highly configurable print filter for LPRng
BROKEN= Size mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
index 0fd568d1e511..9a2d90eeae16 100644
--- a/security/squidclam/Makefile
+++ b/security/squidclam/Makefile
@@ -32,6 +32,8 @@ PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
PLIST_DIRS= %%EXAMPLESDIR%%
BROKEN= Doesn't build with clamav-0.93 or higher
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/sysutils/quicksynergy/Makefile b/sysutils/quicksynergy/Makefile
index 27a96985dfb4..7afdc256947f 100644
--- a/sysutils/quicksynergy/Makefile
+++ b/sysutils/quicksynergy/Makefile
@@ -20,6 +20,8 @@ GNU_CONFIGURE= yes
USE_GNOME= gtk20 libglade
BROKEN= does not build
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
PLIST_FILES= bin/quicksynergy
diff --git a/textproc/htmlize.el/Makefile b/textproc/htmlize.el/Makefile
index fab445485d84..ff03b7977d75 100644
--- a/textproc/htmlize.el/Makefile
+++ b/textproc/htmlize.el/Makefile
@@ -17,6 +17,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Emacs major mode to create HTML files from Emacs buffers (in colour!)
BROKEN= Size mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index d3d8c0dfe728..deb4e933702d 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -32,6 +32,8 @@ OPTIONS= CLAMAV "Build with srv_clamav service" on \
# PERL "With Perl support" off
BROKEN= Doesn't build with clamav-0.93 or higher
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
.include <bsd.port.pre.mk>
diff --git a/www/cybercalendar/Makefile b/www/cybercalendar/Makefile
index 3389543b08ee..b1b0a67f178a 100644
--- a/www/cybercalendar/Makefile
+++ b/www/cybercalendar/Makefile
@@ -15,6 +15,8 @@ MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= CyberCalendar is a web based calendar program written in perl
BROKEN= does not fetch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
diff --git a/www/geneweb/Makefile b/www/geneweb/Makefile
index e4a65d9a302e..f51208de5b05 100644
--- a/www/geneweb/Makefile
+++ b/www/geneweb/Makefile
@@ -18,6 +18,8 @@ COMMENT= An advanced genealogy software
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
BROKEN= does not build with new ocaml
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
MAN1= ged2gwb.1 gwb2ged.1 gwc.1 gwu.1
diff --git a/www/ocaml-wdialog/Makefile b/www/ocaml-wdialog/Makefile
index f9acea898dd8..39451e51da9f 100644
--- a/www/ocaml-wdialog/Makefile
+++ b/www/ocaml-wdialog/Makefile
@@ -25,6 +25,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/site-lib/pxp-engine/pxp_engine.a:${PORTSDIR}
${LOCALBASE}/lib/ocaml/site-lib/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
BROKEN= does not build with new ocaml
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_GMAKE= yes
diff --git a/www/ocsigen/Makefile b/www/ocsigen/Makefile
index 8864529429af..42cc05d62e39 100644
--- a/www/ocsigen/Makefile
+++ b/www/ocsigen/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= ocaml-net<2:${PORTSDIR}/www/ocaml-net \
${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
BROKEN= unsatisfiable dependency line
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
diff --git a/www/pecl-mnogosearch/Makefile b/www/pecl-mnogosearch/Makefile
index 079f9fa6de92..4035eac2c66c 100644
--- a/www/pecl-mnogosearch/Makefile
+++ b/www/pecl-mnogosearch/Makefile
@@ -19,6 +19,8 @@ COMMENT= The mnoGoSearch Bindings for php51+
BUILD_DEPENDS= indexer:${PORTSDIR}/www/mnogosearch
BROKEN= does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/x11-themes/gtk-industrial-theme/Makefile b/x11-themes/gtk-industrial-theme/Makefile
index 69e190fc5624..9079590eb0d9 100644
--- a/x11-themes/gtk-industrial-theme/Makefile
+++ b/x11-themes/gtk-industrial-theme/Makefile
@@ -20,6 +20,8 @@ COMMENT= Slick theme for GTK1 from Ximian
EXTRACT_DEPENDS=rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
BROKEN= Checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
WRKSRC= ${WRKDIR}/ximian-artwork-${PORTVERSION}
USE_GMAKE= yes
diff --git a/x11-toolkits/wxmozilla/Makefile b/x11-toolkits/wxmozilla/Makefile
index d7a53d7497b7..a2805b862b9e 100644
--- a/x11-toolkits/wxmozilla/Makefile
+++ b/x11-toolkits/wxmozilla/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Embedding Mozilla in wxWidgets
BROKEN= does not compile
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_PYTHON= yes
USE_GNOME= gnomehack gnometarget
diff --git a/x11-wm/fluxspace/Makefile b/x11-wm/fluxspace/Makefile
index c30929601032..a7125461094b 100644
--- a/x11-wm/fluxspace/Makefile
+++ b/x11-wm/fluxspace/Makefile
@@ -17,6 +17,8 @@ COMMENT= A window manager and workspace enhancer and integrator
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
BROKEN= Checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
USE_XORG= x11
USE_PYTHON= yes
diff --git a/x11/bbuname/Makefile b/x11/bbuname/Makefile
index ee440ad036f1..9c0d0a2ac698 100644
--- a/x11/bbuname/Makefile
+++ b/x11/bbuname/Makefile
@@ -19,6 +19,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Flux/Black-box applet displaying system information a la GNU uname
BROKEN= Checksum mismatch
+DEPRECATED= has been broken for more than 6 months
+EXPIRATION_DATE=2009-01-19
GNU_CONFIGURE= yes
USE_BZIP2= yes