aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/qtcreator/Makefile14
-rw-r--r--devel/qtcreator/distinfo6
-rw-r--r--devel/qtcreator/pkg-plist2
3 files changed, 14 insertions, 8 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index f3926df319fc..11311a01571e 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -1,5 +1,5 @@
PORTNAME= qtcreator
-DISTVERSION= 8.0.1
+DISTVERSION= 8.0.2
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -55,10 +55,14 @@ SHEBANG_FILES= bin/qtcreator.sh \
# Provide library paths, default llvm first as a hint to the clang code model.
CMAKE_ARGS+= -DCMAKE_PREFIX_PATH:STRING="${PREFIX}/llvm${LLVM_DEFAULT};${PREFIX}"
-# Prevent accidental pickup of devel/elfutils libraries.
-CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_elfutils
-# Disable precompiled headers for now, they are missing compile flags.
-CMAKE_OFF= BUILD_WITH_PCH
+# - Prevent accidental pickup of devel/elfutils libraries.
+# - Prevent accidental use of devel/googletest headers, use bundled.
+CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_elfutils \
+ CMAKE_DISABLE_FIND_PACKAGE_Googletest
+# - Disable precompiled headers for now, they are missing compile flags.
+# - Suppress installed yaml-cpp, use bundled.
+CMAKE_OFF= BUILD_WITH_PCH \
+ yaml-cpp_FOUND
# Disable Qt6 suport for now
CMAKE_ON+= CMAKE_DISABLE_FIND_PACKAGE_Qt6
diff --git a/devel/qtcreator/distinfo b/devel/qtcreator/distinfo
index 84300a54171b..ec0205bde439 100644
--- a/devel/qtcreator/distinfo
+++ b/devel/qtcreator/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1660214443
-SHA256 (KDE/Qt/qtcreator/qt-creator-opensource-src-8.0.1.tar.xz) = e2ce200a79c74dcd6367dcbb83c839c1c20b2cc077d6a658639eacde8a4ab865
-SIZE (KDE/Qt/qtcreator/qt-creator-opensource-src-8.0.1.tar.xz) = 46918596
+TIMESTAMP = 1666351578
+SHA256 (KDE/Qt/qtcreator/qt-creator-opensource-src-8.0.2.tar.xz) = 0cbd93c62bfc33f517d7c026d82fb02a7203fe5efd67132814271083f7299db0
+SIZE (KDE/Qt/qtcreator/qt-creator-opensource-src-8.0.2.tar.xz) = 48874868
diff --git a/devel/qtcreator/pkg-plist b/devel/qtcreator/pkg-plist
index 4395b5b45f38..12c60351a8f0 100644
--- a/devel/qtcreator/pkg-plist
+++ b/devel/qtcreator/pkg-plist
@@ -334,6 +334,8 @@ share/metainfo/org.qt-project.qtcreator.appdata.xml
%%DATADIR%%/qml/qmlpuppet/mockfiles/images/floor_tex.png
%%DATADIR%%/qml/qmlpuppet/mockfiles/images/point.png
%%DATADIR%%/qml/qmlpuppet/mockfiles/images/point@2x.png
+%%DATADIR%%/qml/qmlpuppet/mockfiles/images/preview_landscape.hdr
+%%DATADIR%%/qml/qmlpuppet/mockfiles/images/preview_studio.hdr
%%DATADIR%%/qml/qmlpuppet/mockfiles/images/spot.png
%%DATADIR%%/qml/qmlpuppet/mockfiles/images/spot@2x.png
%%DATADIR%%/qml/qmlpuppet/mockfiles/images/static_floor.png