aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/libg15/Makefile20
-rw-r--r--sysutils/libg15/distinfo3
-rw-r--r--sysutils/libg15/pkg-descr4
-rw-r--r--sysutils/libg15/pkg-plist5
-rw-r--r--sysutils/libg15render/Makefile22
-rw-r--r--sysutils/libg15render/distinfo3
-rw-r--r--sysutils/libg15render/pkg-descr3
-rw-r--r--sysutils/libg15render/pkg-plist6
9 files changed, 68 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0e466eac664b..3a351d091306 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -589,6 +589,8 @@
SUBDIR += libcpuid
SUBDIR += libdnf
SUBDIR += libfvde
+ SUBDIR += libg15
+ SUBDIR += libg15render
SUBDIR += libgksu
SUBDIR += libieee1284
SUBDIR += libretto-config
diff --git a/sysutils/libg15/Makefile b/sysutils/libg15/Makefile
new file mode 100644
index 000000000000..ab1901ca90f1
--- /dev/null
+++ b/sysutils/libg15/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= libg15
+PORTVERSION= 1.2.7
+CATEGORIES= sysutils
+MASTER_SITES= SF/g15tools/libg15/${PORTVERSION}
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= API for control of LCD and the extra keys on Logitech keyboards
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= compiler:gcc-c++11-lib gmake libtool tar:bzip2
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/libg15/distinfo b/sysutils/libg15/distinfo
new file mode 100644
index 000000000000..e50838918c8e
--- /dev/null
+++ b/sysutils/libg15/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608067028
+SHA256 (libg15-1.2.7.tar.bz2) = 132febe27e66fd9ee1cb7675ef2b0d99b5a404c28923494ff995012b847179d6
+SIZE (libg15-1.2.7.tar.bz2) = 232475
diff --git a/sysutils/libg15/pkg-descr b/sysutils/libg15/pkg-descr
new file mode 100644
index 000000000000..3db6d3cde8ad
--- /dev/null
+++ b/sysutils/libg15/pkg-descr
@@ -0,0 +1,4 @@
+API for control of the LCD display and the extra keys on some
+Logitech keyboards.
+
+WWW: https://sourceforge.net/projects/g15tools
diff --git a/sysutils/libg15/pkg-plist b/sysutils/libg15/pkg-plist
new file mode 100644
index 000000000000..f4af5776b630
--- /dev/null
+++ b/sysutils/libg15/pkg-plist
@@ -0,0 +1,5 @@
+include/libg15.h
+lib/libg15.a
+lib/libg15.so
+lib/libg15.so.1
+lib/libg15.so.1.0.0
diff --git a/sysutils/libg15render/Makefile b/sysutils/libg15render/Makefile
new file mode 100644
index 000000000000..3848a9bc3080
--- /dev/null
+++ b/sysutils/libg15render/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= libg15render
+PORTVERSION= 1.2
+CATEGORIES= sysutils
+MASTER_SITES= SF/g15tools/libg15render/${PORTVERSION}
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Library to render the LCD screen on Logitech keyboards
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libg15.so:sysutils/libg15
+
+USES= compiler:gcc-c++11-lib gmake libtool tar:bzip2
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/libg15render/distinfo b/sysutils/libg15render/distinfo
new file mode 100644
index 000000000000..5c6b59c16287
--- /dev/null
+++ b/sysutils/libg15render/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1602857268
+SHA256 (libg15render-1.2.tar.bz2) = d22335af6a17ec44799da82671778d2072499b26c5773ab913d9ba20d159d20f
+SIZE (libg15render-1.2.tar.bz2) = 246034
diff --git a/sysutils/libg15render/pkg-descr b/sysutils/libg15render/pkg-descr
new file mode 100644
index 000000000000..b00fb258548a
--- /dev/null
+++ b/sysutils/libg15render/pkg-descr
@@ -0,0 +1,3 @@
+Render text and graphics to a buffer usable by libg15.
+
+WWW: https://sourceforge.net/projects/g15tools
diff --git a/sysutils/libg15render/pkg-plist b/sysutils/libg15render/pkg-plist
new file mode 100644
index 000000000000..8694c0271375
--- /dev/null
+++ b/sysutils/libg15render/pkg-plist
@@ -0,0 +1,6 @@
+include/libg15render.h
+lib/libg15render.a
+lib/libg15render.so
+lib/libg15render.so.1
+lib/libg15render.so.1.1.0
+man/man3/libg15render.3.gz