aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/grass-i18n/Makefile3
-rw-r--r--databases/grass/Makefile3
-rw-r--r--databases/gtksql/Makefile3
-rw-r--r--databases/libgda2/Makefile3
-rw-r--r--databases/libgda3/Makefile3
-rw-r--r--databases/p5-DBD-Pg-13/Makefile4
-rw-r--r--databases/p5-DBD-Pg/Makefile4
-rw-r--r--databases/p5-Pg/Makefile6
-rw-r--r--databases/phppgadmin/Makefile3
-rw-r--r--databases/py-PyGreSQL/Makefile4
-rw-r--r--databases/py-psycopg/Makefile3
-rw-r--r--databases/ruby-postgres/Makefile4
-rw-r--r--databases/rubygem-postgres/Makefile4
-rw-r--r--databases/sqlrelay/Makefile4
-rw-r--r--databases/zpygresqlda/Makefile3
-rw-r--r--dns/bind9-dlz/Makefile3
-rw-r--r--ftp/proftpd-devel/Makefile5
-rw-r--r--ftp/proftpd/Makefile5
-rw-r--r--lang/pike72/Makefile2
-rw-r--r--mail/exim-old/Makefile4
-rw-r--r--mail/exim/Makefile4
-rw-r--r--mail/ezmlm-idx/Makefile3
-rw-r--r--mail/horde-imp/Makefile2
-rw-r--r--mail/horde-turba/Makefile2
-rw-r--r--mail/horde4-imp/Makefile2
-rw-r--r--mail/horde4-turba/Makefile2
-rw-r--r--mail/imp/Makefile2
-rw-r--r--mail/imp3/Makefile2
-rw-r--r--mail/teapop-devel/Makefile3
-rw-r--r--mail/teapop/Makefile3
-rw-r--r--mail/turba/Makefile2
-rw-r--r--net/bind9-dlz/Makefile3
-rw-r--r--security/audit/Makefile3
-rw-r--r--security/snort/Makefile3
-rw-r--r--sysutils/msyslog/Makefile3
-rw-r--r--www/mnogosearch/Makefile3
-rw-r--r--www/mnogosearch31/Makefile3
-rw-r--r--www/twig/Makefile2
38 files changed, 78 insertions, 42 deletions
diff --git a/databases/grass-i18n/Makefile b/databases/grass-i18n/Makefile
index db0e52ecfc18..46aa1cf4e113 100644
--- a/databases/grass-i18n/Makefile
+++ b/databases/grass-i18n/Makefile
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= reg@FreeBSD.org
+POSTGRESQL_PORT?= databases/postgresql7
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -23,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
iconv.3:${PORTSDIR}/converters/libiconv \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
- pq.2:${PORTSDIR}/databases/postgresql7 \
+ pq.3:${PORTSDIR}/${POSTGRESQL_PORT} \
odbc.1:${PORTSDIR}/databases/unixODBC \
lapack.3:${PORTSDIR}/math/lapack
BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index db0e52ecfc18..46aa1cf4e113 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= reg@FreeBSD.org
+POSTGRESQL_PORT?= databases/postgresql7
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -23,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
iconv.3:${PORTSDIR}/converters/libiconv \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
- pq.2:${PORTSDIR}/databases/postgresql7 \
+ pq.3:${PORTSDIR}/${POSTGRESQL_PORT} \
odbc.1:${PORTSDIR}/databases/unixODBC \
lapack.3:${PORTSDIR}/math/lapack
BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index 10d7bfeed8db..96cd5765216e 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -19,6 +19,7 @@ WITH_MYSQL= yes
USE_X_PREFIX= yes
USE_GTK= yes
+POSTGRESQL_PORT?= databases/postgresql7
.include <bsd.port.pre.mk>
@@ -30,7 +31,7 @@ LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.if defined(WITH_PGSQL) || (exists(${LOCALBASE}/lib/libpq.a) \
&& !defined(WITHOUT_PGSQL))
HAVE_PGSQL= yes
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
pre-patch:
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 5baad1b6a879..3387be688dd8 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -45,7 +45,8 @@ PLIST_SUB= MYSQL="@comment "
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index 5baad1b6a879..3387be688dd8 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -45,7 +45,8 @@ PLIST_SUB= MYSQL="@comment "
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index da5dab47fe33..431d0c26831b 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -15,9 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fjoe@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index da5dab47fe33..431d0c26831b 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -15,9 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fjoe@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index 90b52da5d0bb..891e2d2ab470 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -13,9 +13,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= girgen@partitur.se
POSTGRESQL_SUBPORT=YES
-.include <${.CURDIR}/../postgresql7/Makefile>
-
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
USE_PERL5= yes
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index e96a722fbbd4..8c4718ab0f6b 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.else
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.endif
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
WRKSRC= ${WRKDIR}/phpPgAdmin
NO_BUILD= YES
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 12768f05fd94..196f60225eea 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -16,7 +16,9 @@ POSTGRESQL_SUBPORT= YES
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
USE_PYTHON= yes
CONFIGURE_ARGS= --with-python --prefix=${PREFIX}
diff --git a/databases/py-psycopg/Makefile b/databases/py-psycopg/Makefile
index 4f89b3f996a5..d51a9ef4f0f7 100644
--- a/databases/py-psycopg/Makefile
+++ b/databases/py-psycopg/Makefile
@@ -16,8 +16,9 @@ MAINTAINER= simuran@shaw.ca
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.2:${PORTSDIR}/${POSTGRESQL_PORT}
+POSTGRESQL_PORT?= databases/postgresql7
USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/databases/ruby-postgres/Makefile b/databases/ruby-postgres/Makefile
index 02df47cec0e8..784f467b5dc6 100644
--- a/databases/ruby-postgres/Makefile
+++ b/databases/ruby-postgres/Makefile
@@ -15,7 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/databases/rubygem-postgres/Makefile b/databases/rubygem-postgres/Makefile
index 02df47cec0e8..784f467b5dc6 100644
--- a/databases/rubygem-postgres/Makefile
+++ b/databases/rubygem-postgres/Makefile
@@ -15,7 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index 88ef9e257cc0..366031b5e2b2 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -31,6 +31,8 @@ CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
MAKE_ARGS= VERSION="${PORTVERSION:R}"
INSTALLS_SHLIB= yes
+POSTGRESQL_PORT?= databases/postgresql7
+
.include "${.CURDIR}/Makefile.common"
.if defined(PACKAGE_BUILDING) || defined(BATCH)
@@ -82,7 +84,7 @@ IF_MSQL= "@comment "
.endif
.if defined(WITH_POSTGRESQL) && ${WITH_POSTGRESQL:L} != no
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgresql-prefix="${LOCALBASE}"
IF_POSTGRESQL= ""
.else
diff --git a/databases/zpygresqlda/Makefile b/databases/zpygresqlda/Makefile
index 11f74a7dc557..16bd89930e51 100644
--- a/databases/zpygresqlda/Makefile
+++ b/databases/zpygresqlda/Makefile
@@ -15,8 +15,9 @@ DISTNAME= ZPyGreSQLDA-0.3-rjr2
MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+POSTGRESQL_PORT?= databases/postgresql7
PYTHON_VERSION= python1.5
# You can change this in the environment
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
index 22b233180f77..e59212276486 100644
--- a/dns/bind9-dlz/Makefile
+++ b/dns/bind9-dlz/Makefile
@@ -17,6 +17,7 @@ DISTFILES= bind-${ISCVERSION}.tar.gz \
MAINTAINER= dinoex@FreeBSD.org
+POSTGRESQL_PORT?= databases/postgresql7
MASTER_SITES_DLZ= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bind-dlz/:dlz
@@ -31,7 +32,7 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps
.endif
.if defined(WITH_POSTGRESQL_DRIVER)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-dlz-postgres
.endif
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index 8e6da40bae12..9bb8bf158534 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -56,9 +56,10 @@ LIBDIRS:=${LIBDIRS}:${PREFIX}/lib/mysql
.endif
.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
MODULES:=${MODULES}:mod_sql:mod_sql_postgres
-LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7
-INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
+LIB_DEPENDS+= pq.3:\${PORTSDIR}/${POSTGRESQL_PORT}
+INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include/pgsql
LIBDIRS:=${LIBDIRS}:${PREFIX}/lib
.endif
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 8e6da40bae12..9bb8bf158534 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -56,9 +56,10 @@ LIBDIRS:=${LIBDIRS}:${PREFIX}/lib/mysql
.endif
.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
MODULES:=${MODULES}:mod_sql:mod_sql_postgres
-LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7
-INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
+LIB_DEPENDS+= pq.3:\${PORTSDIR}/${POSTGRESQL_PORT}
+INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include/pgsql
LIBDIRS:=${LIBDIRS}:${PREFIX}/lib
.endif
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index ce422937ecf9..923dbed894c1 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -140,7 +140,7 @@ CONFIGURE_ARGS+= --without-mysql
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql=${PREFIX}
.else
CONFIGURE_ARGS+= --without-pgsql
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index d5b890c5c5dd..35c0f0196a91 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -24,6 +24,8 @@ PKGMESSAGE= ${FILESDIR}/POST-INSTALL-NOTES
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+POSTGRESQL_PORT?= databases/postgresql7
+
# If WITH_EXIMON is defined, the eximon monitor, which requires X,
# will be made a dependency. Note that using WITH_EXIMON will cause
# XFree86 to be installed if it is not present.
@@ -150,7 +152,7 @@ SEDLIST+= -e 's,^\# AUTH_PLAINTEXT=,AUTH_PLAINTEXT=,'
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${LOCALBASE}/lib -lpq,' \
-e 's,XX_PGSQL_INCLUDE_XX,-I${LOCALBASE}/include/pgsql,' \
-e 's,^\# LOOKUP_PGSQL=,LOOKUP_PGSQL=,'
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index e9128a5cf6fd..3b86cccc63e3 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -39,6 +39,8 @@ PKGMESSAGE= ${WRKDIR}/POST-INSTALL-NOTES
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+POSTGRESQL_PORT?= databases/postgresql7
+
# If WITH_EXIMON is defined, the eximon monitor, which requires X,
# will be made a dependency. Note that using WITH_EXIMON will cause
# XFree86 to be installed if it is not present.
@@ -205,7 +207,7 @@ SEDLIST+= -e 's,^\# AUTH_PLAINTEXT=,AUTH_PLAINTEXT=,'
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${LOCALBASE}/lib -lpq,' \
-e 's,XX_PGSQL_INCLUDE_XX,-I${LOCALBASE}/include/pgsql,' \
-e 's,^\# LOOKUP_PGSQL=,LOOKUP_PGSQL=,'
diff --git a/mail/ezmlm-idx/Makefile b/mail/ezmlm-idx/Makefile
index 2887b0821790..2232a42c8034 100644
--- a/mail/ezmlm-idx/Makefile
+++ b/mail/ezmlm-idx/Makefile
@@ -42,7 +42,8 @@ EXTRACT_INCLUDE+= -I${PREFIX}/include/mysql
EXTRACT_LIB+= -L${PREFIX}/lib/mysql -lmysqlclient -lm
.elif defined(WITH_POSTGRESQL)
ALL_TARGET= pgsql it ${LANGUAGE}
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
EXTRACT_INCLUDE+= -I${PREFIX}/include/pgsql
EXTRACT_LIB+= -L${PREFIX}/lib -lpq -lcrypt
.else
diff --git a/mail/horde-imp/Makefile b/mail/horde-imp/Makefile
index d71c04a3b821..cd7294b35e70 100644
--- a/mail/horde-imp/Makefile
+++ b/mail/horde-imp/Makefile
@@ -153,7 +153,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index 850e007e9ae5..46f7c46b9be4 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -63,7 +63,7 @@ pre-install:
# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/horde4-imp/Makefile b/mail/horde4-imp/Makefile
index d71c04a3b821..cd7294b35e70 100644
--- a/mail/horde4-imp/Makefile
+++ b/mail/horde4-imp/Makefile
@@ -153,7 +153,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index 850e007e9ae5..46f7c46b9be4 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -63,7 +63,7 @@ pre-install:
# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/imp/Makefile b/mail/imp/Makefile
index d71c04a3b821..cd7294b35e70 100644
--- a/mail/imp/Makefile
+++ b/mail/imp/Makefile
@@ -153,7 +153,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/imp3/Makefile b/mail/imp3/Makefile
index 1b4206389c69..4345211cea9d 100644
--- a/mail/imp3/Makefile
+++ b/mail/imp3/Makefile
@@ -212,7 +212,7 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/mail/teapop-devel/Makefile b/mail/teapop-devel/Makefile
index d002ae401406..c2fc9446a883 100644
--- a/mail/teapop-devel/Makefile
+++ b/mail/teapop-devel/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.toontown.org/pub/teapop/ \
MAINTAINER= ports@FreeBSD.org
.if defined(WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
.if defined(WITH_MYSQL)
diff --git a/mail/teapop/Makefile b/mail/teapop/Makefile
index d002ae401406..c2fc9446a883 100644
--- a/mail/teapop/Makefile
+++ b/mail/teapop/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.toontown.org/pub/teapop/ \
MAINTAINER= ports@FreeBSD.org
.if defined(WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
.if defined(WITH_MYSQL)
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index 850e007e9ae5..46f7c46b9be4 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -63,7 +63,7 @@ pre-install:
# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
- if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.3" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.1" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
${ECHO_MSG} "" ; \
diff --git a/net/bind9-dlz/Makefile b/net/bind9-dlz/Makefile
index 22b233180f77..e59212276486 100644
--- a/net/bind9-dlz/Makefile
+++ b/net/bind9-dlz/Makefile
@@ -17,6 +17,7 @@ DISTFILES= bind-${ISCVERSION}.tar.gz \
MAINTAINER= dinoex@FreeBSD.org
+POSTGRESQL_PORT?= databases/postgresql7
MASTER_SITES_DLZ= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bind-dlz/:dlz
@@ -31,7 +32,7 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps
.endif
.if defined(WITH_POSTGRESQL_DRIVER)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-dlz-postgres
.endif
diff --git a/security/audit/Makefile b/security/audit/Makefile
index c736c8b045e4..373159f1c374 100644
--- a/security/audit/Makefile
+++ b/security/audit/Makefile
@@ -19,7 +19,8 @@ MAINTAINER= anders@FreeBSD.org
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}beta
diff --git a/security/snort/Makefile b/security/snort/Makefile
index ee09b4d8ec2e..1dccf23e25d8 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -35,7 +35,8 @@ LDFLAGS+= ${PTHREAD_LIBS}
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+=--with-postgresql=${LOCALBASE}/pgsql
.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
LDFLAGS+= -lssl -lcrypto
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index a1bfb77f6ec0..57df1b71100c 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
#USE_AUTOCONF_VER= 252 # not yet
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 0757baeb60d1..6b9760f6eea8 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -42,7 +42,8 @@ CONFIGURE_ARGS+= --enable-charset-guesser
.endif
.if defined(WITH_MNOGO_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
.elif defined(WITH_MNOGO_MSQL)
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index 0757baeb60d1..6b9760f6eea8 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -42,7 +42,8 @@ CONFIGURE_ARGS+= --enable-charset-guesser
.endif
.if defined(WITH_MNOGO_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
.elif defined(WITH_MNOGO_MSQL)
diff --git a/www/twig/Makefile b/www/twig/Makefile
index 11ec64d78a46..e2839141a5d3 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.endif
.if !defined(WITH_MYSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql7
.else
.endif