aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/strongswan/Makefile5
-rw-r--r--security/strongswan/pkg-plist4
2 files changed, 8 insertions, 1 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index 089d49876393..a7dd87435306 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -1,5 +1,6 @@
PORTNAME= strongswan
DISTVERSION= 5.9.6
+PORTREVISION= 1
CATEGORIES= security net-vpn
MASTER_SITES= https://download.strongswan.org/ \
https://download2.strongswan.org/
@@ -38,7 +39,7 @@ CONFIGURE_ARGS= --disable-gmp \
INSTALL_TARGET= install-strip
TEST_TARGET= check
-OPTIONS_DEFINE= CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS \
+OPTIONS_DEFINE= CTR CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS \
EAPSIMFILE FARP GCM IKEV1 IPSECKEY KDF \
KERNELLIBIPSEC LDAP LOADTESTER MEDIATION MYSQL \
PKCS11 PKI PYTHON SCEP SMP SQLITE SWANCTL \
@@ -51,6 +52,7 @@ OPTIONS_SUB= yes
# Description of options
BUILTIN_DESC= Use builtin printf hooks
+CTR_DESC= Enable CTR cipher mode wrapper plugin
CURL_DESC= Enable CURL to fetch CRL/OCSP
EAPAKA3GPP2_DESC= Enable EAP AKA with 3gpp2 backend
EAPDYNAMIC_DESC= Enable EAP dynamic proxy module
@@ -83,6 +85,7 @@ XAUTH_DESC= Enable XAuth password verification
# Extra options
BUILTIN_CONFIGURE_ON= --with-printf-hooks=builtin
+CTR_CONFIGURE_ON= --enable-ctr
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ON= --enable-curl
EAPAKA3GPP2_LIB_DEPENDS= libgmp.so:math/gmp
diff --git a/security/strongswan/pkg-plist b/security/strongswan/pkg-plist
index 44719db43143..b2e8b6cf9f43 100644
--- a/security/strongswan/pkg-plist
+++ b/security/strongswan/pkg-plist
@@ -13,6 +13,7 @@
@sample %%ETCDIR%%.d/charon/cmac.conf.sample
@sample %%ETCDIR%%.d/charon/constraints.conf.sample
@sample %%ETCDIR%%.d/charon/counters.conf.sample
+%%CTR%%@sample %%ETCDIR%%.d/charon/ctr.conf.sample
%%CURL%%@sample %%ETCDIR%%.d/charon/curl.conf.sample
@sample %%ETCDIR%%.d/charon/curve25519.conf.sample
@sample %%ETCDIR%%.d/charon/des.conf.sample
@@ -135,6 +136,8 @@ lib/ipsec/plugins/libstrongswan-constraints.la
lib/ipsec/plugins/libstrongswan-constraints.so
lib/ipsec/plugins/libstrongswan-counters.la
lib/ipsec/plugins/libstrongswan-counters.so
+%%CTR%%lib/ipsec/plugins/libstrongswan-ctr.la
+%%CTR%%lib/ipsec/plugins/libstrongswan-ctr.so
%%CURL%%lib/ipsec/plugins/libstrongswan-curl.la
%%CURL%%lib/ipsec/plugins/libstrongswan-curl.so
lib/ipsec/plugins/libstrongswan-curve25519.la
@@ -349,6 +352,7 @@ sbin/ipsec
%%DATADIR%%/templates/config/plugins/pgp.conf
%%DATADIR%%/templates/config/plugins/pkcs1.conf
%%PKCS11%%%%DATADIR%%/templates/config/plugins/pkcs11.conf
+%%CTR%%%%DATADIR%%/templates/config/plugins/ctr.conf
%%DATADIR%%/templates/config/plugins/pkcs12.conf
%%DATADIR%%/templates/config/plugins/pkcs7.conf
%%DATADIR%%/templates/config/plugins/pkcs8.conf