aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-Backoff/Makefile22
-rw-r--r--devel/p5-Algorithm-Backoff/distinfo3
-rw-r--r--devel/p5-Algorithm-Backoff/pkg-descr3
-rw-r--r--devel/p5-Algorithm-Backoff/pkg-plist16
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 644f338ddc6f..d069fa8879a1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1660,6 +1660,7 @@
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Accounting
SUBDIR += p5-Algorithm-Annotate
+ SUBDIR += p5-Algorithm-Backoff
SUBDIR += p5-Algorithm-Binpack
SUBDIR += p5-Algorithm-Bucketizer
SUBDIR += p5-Algorithm-C3
diff --git a/devel/p5-Algorithm-Backoff/Makefile b/devel/p5-Algorithm-Backoff/Makefile
new file mode 100644
index 000000000000..8fa9529e1e92
--- /dev/null
+++ b/devel/p5-Algorithm-Backoff/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= Algorithm-Backoff
+PORTVERSION= 0.009
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PERLANCAR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Various backoff strategies for retry
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+TEST_DEPENDS= p5-Test-Exception>=0:devel/p5-Test-Exception \
+ p5-Test-Number-Delta>=0:devel/p5-Test-Number-Delta
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-Backoff/distinfo b/devel/p5-Algorithm-Backoff/distinfo
new file mode 100644
index 000000000000..52b6d77daf2e
--- /dev/null
+++ b/devel/p5-Algorithm-Backoff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659585039
+SHA256 (Algorithm-Backoff-0.009.tar.gz) = 9f0ffcdf1e65a88022d6412f46ad977ede5a7b64be663009d13948fe8c9d180b
+SIZE (Algorithm-Backoff-0.009.tar.gz) = 23444
diff --git a/devel/p5-Algorithm-Backoff/pkg-descr b/devel/p5-Algorithm-Backoff/pkg-descr
new file mode 100644
index 000000000000..b29cf7eebcdd
--- /dev/null
+++ b/devel/p5-Algorithm-Backoff/pkg-descr
@@ -0,0 +1,3 @@
+Various backoff strategies for retry
+
+WWW: https://metacpan.org/release/Algorithm-Backoff
diff --git a/devel/p5-Algorithm-Backoff/pkg-plist b/devel/p5-Algorithm-Backoff/pkg-plist
new file mode 100644
index 000000000000..206a8610a52b
--- /dev/null
+++ b/devel/p5-Algorithm-Backoff/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Algorithm/Backoff.pm
+%%SITE_PERL%%/Algorithm/Backoff/Constant.pm
+%%SITE_PERL%%/Algorithm/Backoff/Exponential.pm
+%%SITE_PERL%%/Algorithm/Backoff/Fibonacci.pm
+%%SITE_PERL%%/Algorithm/Backoff/LILD.pm
+%%SITE_PERL%%/Algorithm/Backoff/LIMD.pm
+%%SITE_PERL%%/Algorithm/Backoff/MILD.pm
+%%SITE_PERL%%/Algorithm/Backoff/MIMD.pm
+%%PERL5_MAN3%%/Algorithm::Backoff.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::Constant.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::Exponential.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::Fibonacci.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::LILD.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::LIMD.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::MILD.3.gz
+%%PERL5_MAN3%%/Algorithm::Backoff::MIMD.3.gz