aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/openldap24-server/Makefile7
-rw-r--r--net/openldap25-server/Makefile7
2 files changed, 10 insertions, 4 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index a36363a23d6d..cfe181e3923e 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -34,8 +34,11 @@ LICENSE_NAME= OpenLDAP Public License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS_INSTALL= ${PORTNAME}2[0-3][5-9]-client-* ${PORTNAME}-client-* \
- ${PORTNAME}2[0-3][5-9]-server-* ${PORTNAME}-server-*
+.if defined(CLIENT_ONLY)
+CONFLICTS_INSTALL= ${PORTNAME}2[0-3][5-9]-client-* ${PORTNAME}-client-*
+.else
+CONFLICTS_INSTALL= ${PORTNAME}2[0-3][5-9]-server-* ${PORTNAME}-server-*
+.endif
GNU_CONFIGURE= yes
# :keepla because port uses lt_dlopen
diff --git a/net/openldap25-server/Makefile b/net/openldap25-server/Makefile
index 56cf6d239df2..dc02e97c583b 100644
--- a/net/openldap25-server/Makefile
+++ b/net/openldap25-server/Makefile
@@ -37,8 +37,11 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
# :keepla because port uses lt_dlopen
USES= cpe gmake libtool:keepla localbase ssl tar:tgz
-CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-client-* ${PORTNAME}-client-* \
- ${PORTNAME}2[0-46-9]-server-* ${PORTNAME}-server-*
+.if defined(CLIENT_ONLY)
+CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-client-* ${PORTNAME}-client-*
+.else
+CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-server-* ${PORTNAME}-server-*
+.endif
GNU_CONFIGURE= yes