aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/Makefile1
-rw-r--r--biology/jalview/Makefile31
-rw-r--r--biology/jalview/distinfo3
-rw-r--r--biology/jalview/files/jalview.sh.in7
-rw-r--r--biology/jalview/files/patch-build.xml52
-rw-r--r--biology/jalview/pkg-descr25
-rw-r--r--biology/jalview/pkg-plist18
7 files changed, 137 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 453364cbe0fc..fd9dcda8d631 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -29,6 +29,7 @@
SUBDIR += gperiodic
SUBDIR += grappa
SUBDIR += hmmer
+ SUBDIR += jalview
SUBDIR += kinemage
SUBDIR += lamarc
SUBDIR += libgenome
diff --git a/biology/jalview/Makefile b/biology/jalview/Makefile
new file mode 100644
index 000000000000..9596bb7d00e5
--- /dev/null
+++ b/biology/jalview/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jalview
+# Date created: 11 Jan 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jalview
+PORTVERSION= 2.07
+CATEGORIES= biology java
+MASTER_SITES= http://www.jalview.org/source/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= A viewer and editor for multiple sequence alignments
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+USE_ANT= yes
+ALL_TARGET= makejars
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+SUB_FILES= jalview.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/jalview.sh ${PREFIX}/bin/jalview
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/* ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/biology/jalview/distinfo b/biology/jalview/distinfo
new file mode 100644
index 000000000000..171be1e810a8
--- /dev/null
+++ b/biology/jalview/distinfo
@@ -0,0 +1,3 @@
+MD5 (jalview_2_07.tar.gz) = 48261fc1c2dc011fe8788368c8bf8223
+SHA256 (jalview_2_07.tar.gz) = 2cc6b5ec40cf45b0e8e8048b98eacb14af230db6ed6929b95bec4ce0792a51f7
+SIZE (jalview_2_07.tar.gz) = 8439780
diff --git a/biology/jalview/files/jalview.sh.in b/biology/jalview/files/jalview.sh.in
new file mode 100644
index 000000000000..0444e47656ea
--- /dev/null
+++ b/biology/jalview/files/jalview.sh.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+# Shell script to launch jalview using our javavm wrapper
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -Djava.ext.dirs="%%DATADIR%%" -cp "%%DATADIR%%/jalview.jar" jalview.bin.Jalview
diff --git a/biology/jalview/files/patch-build.xml b/biology/jalview/files/patch-build.xml
new file mode 100644
index 000000000000..d7cd9ab4a814
--- /dev/null
+++ b/biology/jalview/files/patch-build.xml
@@ -0,0 +1,52 @@
+$FreeBSD$
+
+This patch removes the webstart support.
+
+--- build.xml.orig Mon Dec 12 14:57:02 2005
++++ build.xml Fri Jan 27 12:20:52 2006
+@@ -180,6 +180,10 @@
+ </fileset>
+ </copy>
+ <!-- the default keystore details might need to be edited here -->
++<!-- Remove all the remaining stuff for this target
++ which is only necessary if we want to start jalview
++ using java web start. It requires us to generate a key
++ before building the port - Fernan - 27.Jan.2006
+ <signjar
+ storepass="alignmentisfun"
+ keypass="alignmentisfun"
+@@ -194,8 +198,9 @@
+ </fileset>
+ </signjar>
+ <taskdef classpathref="build.classpath" resource="com/roxes/tools/ant/taskdefs.properties"/>
+-
++-->
+ <!-- codebase="http://www.jalview.org/jalview/webstart" -->
++<!--
+ <jnlp toFile="${packageDir}/jalview.jnlp" href="jalview.jnlp"
+ codebase="${WebStartLocation}">
+ <information>
+@@ -206,6 +211,7 @@
+ <description kind="short">Jalview</description>
+ <icon href="logo_big.gif"/>
+ <offline_allowed/>
++-->
+ <!--
+ <association mime-type="application-x/ext-file" extensions="fa"/>
+ <association mime-type="application-x/ext-file" extensions="fasta"/>
+@@ -216,6 +222,7 @@
+ <association mime-type="application-x/ext-file" extensions="aln"/>
+ <association mime-type="application-x/ext-file" extensions="pir"/>
+ -->
++<!--
+ </information>
+ <resources>
+ <j2se version="1.4+"/>
+@@ -234,6 +241,7 @@
+ <all_permissions/>
+ </security>
+ </jnlp>
++-->
+ </target>
+ <target name="runenv" depends="init">
+ <path id="run.classpath">
diff --git a/biology/jalview/pkg-descr b/biology/jalview/pkg-descr
new file mode 100644
index 000000000000..74d38570a4e6
--- /dev/null
+++ b/biology/jalview/pkg-descr
@@ -0,0 +1,25 @@
+Jalview is a multiple alignment editor written in Java. It is used widely in a
+variety of web pages (e.g. the EBI Clustalw server and the Pfam protein domain
+database) and is also available as a general purpose alignment editor.
+
+o Reads and writes alignments in a variety of formats
+o Gaps can be inserted/deleted using the mouse.
+o Group editing (insertion deletion of gaps in groups of sequences).
+o Removal of gapped columns.
+o Align sequences using Web Services (Clustal, Muscle...)
+o Amino acid conservation analysis similar to that of AMAS.
+o Alignment sorting options (by name, tree order, percent identity, group).
+o UPGMA and NJ trees calculated and drawn based on percent identity distances.
+o Sequence clustering using principal component analysis.
+o Removal of redundant sequences.
+o Smith Waterman pairwise alignment of selected sequences.
+o Web based secondary structure prediction programs (JNet).
+o User predefined or custom colour schemes to colour alignments or groups.
+o Sequence feature retrieval and display on the alignment.
+o Print your alignment with colours and annotations.
+o Output alignments as HTML pages, images (PNG) or postscript (EPS).
+
+If you use Jalview in your work, please quote this publication. Clamp, M., et
+al. (2004), The Jalview Java Alignment Editor. Bioinformatics, 12, 426-7
+
+WWW: http://www.jalview.org
diff --git a/biology/jalview/pkg-plist b/biology/jalview/pkg-plist
new file mode 100644
index 000000000000..203369118cda
--- /dev/null
+++ b/biology/jalview/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+bin/jalview
+%%DATADIR%%/activation.jar
+%%DATADIR%%/xercesImpl.jar
+%%DATADIR%%/wsdl4j.jar
+%%DATADIR%%/saaj.jar
+%%DATADIR%%/regex.jar
+%%DATADIR%%/mail.jar
+%%DATADIR%%/log4j-1.2.8.jar
+%%DATADIR%%/jhall.jar
+%%DATADIR%%/jaxrpc.jar
+%%DATADIR%%/jalview.jar
+%%DATADIR%%/commons-logging.jar
+%%DATADIR%%/commons-discovery.jar
+%%DATADIR%%/castor-0.9.6-xml.jar
+%%DATADIR%%/axis.jar
+%%DATADIR%%/xml-apis.jar
+@dirrm %%DATADIR%%