aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LEGAL1
-rw-r--r--net/Makefile1
-rw-r--r--net/cloudflared/Makefile31
-rw-r--r--net/cloudflared/distinfo3
-rw-r--r--net/cloudflared/pkg-descr8
5 files changed, 44 insertions, 0 deletions
diff --git a/LEGAL b/LEGAL
index db2b511379ce..539b482c4ce0 100644
--- a/LEGAL
+++ b/LEGAL
@@ -45,6 +45,7 @@ Browser*.tar.gz net/ldapbrowser No reply from author regarding redistribution
bzip-* archivers/bzip Some algorithms used may infringe certain US patents. Opinions differ. Commercial use could render you liable to unfriendly legal action
citrix_ica-* net/citrix_ica License prohibits redistribution
arcconf-v* sysutils/arcconf May not be redistributed in binary form
+cloudflare-cloudflared* net/cloudflared Not sure if we are allowed to redistribute it.
clustalw-* biology/clustalw No commercial use
consed_linux.tar.gz biology/consed Redistribution is not permitted in any form. You must request access permission via e-mail to get the tarball. Free for academic use.
cos-* java/cos Special conditions apply for commercial use
diff --git a/net/Makefile b/net/Makefile
index 2df181052b37..486b992dc59f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -86,6 +86,7 @@
SUBDIR += clash
SUBDIR += cloud-init
SUBDIR += cloud-init-azure
+ SUBDIR += cloudflared
SUBDIR += clusterit
SUBDIR += cnd
SUBDIR += concourse-fly
diff --git a/net/cloudflared/Makefile b/net/cloudflared/Makefile
new file mode 100644
index 000000000000..84047a791db9
--- /dev/null
+++ b/net/cloudflared/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= cloudflared
+DISTVERSION= 2019.11.0
+CATEGORIES= net www
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Cloudflare's Argo Tunnel client
+
+LICENSE= cloudflare
+LICENSE_NAME= cloudflare
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= no-dist-sell no-pkg-sell
+
+RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
+
+USES= cpe go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= cloudflare
+
+CPE_VENDOR= cloudflare
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= ${GO_PKGNAME}/cmd/cloudflared
+GO_BUILDFLAGS+= -ldflags '-s -w -X main.Version=${PORTVERSION}'
+
+PLIST_FILES= bin/${PORTNAME}
+RESTRICTED= Not sure if we are allowed to redistribute it.
+
+.include <bsd.port.mk>
diff --git a/net/cloudflared/distinfo b/net/cloudflared/distinfo
new file mode 100644
index 000000000000..b5f4bb97ba4e
--- /dev/null
+++ b/net/cloudflared/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1573825365
+SHA256 (cloudflare-cloudflared-2019.11.0_GH0.tar.gz) = ac48a3667f8f697a6bf9d29b4e71efb6aa5d4ee7e39ec64665f4f87f1ad12908
+SIZE (cloudflare-cloudflared-2019.11.0_GH0.tar.gz) = 4672810
diff --git a/net/cloudflared/pkg-descr b/net/cloudflared/pkg-descr
new file mode 100644
index 000000000000..40316fea8c08
--- /dev/null
+++ b/net/cloudflared/pkg-descr
@@ -0,0 +1,8 @@
+cloudflared is the command-line client for Argo Tunnel, a tunneling daemon
+that proxies any local webserver through the cloudflare network.
+
+Argo Tunnel exposes applications running on your local web server, on any
+network with an Internet connection, without adding DNS records or configuring
+a firewall or router. It just works.
+
+WWW: https://developers.cloudflare.com/argo-tunnel/