aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/pear-DoctrineDBAL/Makefile3
-rw-r--r--databases/sqlbuddy/Makefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/databases/pear-DoctrineDBAL/Makefile b/databases/pear-DoctrineDBAL/Makefile
index cad8d44db855..e36c85737f13 100644
--- a/databases/pear-DoctrineDBAL/Makefile
+++ b/databases/pear-DoctrineDBAL/Makefile
@@ -23,11 +23,10 @@ ODBC_DESC= Install PHP DBO driver for ODBC
PGSQL_DESC= Install PHP DBO driver for PostgreSQL
SQLITE_DESC= Install PHP DBO driver for SQLite
-USES= pear
+USES= pear php:cli
PEAR_CHANNEL= doctrine
USE_PHP= pdo
-WANT_PHP_CLI= yes
DBLIB_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:databases/php${PHP_VER}-pdo_dblib
MYSQL_USE= PHP=pdo_mysql
diff --git a/databases/sqlbuddy/Makefile b/databases/sqlbuddy/Makefile
index b8dfd0eb3356..a8b500d63673 100644
--- a/databases/sqlbuddy/Makefile
+++ b/databases/sqlbuddy/Makefile
@@ -19,7 +19,7 @@ GH_TAGNAME= b2cdc2b
NO_BUILD= yes
USE_PHP= ctype pcre session mysql
-WANT_PHP_WEB= yes
+USES= php:web
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message