aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/luaexpat/Makefile14
-rw-r--r--textproc/luaexpat/files/patch-Makefile6
-rw-r--r--textproc/luaexpat/pkg-descr2
3 files changed, 10 insertions, 12 deletions
diff --git a/textproc/luaexpat/Makefile b/textproc/luaexpat/Makefile
index f3febfbaefed..60d656237f77 100644
--- a/textproc/luaexpat/Makefile
+++ b/textproc/luaexpat/Makefile
@@ -4,24 +4,22 @@ PORTNAME= luaexpat
PORTVERSION= 1.3.0
PORTREVISION= 5
CATEGORIES= textproc
-MASTER_SITES= http://matthewwild.co.uk/projects/luaexpat/ \
- http://redundancy.redundancy.org/mirror/
+MASTER_SITES= https://matthewwild.co.uk/projects/luaexpat/
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= SAX XML parser based on Expat library
LICENSE= MIT
LIB_DEPENDS= libexpat.so:textproc/expat2
-USES= lua:module
-USES+= gmake
-ALL_TARGET= lib
+USES= gmake lua:module
+ALL_TARGET= lib
CFLAGS+= -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ARGS+= COMMON_CFLAGS="-Wall"
-MAKE_ENV= LUA_CDIR=${LUA_MODLIBDIR} LUA_LDIR=${LUA_MODSHAREDIR} LUA_INC="-I${LUA_INCDIR}" EXPAT_INC="-I${LOCALBASE}/include"
+MAKE_ARGS= COMMON_CFLAGS="-Wall"
+MAKE_ENV= EXPAT_INC=-I${LOCALBASE}/include LUA_CDIR=${LUA_MODLIBDIR} LUA_INC=-I${LUA_INCDIR} LUA_LDIR=${LUA_MODSHAREDIR}
.include <bsd.port.mk>
diff --git a/textproc/luaexpat/files/patch-Makefile b/textproc/luaexpat/files/patch-Makefile
index f2dc00fab21b..c6f135d16d82 100644
--- a/textproc/luaexpat/files/patch-Makefile
+++ b/textproc/luaexpat/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2014-04-02 16:30:37.000000000 -0700
-+++ Makefile 2014-06-09 16:02:02.000000000 -0700
-@@ -27,8 +27,10 @@
+--- Makefile.orig 2014-04-02 23:30:37 UTC
++++ Makefile
+@@ -27,8 +27,10 @@ src/$(LIBNAME):
$(CC) $(CF) -o $@ src/$(T)lib.c $(LF)
install:
diff --git a/textproc/luaexpat/pkg-descr b/textproc/luaexpat/pkg-descr
index 0629aee6a9d7..322a7b4993a7 100644
--- a/textproc/luaexpat/pkg-descr
+++ b/textproc/luaexpat/pkg-descr
@@ -12,4 +12,4 @@ document chunk. LuaExpat reports parsing events (such as the start and end of
elements) directly to the application through callbacks. The parsing of huge
documents can benefit from this piecemeal operation.
-WWW: http://www.keplerproject.org/luaexpat
+WWW: https://www.keplerproject.org/luaexpat/