aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/firefox/Makefile7
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug168671376
3 files changed, 6 insertions, 83 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 24083f259305..85b7ab212bbc 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,8 +1,7 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 88.0.1
-PORTREVISION= 1
+DISTVERSION= 89.0
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
@@ -13,10 +12,10 @@ MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.26:devel/nspr \
- nss>=3.63:security/nss \
+ nss>=3.64:security/nss \
icu>=67.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=2.7.4:print/harfbuzz \
+ harfbuzz>=2.8.0:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
libvpx>=1.8.2:multimedia/libvpx \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 0c892d9d8dd6..524e7a2c2f81 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620159548
-SHA256 (firefox-88.0.1.source.tar.xz) = 83df1eae0e28fe99661fd5d39d705cdab2e108b4a24ce12c2db6183c632804cc
-SIZE (firefox-88.0.1.source.tar.xz) = 376465316
+TIMESTAMP = 1621929239
+SHA256 (firefox-89.0.source.tar.xz) = 926584209afc12920bf24f8d28e1e186c8ef9bd245376d18a89356f94aadd279
+SIZE (firefox-89.0.source.tar.xz) = 372248708
diff --git a/www/firefox/files/patch-bug1686713 b/www/firefox/files/patch-bug1686713
deleted file mode 100644
index f4e1eb4c0a98..000000000000
--- a/www/firefox/files/patch-bug1686713
+++ /dev/null
@@ -1,76 +0,0 @@
-commit 89e72841a8f5
-Author: Greg V <greg@unrelenting.technology>
-Date: Thu Jan 14 22:16:53 2021 +0000
-
- Bug 1686713 - Fix mozglue/misc/Uptime build on *BSD
----
- mozglue/misc/Uptime.cpp | 28 +++++++++++++++++-----------
- 1 file changed, 17 insertions(+), 11 deletions(-)
-
-diff --git mozglue/misc/Uptime.cpp mozglue/misc/Uptime.cpp
-index bded4017ec13..0e953101994d 100644
---- mozglue/misc/Uptime.cpp
-+++ mozglue/misc/Uptime.cpp
-@@ -43,9 +43,7 @@ Maybe<uint64_t> NowIncludingSuspendMs() {
- return Some(clock_gettime_nsec_np(CLOCK_MONOTONIC_RAW) / kNSperMS);
- }
-
--#endif // macOS
--
--#if defined(XP_WIN)
-+#elif defined(XP_WIN)
-
- // Number of hundreds of nanoseconds in a millisecond
- static constexpr uint64_t kHNSperMS = 10000;
-@@ -77,11 +75,23 @@ Maybe<uint64_t> NowIncludingSuspendMs() {
- pQueryInterruptTime(&interrupt_time);
- return Some(interrupt_time / kHNSperMS);
- }
--#endif // XP_WIN
-
--#if defined(XP_LINUX) // including Android
-+#else
-+
- # include <time.h>
-
-+# ifdef CLOCK_UPTIME // FreeBSD, OpenBSD
-+# define CLOCK_EXCLUDING_SUSPEND CLOCK_UPTIME
-+# else
-+# define CLOCK_EXCLUDING_SUSPEND CLOCK_MONOTONIC
-+# endif
-+
-+# ifdef CLOCK_BOOTTIME // Linux (including Android), OpenBSD (== MONOTONIC)
-+# define CLOCK_INCLUDING_SUSPEND CLOCK_BOOTTIME
-+# else
-+# define CLOCK_INCLUDING_SUSPEND CLOCK_MONOTONIC
-+# endif
-+
- // Number of nanoseconds in a millisecond.
- static constexpr uint64_t kNSperMS = 1000000;
-
-@@ -92,23 +102,19 @@ uint64_t TimespecToMilliseconds(struct timespec aTs) {
- Maybe<uint64_t> NowExcludingSuspendMs() {
- struct timespec ts = {0};
-
-- if (clock_gettime(CLOCK_MONOTONIC, &ts)) {
-+ if (clock_gettime(CLOCK_EXCLUDING_SUSPEND, &ts)) {
- return Nothing();
- }
- return Some(TimespecToMilliseconds(ts));
- }
-
- Maybe<uint64_t> NowIncludingSuspendMs() {
--# ifndef CLOCK_BOOTTIME
-- return Nothing();
--# else
- struct timespec ts = {0};
-
-- if (clock_gettime(CLOCK_BOOTTIME, &ts)) {
-+ if (clock_gettime(CLOCK_INCLUDING_SUSPEND, &ts)) {
- return Nothing();
- }
- return Some(TimespecToMilliseconds(ts));
--# endif
- }
-
- #endif // XP_LINUX