aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pdal/Makefile34
-rw-r--r--math/py-pdal/distinfo3
-rw-r--r--math/py-pdal/pkg-descr8
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index cb00f24395c1..77372a89b1b9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -793,6 +793,7 @@
SUBDIR += py-pandas
SUBDIR += py-pandas-datareader
SUBDIR += py-patsy
+ SUBDIR += py-pdal
SUBDIR += py-permutation
SUBDIR += py-petsc4py
SUBDIR += py-piranha
diff --git a/math/py-pdal/Makefile b/math/py-pdal/Makefile
new file mode 100644
index 000000000000..782859a3ed60
--- /dev/null
+++ b/math/py-pdal/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= pdal
+DISTVERSION= 2.3.3
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
+
+MAINTAINER= lbartoletti@FreeBSD.org
+COMMENT= PDAL Python bindings
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
+ ${LOCALBASE}/bin/cmake:devel/cmake \
+ ${LOCALBASE}/bin/ninja:devel/ninja
+LIB_DEPENDS= libpdal_base.so:math/pdal
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYNUMPY}
+
+USES= python
+USE_PYTHON= autoplist cython distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpdal_plugin_filter_python.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/libpdalpython.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpdal_plugin_reader_numpy.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/math/py-pdal/distinfo b/math/py-pdal/distinfo
new file mode 100644
index 000000000000..adb0b2466de1
--- /dev/null
+++ b/math/py-pdal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595956011
+SHA256 (PDAL-2.3.3.tar.gz) = 04203b65110447b7c305e89f33ec0f3a898b3f464af0c266cc5bccbf8c05d64b
+SIZE (PDAL-2.3.3.tar.gz) = 998382
diff --git a/math/py-pdal/pkg-descr b/math/py-pdal/pkg-descr
new file mode 100644
index 000000000000..2b9d3ad4bfdd
--- /dev/null
+++ b/math/py-pdal/pkg-descr
@@ -0,0 +1,8 @@
+PDAL Python support allows you to process data with PDAL into Numpy arrays.
+It supports embedding Python in PDAL pipelines with the readers.numpy and
+filters.python stages, and it provides a PDAL extension module to control
+Python interaction with PDAL.
+
+Additionally, you can use it to fetch schema and metadata from PDAL operations.
+
+WWW: https://pypi.python.org/pypi/pdal