aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/spdlog/Makefile6
-rw-r--r--devel/spdlog/distinfo6
-rw-r--r--devel/spdlog/files/patch-include_spdlog_common-inl.h11
-rw-r--r--devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h11
4 files changed, 32 insertions, 2 deletions
diff --git a/devel/spdlog/Makefile b/devel/spdlog/Makefile
index 91b5ca949eda..a46be95ea907 100644
--- a/devel/spdlog/Makefile
+++ b/devel/spdlog/Makefile
@@ -3,9 +3,13 @@
PORTNAME= spdlog
DISTVERSIONPREFIX= v
DISTVERSION= 1.8.5
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
+PATCH_SITES= https://github.com/gabime/spdlog/commit/
+PATCHFILES= 7b14a65b2b8cbdca3c6bd1d36fe5b271389c1d07.patch:-p1 \
+ 68111122086187761cca36c24e6d8c8daa96656d.patch:-p1
+
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Super fast C++ logging library
diff --git a/devel/spdlog/distinfo b/devel/spdlog/distinfo
index bf3b9ebcf118..e0dbb0d02aad 100644
--- a/devel/spdlog/distinfo
+++ b/devel/spdlog/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1616997697
+TIMESTAMP = 1624574846
SHA256 (gabime-spdlog-v1.8.5_GH0.tar.gz) = 944d0bd7c763ac721398dca2bb0f3b5ed16f67cef36810ede5061f35a543b4b8
SIZE (gabime-spdlog-v1.8.5_GH0.tar.gz) = 321229
+SHA256 (7b14a65b2b8cbdca3c6bd1d36fe5b271389c1d07.patch) = 5efa9e3b8d4dc4de351dc0e1d2516b2a6e141854e055ae420446785df85d9574
+SIZE (7b14a65b2b8cbdca3c6bd1d36fe5b271389c1d07.patch) = 6523
+SHA256 (68111122086187761cca36c24e6d8c8daa96656d.patch) = a491f1734429203bc298658c1cdc49d1b30b17f8fad6f342511ad1f8692ae666
+SIZE (68111122086187761cca36c24e6d8c8daa96656d.patch) = 753
diff --git a/devel/spdlog/files/patch-include_spdlog_common-inl.h b/devel/spdlog/files/patch-include_spdlog_common-inl.h
new file mode 100644
index 000000000000..0a219ab8ea41
--- /dev/null
+++ b/devel/spdlog/files/patch-include_spdlog_common-inl.h
@@ -0,0 +1,11 @@
+--- include/spdlog/common-inl.h.orig 2021-06-24 13:59:17 UTC
++++ include/spdlog/common-inl.h
+@@ -60,7 +60,7 @@ SPDLOG_INLINE spdlog_ex::spdlog_ex(std::string msg)
+ SPDLOG_INLINE spdlog_ex::spdlog_ex(const std::string &msg, int last_errno)
+ {
+ memory_buf_t outbuf;
+- fmt::format_system_error(outbuf, last_errno, msg);
++ fmt::format_system_error(outbuf, last_errno, msg.c_str());
+ msg_ = fmt::to_string(outbuf);
+ }
+
diff --git a/devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h b/devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h
new file mode 100644
index 000000000000..26f9761a4058
--- /dev/null
+++ b/devel/spdlog/files/patch-include_spdlog_fmt_bin__to__hex.h
@@ -0,0 +1,11 @@
+--- include/spdlog/fmt/bin_to_hex.h.orig 2021-06-24 14:01:22 UTC
++++ include/spdlog/fmt/bin_to_hex.h
+@@ -209,7 +209,7 @@ struct formatter<spdlog::details::dump_info<T>>
+
+ if (put_positions)
+ {
+- fmt::format_to(inserter, "{:<04X}: ", pos);
++ fmt::format_to(inserter, "{:04X}: ", pos);
+ }
+ }
+ };