aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/nghttp2/Makefile2
-rw-r--r--www/nghttp2/distinfo6
-rw-r--r--www/nghttp2/files/patch-src-util.cc20
-rw-r--r--www/nghttp2/files/patch-src-util.h14
4 files changed, 4 insertions, 38 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 177bc7f4d436..680209452960 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -1,7 +1,7 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= nghttp2
-PORTVERSION= 1.45.1
+PORTVERSION= 1.46.0
CATEGORIES= www net
MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index 749abdfcbe55..b770a4fb4486 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1634111660
-SHA256 (nghttp2-1.45.1.tar.xz) = abdc4addccadbc7d89abe27c4d6427d78e57d139f69c1f45749227393c68bf79
-SIZE (nghttp2-1.45.1.tar.xz) = 4017852
+TIMESTAMP = 1635730909
+SHA256 (nghttp2-1.46.0.tar.xz) = 1a68cc4a5732afb735baf50aaac3cb3a6771e49f744bd5db6c49ab5042f12a43
+SIZE (nghttp2-1.46.0.tar.xz) = 4024972
diff --git a/www/nghttp2/files/patch-src-util.cc b/www/nghttp2/files/patch-src-util.cc
deleted file mode 100644
index d28648d1946c..000000000000
--- a/www/nghttp2/files/patch-src-util.cc
+++ /dev/null
@@ -1,20 +0,0 @@
-Obtained from: https://github.com/nghttp2/nghttp2/commit/318e0c8447e2399e7c1e95d8ae8d00118ccea5f7
-
---- src/util.cc.orig 2021-09-21 13:08:54 UTC
-+++ src/util.cc
-@@ -1688,6 +1688,7 @@ int daemonize(int nochdir, int noclose) {
- #endif // !defined(__APPLE__)
- }
-
-+#ifdef ENABLE_HTTP3
- int msghdr_get_local_addr(Address &dest, msghdr *msg, int family) {
- switch (family) {
- case AF_INET:
-@@ -1721,6 +1722,7 @@ int msghdr_get_local_addr(Address &dest, msghdr *msg,
-
- return -1;
- }
-+#endif // ENABLE_HTTP3
-
- } // namespace util
-
diff --git a/www/nghttp2/files/patch-src-util.h b/www/nghttp2/files/patch-src-util.h
deleted file mode 100644
index 39e08a95e54f..000000000000
--- a/www/nghttp2/files/patch-src-util.h
+++ /dev/null
@@ -1,14 +0,0 @@
-Obtained from: https://github.com/nghttp2/nghttp2/commit/318e0c8447e2399e7c1e95d8ae8d00118ccea5f7
-
---- src/util.h.orig 2021-09-21 13:08:54 UTC
-+++ src/util.h
-@@ -916,7 +916,9 @@ std::mt19937 make_mt19937();
- // daemon() using fork().
- int daemonize(int nochdir, int noclose);
-
-+#ifdef ENABLE_HTTP3
- int msghdr_get_local_addr(Address &dest, msghdr *msg, int family);
-+#endif // ENABLE_HTTP3
-
- } // namespace util
-