aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/gamescope/Makefile2
-rw-r--r--x11-wm/gamescope/distinfo6
-rw-r--r--x11-wm/gamescope/files/patch-src_vblankmanager.cpp13
3 files changed, 17 insertions, 4 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index 0fe27cf676ea..1da23f968ff9 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gamescope
-DISTVERSION= 3.11.10
+DISTVERSION= 3.11.11
CATEGORIES= x11-wm
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
diff --git a/x11-wm/gamescope/distinfo b/x11-wm/gamescope/distinfo
index 43421b132073..0705d9f33530 100644
--- a/x11-wm/gamescope/distinfo
+++ b/x11-wm/gamescope/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1644557283
-SHA256 (Plagman-gamescope-3.11.10_GH0.tar.gz) = c353cb9dd310ea74be25ec96104ff1bb065c9672ac11ab014e62c3b4b4ac38f9
-SIZE (Plagman-gamescope-3.11.10_GH0.tar.gz) = 153805
+TIMESTAMP = 1644690252
+SHA256 (Plagman-gamescope-3.11.11_GH0.tar.gz) = 89787d1e1101bcad0009ad7b6ed3f14b9c688c1c1134b59ee62accc54adc93ad
+SIZE (Plagman-gamescope-3.11.11_GH0.tar.gz) = 154436
SHA256 (nothings-stb-af1a5bc_GH0.tar.gz) = 3facf6e6f8c3e1715e1a088f22bad9c9202973f9369fb3f088f46cced3f64058
SIZE (nothings-stb-af1a5bc_GH0.tar.gz) = 1387334
SHA256 (2a84a44f6897.patch) = fd892d4477885926b0ef5793d5222764afa2ba334fd25c4cc671c89812e100b5
diff --git a/x11-wm/gamescope/files/patch-src_vblankmanager.cpp b/x11-wm/gamescope/files/patch-src_vblankmanager.cpp
new file mode 100644
index 000000000000..a7c3e67902df
--- /dev/null
+++ b/x11-wm/gamescope/files/patch-src_vblankmanager.cpp
@@ -0,0 +1,13 @@
+https://github.com/Plagman/gamescope/issues/410
+
+--- src/vblankmanager.cpp.orig 2022-02-12 18:24:12 UTC
++++ src/vblankmanager.cpp
+@@ -282,7 +282,7 @@ void fpslimitThreadRun( void )
+ // Don't roll back before current vblank
+ // based on varying draw time otherwise we can become divergent
+ // if these value change how we do not expect and get stuck in a feedback loop.
+- sleepyTime = std::max( sleepyTime, 0l );
++ sleepyTime = std::max<decltype(sleepyTime)>( sleepyTime, 0 );
+ sleepyTime -= g_uFPSLimiterRedZoneNS;
+ sleepyTime -= g_uVblankDrawBufferRedZoneNS;
+