aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/sane-backends/Makefile24
-rw-r--r--graphics/sane-backends/files/patch-backend__Makefile.in11
-rw-r--r--graphics/sane-backends/pkg-plist171
3 files changed, 141 insertions, 65 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 24192b6a594d..766c13cfafd0 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.17
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://alioth.debian.org/download.php/1347/ \
ftp://ftp.sane-project.org/pub/sane/%SUBDIR%/ \
@@ -26,7 +27,6 @@ OPTIONS= USB "USB support" on \
GPHOTO2 "gPhoto2 support" off
USE_GNOME= gnometarget
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -41,25 +41,33 @@ INSTALLS_SHLIB= yes
.if defined(WITHOUT_USB)
CONFIGURE_ARGS+= --disable-libusb
.else
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-translations
-PLIST_SUB+= NLS="@comment "
+PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.endif
.if defined(WITH_GPHOTO2)
-LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-PLIST_SUB+= GPHOTO2=""
+LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+PLIST_SUB+= GPHOTO2=""
.else
CONFIGURE_ARGS+= --with-gphoto2=no
-PLIST_SUB+= GPHOTO2="@comment "
+PLIST_SUB+= GPHOTO2="@comment "
.endif
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "*** ATTENTION ***"
+ @${ECHO} ""
+ @${ECHO} "Old versions then 1.0.17_1 do not check if you change config files."
+ @${ECHO} "If it's your case, press CTRL+C and copy your config files."
+ @${ECHO} ""
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|= \.\./libtool|= @LIBTOOL@|g'
diff --git a/graphics/sane-backends/files/patch-backend__Makefile.in b/graphics/sane-backends/files/patch-backend__Makefile.in
new file mode 100644
index 000000000000..983f301b8a5b
--- /dev/null
+++ b/graphics/sane-backends/files/patch-backend__Makefile.in
@@ -0,0 +1,11 @@
+--- ./backend/Makefile.in.orig Sun Feb 19 18:30:27 2006
++++ ./backend/Makefile.in Sun Feb 19 18:32:47 2006
+@@ -244,6 +244,8 @@
+ $(INSTALL_DATA) $(srcdir)/$${cfg} $(DESTDIR)$(configdir)/$${cfg} \
+ || exit 1; \
+ fi; \
++ if test ! -d $(DESTDIR)$(configdir)/dist; then $(MKDIR) $(DESTDIR)$(configdir)/dist; fi; \
++ $(INSTALL_DATA) $(srcdir)/$${cfg} $(DESTDIR)$(configdir)/dist/$${cfg} ; \
+ done
+ for dir in $(FIRMWARE_DIRS) ; do \
+ $(MKDIR) $(DESTDIR)$(datadir)/sane/$${dir} ; \
diff --git a/graphics/sane-backends/pkg-plist b/graphics/sane-backends/pkg-plist
index 298c44184f9f..d0356820b1c6 100644
--- a/graphics/sane-backends/pkg-plist
+++ b/graphics/sane-backends/pkg-plist
@@ -2,62 +2,118 @@ bin/gamma4scanimage
bin/sane-config
bin/sane-find-scanner
bin/scanimage
-etc/sane.d/abaton.conf
-etc/sane.d/agfafocus.conf
-etc/sane.d/apple.conf
-etc/sane.d/artec.conf
-etc/sane.d/artec_eplus48u.conf
-etc/sane.d/avision.conf
-etc/sane.d/bh.conf
-etc/sane.d/canon.conf
-etc/sane.d/canon630u.conf
-etc/sane.d/coolscan.conf
-etc/sane.d/coolscan2.conf
-etc/sane.d/dc210.conf
-etc/sane.d/dc240.conf
-etc/sane.d/dc25.conf
-etc/sane.d/dll.conf
-etc/sane.d/dmc.conf
-etc/sane.d/epson.conf
-etc/sane.d/fujitsu.conf
-etc/sane.d/genesys.conf
-%%GPHOTO2%%etc/sane.d/gphoto2.conf
-etc/sane.d/gt68xx.conf
-etc/sane.d/hp.conf
-etc/sane.d/hp4200.conf
-etc/sane.d/hp5400.conf
-etc/sane.d/ibm.conf
-etc/sane.d/leo.conf
-etc/sane.d/lexmark.conf
-etc/sane.d/ma1509.conf
-etc/sane.d/matsushita.conf
-etc/sane.d/microtek.conf
-etc/sane.d/microtek2.conf
-etc/sane.d/mustek.conf
-etc/sane.d/mustek_usb.conf
-etc/sane.d/nec.conf
-etc/sane.d/net.conf
-etc/sane.d/pie.conf
-etc/sane.d/plustek.conf
-etc/sane.d/plustek_pp.conf
-etc/sane.d/ricoh.conf
-etc/sane.d/s9036.conf
-etc/sane.d/saned.conf
-etc/sane.d/sceptre.conf
-etc/sane.d/sharp.conf
-etc/sane.d/sm3840.conf
-etc/sane.d/snapscan.conf
-etc/sane.d/sp15c.conf
-etc/sane.d/st400.conf
-etc/sane.d/tamarack.conf
-etc/sane.d/teco1.conf
-etc/sane.d/teco2.conf
-etc/sane.d/teco3.conf
-etc/sane.d/test.conf
-etc/sane.d/u12.conf
-etc/sane.d/umax.conf
-etc/sane.d/umax1220u.conf
-etc/sane.d/umax_pp.conf
+@unexec if cmp -s %D/etc/sane.d/abaton.conf %D/etc/sane.d/dist/abaton.conf; then rm -f %D/etc/sane.d/abaton.conf; fi
+@unexec if cmp -s %D/etc/sane.d/agfafocus.conf %D/etc/sane.d/dist/agfafocus.conf; then rm -f %D/etc/sane.d/agfafocus.conf; fi
+@unexec if cmp -s %D/etc/sane.d/apple.conf %D/etc/sane.d/dist/apple.conf; then rm -f %D/etc/sane.d/apple.conf; fi
+@unexec if cmp -s %D/etc/sane.d/artec.conf %D/etc/sane.d/dist/artec.conf; then rm -f %D/etc/sane.d/artec.conf; fi
+@unexec if cmp -s %D/etc/sane.d/artec_eplus48u.conf %D/etc/sane.d/dist/artec_eplus48u.conf; then rm -f %D/etc/sane.d/artec_eplus48u.conf; fi
+@unexec if cmp -s %D/etc/sane.d/avision.conf %D/etc/sane.d/dist/avision.conf; then rm -f %D/etc/sane.d/avision.conf; fi
+@unexec if cmp -s %D/etc/sane.d/bh.conf %D/etc/sane.d/dist/bh.conf; then rm -f %D/etc/sane.d/bh.conf; fi
+@unexec if cmp -s %D/etc/sane.d/canon.conf %D/etc/sane.d/dist/canon.conf; then rm -f %D/etc/sane.d/canon.conf; fi
+@unexec if cmp -s %D/etc/sane.d/canon630u.conf %D/etc/sane.d/dist/canon630u.conf; then rm -f %D/etc/sane.d/canon630u.conf; fi
+@unexec if cmp -s %D/etc/sane.d/coolscan.conf %D/etc/sane.d/dist/coolscan.conf; then rm -f %D/etc/sane.d/coolscan.conf; fi
+@unexec if cmp -s %D/etc/sane.d/coolscan2.conf %D/etc/sane.d/dist/coolscan2.conf; then rm -f %D/etc/sane.d/coolscan2.conf; fi
+@unexec if cmp -s %D/etc/sane.d/dc210.conf %D/etc/sane.d/dist/dc210.conf; then rm -f %D/etc/sane.d/dc210.conf; fi
+@unexec if cmp -s %D/etc/sane.d/dc240.conf %D/etc/sane.d/dist/dc240.conf; then rm -f %D/etc/sane.d/dc240.conf; fi
+@unexec if cmp -s %D/etc/sane.d/dc25.conf %D/etc/sane.d/dist/dc25.conf; then rm -f %D/etc/sane.d/dc25.conf; fi
+@unexec if cmp -s %D/etc/sane.d/dll.conf %D/etc/sane.d/dist/dll.conf; then rm -f %D/etc/sane.d/dll.conf; fi
+@unexec if cmp -s %D/etc/sane.d/dmc.conf %D/etc/sane.d/dist/dmc.conf; then rm -f %D/etc/sane.d/dmc.conf; fi
+@unexec if cmp -s %D/etc/sane.d/epson.conf %D/etc/sane.d/dist/epson.conf; then rm -f %D/etc/sane.d/epson.conf; fi
+@unexec if cmp -s %D/etc/sane.d/fujitsu.conf %D/etc/sane.d/dist/fujitsu.conf; then rm -f %D/etc/sane.d/fujitsu.conf; fi
+@unexec if cmp -s %D/etc/sane.d/genesys.conf %D/etc/sane.d/dist/genesys.conf; then rm -f %D/etc/sane.d/genesys.conf; fi
+%%GPHOTO2%%@unexec if cmp -s %D/etc/sane.d/gphoto2.conf %D/etc/sane.d/dist/gphoto2.conf; then rm -f %D/etc/sane.d/gphoto2.conf; fi
+@unexec if cmp -s %D/etc/sane.d/gt68xx.conf %D/etc/sane.d/dist/gt68xx.conf; then rm -f %D/etc/sane.d/gt68xx.conf; fi
+@unexec if cmp -s %D/etc/sane.d/hp.conf %D/etc/sane.d/dist/hp.conf; then rm -f %D/etc/sane.d/hp.conf; fi
+@unexec if cmp -s %D/etc/sane.d/hp4200.conf %D/etc/sane.d/dist/hp4200.conf; then rm -f %D/etc/sane.d/hp4200.conf; fi
+@unexec if cmp -s %D/etc/sane.d/hp5400.conf %D/etc/sane.d/dist/hp5400.conf; then rm -f %D/etc/sane.d/hp5400.conf; fi
+@unexec if cmp -s %D/etc/sane.d/ibm.conf %D/etc/sane.d/dist/ibm.conf; then rm -f %D/etc/sane.d/ibm.conf; fi
+@unexec if cmp -s %D/etc/sane.d/leo.conf %D/etc/sane.d/dist/leo.conf; then rm -f %D/etc/sane.d/leo.conf; fi
+@unexec if cmp -s %D/etc/sane.d/lexmark.conf %D/etc/sane.d/dist/lexmark.conf; then rm -f %D/etc/sane.d/lexmark.conf; fi
+@unexec if cmp -s %D/etc/sane.d/ma1509.conf %D/etc/sane.d/dist/ma1509.conf; then rm -f %D/etc/sane.d/ma1509.conf; fi
+@unexec if cmp -s %D/etc/sane.d/matsushita.conf %D/etc/sane.d/dist/matsushita.conf; then rm -f %D/etc/sane.d/matsushita.conf; fi
+@unexec if cmp -s %D/etc/sane.d/microtek.conf %D/etc/sane.d/dist/microtek.conf; then rm -f %D/etc/sane.d/microtek.conf; fi
+@unexec if cmp -s %D/etc/sane.d/microtek2.conf %D/etc/sane.d/dist/microtek2.conf; then rm -f %D/etc/sane.d/microtek2.conf; fi
+@unexec if cmp -s %D/etc/sane.d/mustek.conf %D/etc/sane.d/dist/mustek.conf; then rm -f %D/etc/sane.d/mustek.conf; fi
+@unexec if cmp -s %D/etc/sane.d/mustek_usb.conf %D/etc/sane.d/dist/mustek_usb.conf; then rm -f %D/etc/sane.d/mustek_usb.conf; fi
+@unexec if cmp -s %D/etc/sane.d/nec.conf %D/etc/sane.d/dist/nec.conf; then rm -f %D/etc/sane.d/nec.conf; fi
+@unexec if cmp -s %D/etc/sane.d/net.conf %D/etc/sane.d/dist/net.conf; then rm -f %D/etc/sane.d/net.conf; fi
+@unexec if cmp -s %D/etc/sane.d/pie.conf %D/etc/sane.d/dist/pie.conf; then rm -f %D/etc/sane.d/pie.conf; fi
+@unexec if cmp -s %D/etc/sane.d/plustek.conf %D/etc/sane.d/dist/plustek.conf; then rm -f %D/etc/sane.d/plustek.conf; fi
+@unexec if cmp -s %D/etc/sane.d/plustek_pp.conf %D/etc/sane.d/dist/plustek_pp.conf; then rm -f %D/etc/sane.d/plustek_pp.conf; fi
+@unexec if cmp -s %D/etc/sane.d/ricoh.conf %D/etc/sane.d/dist/ricoh.conf; then rm -f %D/etc/sane.d/ricoh.conf; fi
+@unexec if cmp -s %D/etc/sane.d/s9036.conf %D/etc/sane.d/dist/s9036.conf; then rm -f %D/etc/sane.d/s9036.conf; fi
+@unexec if cmp -s %D/etc/sane.d/saned.conf %D/etc/sane.d/dist/saned.conf; then rm -f %D/etc/sane.d/saned.conf; fi
+@unexec if cmp -s %D/etc/sane.d/sceptre.conf %D/etc/sane.d/dist/sceptre.conf; then rm -f %D/etc/sane.d/sceptre.conf; fi
+@unexec if cmp -s %D/etc/sane.d/sharp.conf %D/etc/sane.d/dist/sharp.conf; then rm -f %D/etc/sane.d/sharp.conf; fi
+@unexec if cmp -s %D/etc/sane.d/sm3840.conf %D/etc/sane.d/dist/sm3840.conf; then rm -f %D/etc/sane.d/sm3840.conf; fi
+@unexec if cmp -s %D/etc/sane.d/snapscan.conf %D/etc/sane.d/dist/snapscan.conf; then rm -f %D/etc/sane.d/snapscan.conf; fi
+@unexec if cmp -s %D/etc/sane.d/sp15c.conf %D/etc/sane.d/dist/sp15c.conf; then rm -f %D/etc/sane.d/sp15c.conf; fi
+@unexec if cmp -s %D/etc/sane.d/st400.conf %D/etc/sane.d/dist/st400.conf; then rm -f %D/etc/sane.d/st400.conf; fi
+@unexec if cmp -s %D/etc/sane.d/tamarack.conf %D/etc/sane.d/dist/tamarack.conf; then rm -f %D/etc/sane.d/tamarack.conf; fi
+@unexec if cmp -s %D/etc/sane.d/teco1.conf %D/etc/sane.d/dist/teco1.conf; then rm -f %D/etc/sane.d/teco1.conf; fi
+@unexec if cmp -s %D/etc/sane.d/teco2.conf %D/etc/sane.d/dist/teco2.conf; then rm -f %D/etc/sane.d/teco2.conf; fi
+@unexec if cmp -s %D/etc/sane.d/teco3.conf %D/etc/sane.d/dist/teco3.conf; then rm -f %D/etc/sane.d/teco3.conf; fi
+@unexec if cmp -s %D/etc/sane.d/test.conf %D/etc/sane.d/dist/test.conf; then rm -f %D/etc/sane.d/test.conf; fi
+@unexec if cmp -s %D/etc/sane.d/u12.conf %D/etc/sane.d/dist/u12.conf; then rm -f %D/etc/sane.d/u12.conf; fi
+@unexec if cmp -s %D/etc/sane.d/umax.conf %D/etc/sane.d/dist/umax.conf; then rm -f %D/etc/sane.d/umax.conf; fi
+@unexec if cmp -s %D/etc/sane.d/umax1220u.conf %D/etc/sane.d/dist/umax1220u.conf; then rm -f %D/etc/sane.d/umax1220u.conf; fi
+@unexec if cmp -s %D/etc/sane.d/umax_pp.conf %D/etc/sane.d/dist/umax_pp.conf; then rm -f %D/etc/sane.d/umax_pp.conf; fi
+etc/sane.d/dist/abaton.conf
+etc/sane.d/dist/agfafocus.conf
+etc/sane.d/dist/apple.conf
+etc/sane.d/dist/artec.conf
+etc/sane.d/dist/artec_eplus48u.conf
+etc/sane.d/dist/avision.conf
+etc/sane.d/dist/bh.conf
+etc/sane.d/dist/canon.conf
+etc/sane.d/dist/canon630u.conf
+etc/sane.d/dist/coolscan.conf
+etc/sane.d/dist/coolscan2.conf
+etc/sane.d/dist/dc210.conf
+etc/sane.d/dist/dc240.conf
+etc/sane.d/dist/dc25.conf
+etc/sane.d/dist/dll.conf
+etc/sane.d/dist/dmc.conf
+etc/sane.d/dist/epson.conf
+etc/sane.d/dist/fujitsu.conf
+etc/sane.d/dist/genesys.conf
+%%GPHOTO2%%etc/sane.d/dist/gphoto2.conf
+etc/sane.d/dist/gt68xx.conf
+etc/sane.d/dist/hp.conf
+etc/sane.d/dist/hp4200.conf
+etc/sane.d/dist/hp5400.conf
+etc/sane.d/dist/ibm.conf
+etc/sane.d/dist/leo.conf
+etc/sane.d/dist/lexmark.conf
+etc/sane.d/dist/ma1509.conf
+etc/sane.d/dist/matsushita.conf
+etc/sane.d/dist/microtek.conf
+etc/sane.d/dist/microtek2.conf
+etc/sane.d/dist/mustek.conf
+etc/sane.d/dist/mustek_usb.conf
+etc/sane.d/dist/nec.conf
+etc/sane.d/dist/net.conf
+etc/sane.d/dist/pie.conf
+etc/sane.d/dist/plustek.conf
+etc/sane.d/dist/plustek_pp.conf
+etc/sane.d/dist/ricoh.conf
+etc/sane.d/dist/s9036.conf
+etc/sane.d/dist/saned.conf
+etc/sane.d/dist/sceptre.conf
+etc/sane.d/dist/sharp.conf
+etc/sane.d/dist/sm3840.conf
+etc/sane.d/dist/snapscan.conf
+etc/sane.d/dist/sp15c.conf
+etc/sane.d/dist/st400.conf
+etc/sane.d/dist/tamarack.conf
+etc/sane.d/dist/teco1.conf
+etc/sane.d/dist/teco2.conf
+etc/sane.d/dist/teco3.conf
+etc/sane.d/dist/test.conf
+etc/sane.d/dist/u12.conf
+etc/sane.d/dist/umax.conf
+etc/sane.d/dist/umax1220u.conf
+etc/sane.d/dist/umax_pp.conf
include/sane/sane.h
include/sane/saneopts.h
lib/libsane.a
@@ -301,4 +357,5 @@ sbin/saned
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/sane
@dirrm include/sane
-@dirrm etc/sane.d
+@dirrm etc/sane.d/dist
+@dirrmtry etc/sane.d