aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/R-cran-pingr/Makefile20
-rw-r--r--net/R-cran-pingr/distinfo3
-rw-r--r--net/R-cran-pingr/files/patch-src_Makevars5
-rw-r--r--net/R-cran-pingr/files/patch-src_dns.c13
-rw-r--r--net/R-cran-pingr/files/patch-src_rping.c13
-rw-r--r--net/R-cran-pingr/pkg-descr4
7 files changed, 59 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 579c250ba9b4..e47709700d7b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -3,6 +3,7 @@
SUBDIR += 3proxy
SUBDIR += 44bsd-rdist
SUBDIR += 6tunnel
+ SUBDIR += R-cran-pingr
SUBDIR += R-cran-twitteR
SUBDIR += Sockets
SUBDIR += activemq
diff --git a/net/R-cran-pingr/Makefile b/net/R-cran-pingr/Makefile
new file mode 100644
index 000000000000..0a89cb3b0a23
--- /dev/null
+++ b/net/R-cran-pingr/Makefile
@@ -0,0 +1,20 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+
+PORTNAME= pingr
+DISTVERSION= 2.0.1
+CATEGORIES= net
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Check if a Remote Computer is Up
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= R-cran-processx>0:sysutils/R-cran-processx
+TEST_DEPENDS= R-cran-covr>0:devel/R-cran-covr \
+ R-cran-testthat>0:devel/R-cran-testthat
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>
diff --git a/net/R-cran-pingr/distinfo b/net/R-cran-pingr/distinfo
new file mode 100644
index 000000000000..1e16340e1696
--- /dev/null
+++ b/net/R-cran-pingr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1639069503
+SHA256 (pingr_2.0.1.tar.gz) = d49653e705e99ed6ff950d305777ffc18da09b1a79a3091622eeef5df25f7221
+SIZE (pingr_2.0.1.tar.gz) = 16845
diff --git a/net/R-cran-pingr/files/patch-src_Makevars b/net/R-cran-pingr/files/patch-src_Makevars
new file mode 100644
index 000000000000..530e99b645ce
--- /dev/null
+++ b/net/R-cran-pingr/files/patch-src_Makevars
@@ -0,0 +1,5 @@
+--- src/Makevars.orig 2022-01-14 10:24:39 UTC
++++ src/Makevars
+@@ -1 +1 @@
+-PKG_LIBS = -lresolv
++PKG_LIBS =
diff --git a/net/R-cran-pingr/files/patch-src_dns.c b/net/R-cran-pingr/files/patch-src_dns.c
new file mode 100644
index 000000000000..90a6847707d5
--- /dev/null
+++ b/net/R-cran-pingr/files/patch-src_dns.c
@@ -0,0 +1,13 @@
+--- src/dns.c.orig 2022-01-14 08:39:31 UTC
++++ src/dns.c
+@@ -262,6 +262,10 @@ SEXP r_nsl(SEXP hostname, SEXP server, SEXP class, SEX
+
+ #else
+
++#ifdef __FreeBSD__
++#include <netinet/in.h>
++#endif
++
+ #include <resolv.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/net/R-cran-pingr/files/patch-src_rping.c b/net/R-cran-pingr/files/patch-src_rping.c
new file mode 100644
index 000000000000..b78a790d79aa
--- /dev/null
+++ b/net/R-cran-pingr/files/patch-src_rping.c
@@ -0,0 +1,13 @@
+--- src/rping.c.orig 2022-01-14 09:37:12 UTC
++++ src/rping.c
+@@ -5,6 +5,10 @@
+
+ #include "pingr.h"
+
++#ifdef __FreeBSD__
++#include <netinet/in.h>
++#endif
++
+ #ifdef WIN32
+
+ # define WIN32_LEAN_AND_MEAN
diff --git a/net/R-cran-pingr/pkg-descr b/net/R-cran-pingr/pkg-descr
new file mode 100644
index 000000000000..469c0c9b1f1a
--- /dev/null
+++ b/net/R-cran-pingr/pkg-descr
@@ -0,0 +1,4 @@
+Check if a remote computer is up. It can either just call the system ping
+command, or check a specified TCP port.
+
+WWW: https://github.com/r-lib/pingr#readme