aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/exiv2/Makefile6
-rw-r--r--graphics/exiv2/distinfo6
-rw-r--r--graphics/exiv2/files/patch-cmake_compilerFlags.cmake15
-rw-r--r--graphics/exiv2/files/patch-git-01-c069e36605f05e8e58bf964e5ecbde04efb90a2030
-rw-r--r--graphics/exiv2/pkg-plist4
5 files changed, 39 insertions, 22 deletions
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index d343a7ffb3d3..cbc02793bc9d 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -1,7 +1,7 @@
# Created by: Michael Johnson <ahze@ahze.net>
PORTNAME= exiv2
-DISTVERSION= 0.27.3
+DISTVERSION= 0.27.4
DISTVERSIONSUFFIX= -Source
PORTEPOCH= 1
CATEGORIES= graphics
@@ -18,7 +18,7 @@ TEST_DEPENDS= bash:shells/bash
TEST_LIB_DEPENDS= libgtest.so:devel/googletest
USES= cmake compiler:c++11-lang cpe dos2unix gettext-tools pathfix \
- python:3.5+,test localbase:ldflags
+ python:3.6+,test localbase:ldflags
USE_LDCONFIG= yes
DOS2UNIX_FILES= cmake/compilerFlags.cmake
@@ -52,6 +52,8 @@ LDFLAGS_mips64= -lintl
post-patch:
@${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' \
${WRKSRC}/test/Makefile
@${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' \
${WRKSRC}/test/functions.source
diff --git a/graphics/exiv2/distinfo b/graphics/exiv2/distinfo
index d20fd4be455c..7809f5d5e17c 100644
--- a/graphics/exiv2/distinfo
+++ b/graphics/exiv2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593677376
-SHA256 (exiv2-0.27.3-Source.tar.gz) = a79f5613812aa21755d578a297874fb59a85101e793edc64ec2c6bd994e3e778
-SIZE (exiv2-0.27.3-Source.tar.gz) = 26447901
+TIMESTAMP = 1624257042
+SHA256 (exiv2-0.27.4-Source.tar.gz) = 84366dba7c162af9a7603bcd6c16f40fe0e9af294ba2fd2f66ffffb9fbec904e
+SIZE (exiv2-0.27.4-Source.tar.gz) = 32055837
diff --git a/graphics/exiv2/files/patch-cmake_compilerFlags.cmake b/graphics/exiv2/files/patch-cmake_compilerFlags.cmake
deleted file mode 100644
index f7822207c73e..000000000000
--- a/graphics/exiv2/files/patch-cmake_compilerFlags.cmake
+++ /dev/null
@@ -1,15 +0,0 @@
---- cmake/compilerFlags.cmake.orig 2020-07-09 11:24:28 UTC
-+++ cmake/compilerFlags.cmake
-@@ -26,7 +26,11 @@ if ( MINGW OR UNIX OR MSYS ) # MINGW, Linux, APPLE, CY
- # This fails under Fedora, MinGW GCC 8.3.0 and CYGWIN/MSYS 9.3.0
- if (NOT (MINGW OR CMAKE_HOST_SOLARIS OR CYGWIN OR MSYS) )
- if (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 8.0)
-- add_compile_options(-fstack-clash-protection -fcf-protection)
-+ if (NOT (${CMAKE_SYSTEM_PROCESSOR} MATCHES "arm" OR ${CMAKE_SYSTEM_PROCESSOR} MATCHES "powerpc"))
-+ add_compile_options(-fstack-clash-protection -fcf-protection)
-+ else()
-+ add_compile_options(-fstack-clash-protection)
-+ endif()
- endif()
-
- if( (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 5.0) # Not in GCC 4.8
diff --git a/graphics/exiv2/files/patch-git-01-c069e36605f05e8e58bf964e5ecbde04efb90a20 b/graphics/exiv2/files/patch-git-01-c069e36605f05e8e58bf964e5ecbde04efb90a20
new file mode 100644
index 000000000000..0d0ce41dbdfb
--- /dev/null
+++ b/graphics/exiv2/files/patch-git-01-c069e36605f05e8e58bf964e5ecbde04efb90a20
@@ -0,0 +1,30 @@
+From c069e36605f05e8e58bf964e5ecbde04efb90a20 Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Fri, 18 Jun 2021 18:53:46 +0200
+Subject: [PATCH] Fix build with gtest 1.11
+
+INSTANTIATE_TYPED_TEST_CASE_P requires a non-empty prefix now
+---
+ unitTests/test_slice.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/unitTests/test_slice.cpp b/unitTests/test_slice.cpp
+index ccf80d98d..59171cfcf 100644
+--- unitTests/test_slice.cpp
++++ unitTests/test_slice.cpp
+@@ -440,12 +440,12 @@ REGISTER_TYPED_TEST_CASE_P(slice, atAccess, iteratorAccess, constructionFailsFro
+ constMethodsPreserveConst);
+
+ typedef ::testing::Types<const std::vector<int>, std::vector<int>, int*, const int*> test_types_t;
+-INSTANTIATE_TYPED_TEST_CASE_P(, slice, test_types_t);
++INSTANTIATE_TYPED_TEST_CASE_P(slice, slice, test_types_t);
+
+ REGISTER_TYPED_TEST_CASE_P(mutableSlice, iterators, at);
+ typedef ::testing::Types<std::vector<int>, int*> mut_test_types_t;
+-INSTANTIATE_TYPED_TEST_CASE_P(, mutableSlice, mut_test_types_t);
++INSTANTIATE_TYPED_TEST_CASE_P(slice, mutableSlice, mut_test_types_t);
+
+ REGISTER_TYPED_TEST_CASE_P(dataBufSlice, successfulConstruction, failedConstruction);
+ typedef ::testing::Types<DataBuf&, const DataBuf&> data_buf_types_t;
+-INSTANTIATE_TYPED_TEST_CASE_P(, dataBufSlice, data_buf_types_t);
++INSTANTIATE_TYPED_TEST_CASE_P(slice, dataBufSlice, data_buf_types_t);
diff --git a/graphics/exiv2/pkg-plist b/graphics/exiv2/pkg-plist
index aa9767b448b6..66de6e9e58fe 100644
--- a/graphics/exiv2/pkg-plist
+++ b/graphics/exiv2/pkg-plist
@@ -17,7 +17,7 @@ bin/exiv2
%%SAMPLE%%bin/xmpsample
include/exiv2/asfvideo.hpp
include/exiv2/basicio.hpp
-include/exiv2/bigtiffimage.hpp
+include/exiv2/bmffimage.hpp
include/exiv2/bmpimage.hpp
include/exiv2/config.h
include/exiv2/convert.hpp
@@ -69,7 +69,7 @@ lib/cmake/exiv2/exiv2Config-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/exiv2/exiv2Config.cmake
lib/cmake/exiv2/exiv2ConfigVersion.cmake
lib/libexiv2.so
-lib/libexiv2.so.0.27.3
+lib/libexiv2.so.0.27.4
lib/libexiv2.so.27
lib/libexiv2-xmp.a
libdata/pkgconfig/exiv2.pc