aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/gperf.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/gperf.mk')
-rw-r--r--Mk/Uses/gperf.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/Mk/Uses/gperf.mk b/Mk/Uses/gperf.mk
index 3a342ed17f30..abe9932dbf87 100644
--- a/Mk/Uses/gperf.mk
+++ b/Mk/Uses/gperf.mk
@@ -8,24 +8,24 @@
.if !defined(_INCLUDE_USES_GPERF_MK)
_INCLUDE_USES_GPERF_MK= yes
-.if !exists(/usr/bin/gperf)
+. if !exists(/usr/bin/gperf)
BUILD_DEPENDS+= ${LOCALBASE}/bin/gperf:devel/gperf
GPERF= ${LOCALBASE}/bin/gperf
-.else
+. else
_GPERF_VERSION!= /usr/bin/gperf --version | head -1 || true
_GPERF_MAJ_VERSION= ${_GPERF_VERSION:M[0-9].[0-9].[0-9]:C/.*([0-9]).[0-9].[0-9].*/\1/g}
-.if empty(_GPERF_MAJ_VERSION)
+. if empty(_GPERF_MAJ_VERSION)
_GPERF_MAJ_VERSION= 0
-.endif
+. endif
-.if ${_GPERF_MAJ_VERSION} < 3
+. if ${_GPERF_MAJ_VERSION} < 3
BUILD_DEPENDS+= ${LOCALBASE}/bin/gperf:devel/gperf
GPERF= ${LOCALBASE}/bin/gperf
-.else
+. else
GPERF= /usr/bin/gperf
-.endif
-.endif
+. endif
+. endif
CONFIGURE_ENV+= GPERF=${GPERF}
MAKE_ENV+= GPERF=${GPERF}