aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/libtool.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/libtool.mk')
-rw-r--r--Mk/Uses/libtool.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index 0f4c401c0a9a..64a85dfd5b93 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -3,7 +3,13 @@
# Bring libtool scripts up to date.
#
# Feature: libtool
-# Usage: USES=libtool
+# Usage: USES=libtool or USES=libtool:args
+# Valid args: keepla Normally libtool libraries (*.la) are not installed.
+# With this option they are. This is needed as long
+# as there are dependent ports with .la libraries that
+# refer to .la libraries in this port. As soon as all
+# those dependent ports have some form of USES=libtool
+# keepla can be removed.
#
# MAINTAINER: autotools@FreeBSD.org
@@ -54,4 +60,13 @@ patch-libtool:
/versuffix=/s/=.*/="$$major.$$age.$$revision"/; }'
.endif
+patch-lafiles:
+.if ${libtool_ARGS} == keepla || ${libtool_ARGS} == oldver
+ @${FIND} ${STAGEDIR} -type f -name '*.la' | \
+ ${XARGS} ${SED} -i '' -e "/dependency_libs=/s/=.*/=''/"
+.else
+ @${FIND} ${STAGEDIR} -type f -name '*.la' | \
+ ${XARGS} ${GREP} -l 'libtool library' | ${XARGS} ${RM}
+.endif
+
.endif