aboutsummaryrefslogtreecommitdiff
path: root/archivers/arc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/arc/Makefile')
-rw-r--r--archivers/arc/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/archivers/arc/Makefile b/archivers/arc/Makefile
index fad2f9cd8521..e7754045c733 100644
--- a/archivers/arc/Makefile
+++ b/archivers/arc/Makefile
@@ -1,28 +1,36 @@
-# Created by: ache
-
PORTNAME= arc
-PORTVERSION= 5.21p
+PORTVERSION= 5.21q
+PORTREVISION= 1
CATEGORIES= archivers
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= delphij@FreeBSD.org
COMMENT= Create & extract files from DOS .ARC files
+WWW= https://arc.sourceforge.net/
LICENSE= GPLv2
-CONFLICTS= php5-arcanist
+USE_GITHUB= yes
+GH_ACCOUNT= ani6al
+GH_PROJECT= arc
+
+CONFLICTS_INSTALL= arcanist-php[0-9][0-9]
OPTIONS_DEFINE= DOCS
USES= alias cpe
CPE_VENDOR= arc_project
-PLIST_FILES= bin/arc bin/marc man/man1/arc.1.gz
+PLIST_FILES= bin/arc bin/marc share/man/man1/arc.1.gz
PORTDOCS= Arc521.doc
+post-patch:
+.for f in arc.1 marc.1
+ @${REINPLACE_CMD} 's/ 1L / 1 /' ${WRKSRC}/${f}
+.endfor
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arc ${WRKSRC}/marc\
${STAGEDIR}/${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/arc.1 ${STAGEDIR}/${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/arc.1 ${STAGEDIR}/${PREFIX}/share/man/man1
@${MKDIR} ${STAGEDIR}/${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Arc521.doc ${STAGEDIR}/${DOCSDIR}