aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-borgbackup/files/patch-msgpack
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/py-borgbackup/files/patch-msgpack')
-rw-r--r--archivers/py-borgbackup/files/patch-msgpack22
1 files changed, 22 insertions, 0 deletions
diff --git a/archivers/py-borgbackup/files/patch-msgpack b/archivers/py-borgbackup/files/patch-msgpack
new file mode 100644
index 000000000000..8aa640811d82
--- /dev/null
+++ b/archivers/py-borgbackup/files/patch-msgpack
@@ -0,0 +1,22 @@
+--- setup.py.orig 2023-08-31 21:08:57 UTC
++++ setup.py
+@@ -70,7 +70,7 @@ install_requires = [
+ # Please note:
+ # using any other msgpack version is not supported by borg development and
+ # any feedback related to issues caused by this will be ignored.
+- 'msgpack >=0.5.6, <=1.0.5, !=1.0.1',
++ 'msgpack >=0.5.6, <=1.0.6, !=1.0.1',
+ 'packaging',
+ ]
+
+--- src/borg/helpers/msgpack.py.orig 2023-08-31 21:08:57 UTC
++++ src/borg/helpers/msgpack.py
+@@ -182,7 +182,7 @@ def is_slow_msgpack():
+ def is_supported_msgpack():
+ # DO NOT CHANGE OR REMOVE! See also requirements and comments in setup.py.
+ import msgpack
+- return (0, 5, 6) <= msgpack.version <= (1, 0, 5) and \
++ return (0, 5, 6) <= msgpack.version <= (1, 0, 6) and \
+ msgpack.version not in [(1, 0, 1), ] # < add bad releases here to deny list
+
+