aboutsummaryrefslogtreecommitdiff
path: root/archivers/upx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/upx/Makefile')
-rw-r--r--archivers/upx/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/archivers/upx/Makefile b/archivers/upx/Makefile
index b2ce10f6a279..908d7c98b6ea 100644
--- a/archivers/upx/Makefile
+++ b/archivers/upx/Makefile
@@ -1,34 +1,32 @@
-# Created by: Max Khon <fjoe@FreeBSD.org>
-
PORTNAME= upx
-PORTVERSION= 3.96
-DISTVERSIONPREFIX= v
+PORTVERSION= 4.2.3
+MASTER_SITES= https://github.com/upx/upx/releases/download/v${PORTVERSION}/
CATEGORIES= archivers
+DISTVERSIONSUFFIX= -src
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Ultimate Packer for eXecutables
+WWW= https://upx.github.io/ \
+ https://github.com/upx/upx
LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libucl.so:archivers/ucl
-USES= cpe gmake perl5
-USE_PERL5= build
-
-MAKE_ENV= UPX_UCLDIR=${LOCALBASE} \
- target=freebsd
+USES= cmake compiler:c++17-lang cpe tar:xz
-PLIST_FILES= bin/upx \
- man/man1/upx.1.gz
+CMAKE_ON= UPX_CONFIG_DISABLE_BZIP2 \
+ UPX_CONFIG_DISABLE_BZIP2 \
+ UPX_CONFIG_DISABLE_GITREV \
+ UPX_CONFIG_DISABLE_SANITIZE \
+ UPX_CONFIG_DISABLE_SELF_PACK_TEST \
+ UPX_CONFIG_DISABLE_THREADS \
+ UPX_CONFIG_DISABLE_WERROR \
+ UPX_CONFIG_DISABLE_WSTRICT
CPE_VENDOR= upx_project
-GH_TUPLE= upx:upx-lzma-sdk:v${PORTVERSION}:lzma/src/lzma-sdk
-USE_GITHUB= yes
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/upx.out ${STAGEDIR}${PREFIX}/bin/upx
- ${INSTALL_MAN} ${WRKSRC}/doc/upx.1 ${STAGEDIR}${PREFIX}/man/man1
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>