aboutsummaryrefslogtreecommitdiff
path: root/astro/calcmysky/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/calcmysky/Makefile')
-rw-r--r--astro/calcmysky/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/astro/calcmysky/Makefile b/astro/calcmysky/Makefile
new file mode 100644
index 000000000000..1513be58dac6
--- /dev/null
+++ b/astro/calcmysky/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= ${GH_PROJECT:tl}
+PORTVERSION= 0.3.2
+DISTVERSIONPREFIX= v
+CATEGORIES= astro
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Planetary atmosphere light scattering simulator
+WWW= https://github.com/10110111/CalcMySky
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/include/eigen3/Eigen/Dense:math/eigen3 \
+ ${LOCALBASE}/include/glm/glm.hpp:math/glm
+
+USES= cmake:testing localbase qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= 10110111
+GH_PROJECT= CalcMySky
+USE_QT= buildtools:build qmake:build core gui opengl widgets
+
+CMAKE_ARGS= -DQT_VERSION:STRING=5
+
+.include <bsd.port.mk>